Page 11 of 137 FirstFirst ... 9101112132161111 ... LastLast
Results 101 to 110 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #101
    Join Date
    Aug 2005
    Location
    belgium
    Beans
    61
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Mount samba shares with utf8 encoding using cifs

    ok, i don't have firestarter installed, and i turned off the xp firewall.
    now i get:
    Code:
    maarten@craptop:~$ sudo smbtree --authentication-file=/root/.smbcredentials
    WORKGROUP
            \\MAARTEN                       blackbox
    timeout connecting to 10.61.16.155:445
    timeout connecting to 10.61.16.155:139
    Error connecting to 10.61.16.155 (Operation already in progress)
    cli_start_connection: failed to connect to MAARTEN<20> (10.61.16.155)
            \\CRAPTOP
                    \\CRAPTOP\ADMIN$                IPC Service ()
                    \\CRAPTOP\IPC$                  IPC Service ()
                    \\CRAPTOP\MyFiles
                    \\CRAPTOP\print$
    MSHOME
    timeout connecting to 10.91.16.57:445
    timeout connecting to 10.91.16.57:139
    Error connecting to 10.91.16.57 (Operation already in progress)
    cli_start_connection: failed to connect to 10.91.16.57<20> (10.91.16.57)
    timeout connecting to 10.91.16.57:445
    timeout connecting to 10.91.16.57:139
    Error connecting to 10.91.16.57 (Operation already in progress)
    cli_start_connection: failed to connect to PIE<20> (10.91.16.57)
    so this other computer with ip 10.91.16.57 is the one i'm not interested in. my windows pc is 10.61.16.155

  2. #102
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    humm ... well, the problem here is that your windows computer is not allowing the ubuntu machine to authenticate to it. the username and password are getting rejected by your windows computer.

    it should have been necessary to add a new user to your windows machine, and the password for that new user is what you should be using in your smbcredentials file.

    what ip address does the ubuntu computer have?

  3. #103
    Join Date
    Jan 2006
    Location
    US
    Beans
    32
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks for the Howto.

    I can manually mount my MS server 2003 share, however I receive an error "line 9 in /etc/fstab is bad"

    This is what I have in the fstab;

    //rootofevil/files$ /media/music cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777 0 0

    this is what I enter in term and it works;
    sudo mount -t cifs //rootofevil/files$ /media/music -o credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=077

    Thanks for any help.

  4. #104
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    hi!

    you shouldn't be able to mount a share named with a "$". see this post: http://ubuntuforums.org/showpost.php...1&postcount=77

    you said it works when you mount it manually, you might try putting quotes around file$ like so:
    //rootofevil/"files$" /media/music ... but i'm not so sure that should work either.
    Last edited by dmizer; November 30th, 2006 at 11:25 PM.

  5. #105
    Join Date
    Aug 2006
    Location
    Saffrron Walden, UK
    Beans
    140
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Hi I'm trying to access a shared folder on my wireless Window XP laptop and this is what happened. Any help please.

    rob@rob-desktop:~$ sudo cp /etc/fstab /etc/fstab_old
    rob@rob-desktop:~$ sudo nano /etc/fstab
    rob@rob-desktop:~$ sudo mount -a
    mount error: could not find target server. TCP name Laptop/SharedDocs not found
    No ip address specified and hostname not found
    rob@rob-desktop:~$ sudo nano /etc/fstab
    rob@rob-desktop:~$ sudo mount -a
    mount error: could not find target server. TCP name Laptop/SharedDocs not found
    No ip address specified and hostname not found
    rob@rob-desktop:~$

  6. #106
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    post the contents of your fstab file, and post the results of:
    Code:
    smbtree

  7. #107
    Join Date
    Aug 2006
    Location
    Saffrron Walden, UK
    Beans
    140
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/hda1 / ext3 defaults,errors=remount-ro 0 1
    /dev/hda5 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    //Laptop/SharedDocs /media/sharename cifs guest,iocharset=utf8,file_mode=0777,d$



    smbtree appears empty

  8. #108
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    humm ... how about the contents of /etc/nsswitch.conf

    were there errors when you installed winbind?

    have you rebooted since installing winbind?

  9. #109
    Join Date
    Aug 2006
    Location
    Saffrron Walden, UK
    Beans
    140
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.

    passwd: compat
    group: compat
    shadow: compat

    hosts: files dns mdns wins
    networks: files

    protocols: db files
    services: db files
    ethers: db files
    rpc: db files

    netgroup: nis

    evince gnupg kino was kept back during winbird install, yep rebooted. please bare in mind i'm a linux newbiee and out of my depth a bit, so even if really simple i might not have done it. Tried a samba install before and that didn't work either.

  10. #110
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    try this ...
    Code:
    sudo aptitude update
    sudo aptitude upgrade
    sudo aptitude install winbind
    then reboot and see if sambatree shows anything.

    so far, it looks as if you've gotten everything done correctly.

Page 11 of 137 FirstFirst ... 9101112132161111 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •