Page 109 of 137 FirstFirst ... 95999107108109110111119 ... LastLast
Results 1,081 to 1,090 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1081
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by Burky View Post
    Thanks a lot Dmizer! I got it to work, I forgot I had to unshare the folder first before I could change the name.
    Sweet!

  2. #1082
    Join Date
    Jul 2008
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    It may be a firewall interfering.

    Please post the output of the following from both the server and the client:
    Code:
    sudo iptables -L
    Not likely. The server is a Windows XP machine, for one. The Linux machine doesn't have any settings in iptables currently--they're both behind a separate firewall.

    When I mount the share, the Windows permissions seem to behave as expected. In fact, I can write a file to the root of the share as root. For example, sudo touch /path/to/share/test. But no matter what I do, mount would set write permission on the mount point. Very strange.

  3. #1083
    Join Date
    Jul 2008
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by HyugaRicdeau View Post
    Hate to bring this up again, but I'm suddenly having the same problem as dannyboy79.

    I'm trying to mount a few Windows XP shares, but when I perform the mount, the permissions on the mount point itself become "dr-xr-xr-x" no matter what I try.

    I'm using file_mode=744,dir_mode=744, and everything *under* the mount point has the correct modes. Both the mount point and everything under it do have the correct ownership. Specifically, I'm performing the following:
    Code:
    sudo mount -t cifs //NAVI/Code /mnt/smb/navi/code -o rw,iocharset=utf8,credentials=etc/.smbcredentials,file_mode=0744,dir_mode=744,uid=1000,gid=1000
    Basically everything else is as dannyboy79 described. I've done this a bunch of times before, with the same shares, which have not changed recently to my knowledge. But this is on a new server running Jaunty--first time I've used it. I don't know if it's something about Jauny or what, but there's definitely something fishy going on here, and I don't think it's on the windows side. I can interact with the share normally with smbclient.
    I seem to have solved my problem--probably dannyboy79's problem too. mount cifs is paying attention to the readonly flag on the Windows share directory. Apparently it didn't do this with earlier kernel versions, which is why I'm just having this problem now.

    Now, I never intended for those directories to be set read-only. And in fact, they really aren't. So this surprised me. According to Microsoft:

    Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder's Properties dialog box. As a result, Windows Explorer does not allow you to view or change the Read-only or System attributes of folders.
    *sigh* That comes from here: http://support.microsoft.com/kb/326549/

    Using the attrib command to remove the read-only flag solved the problem.

  4. #1084
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    That was a fantastic find! I will update the troubleshooting section of the howto when I get home from work this evening.

    Thank you!

  5. #1085
    Join Date
    Mar 2008
    Beans
    62
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    new problem with a fresh install of karmic;

    I have two shares on the same network drive, one is Public, and has no username/password settings, the other uses a username, but no password.

    I have repeated the steps to get my Jaunty install to connect, but the one using .smbcredentials file access the drive but does not access the folder - i.e I get an empty folder.

    The Public folder works fine.

    Any thoughts?

    David

  6. #1086
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by swatsbiz View Post
    new problem with a fresh install of karmic;

    I have two shares on the same network drive, one is Public, and has no username/password settings, the other uses a username, but no password.

    I have repeated the steps to get my Jaunty install to connect, but the one using .smbcredentials file access the drive but does not access the folder - i.e I get an empty folder.

    The Public folder works fine.

    Any thoughts?

    David
    What does your credentials file look like? Also, please post your /etc/fstab mount lines.

  7. #1087
    Join Date
    Mar 2008
    Beans
    62
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    I've discovered that files I move into the folder stay there and show up when logging into the folder over:

    Places > Network > Windows Network > netbios > folder

    Just nothing shows through the fstab option!

  8. #1088
    Join Date
    Mar 2008
    Beans
    62
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    credentials file looks like:

    username=xxxxxxx
    password=
    password is blank, and work fine like this in Jaunty

    Code:
    //mss-014588/church /media/Church cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,nounix,nobrl,file_mode=0777,dir_mode=0777 0 0
    //mss-014588/Public /media/Public cifs guest,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Last edited by dmizer; October 16th, 2009 at 01:31 AM. Reason: changed to code markup to avoid arbitrary space

  9. #1089
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Try this:
    Code:
    //mss-014588/church /media/Church cifs user=your-username,iocharset=utf8,gid=1000,uid=1000,nounix,nobrl,file_mode=0777,dir_mode=0777 0 0

  10. #1090
    Join Date
    May 2008
    Location
    near Milan, Italy
    Beans
    35
    Distro
    Ubuntu

    Cool Re: Mount samba shares with utf8 encoding using cifs

    I'm having a similar problem:

    my timecapsule has a guest account and I mount it using this one but I cannot see what's inside the storage but files are there because cd works fine and I can even read files if I use the appropriate sw (e.g. mplayer for .mp3) but ls doesn't show anything on the device and even nautilus behaves the same.

    EDIT:

    user=guest doesn't do the job

Page 109 of 137 FirstFirst ... 95999107108109110111119 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •