Page 107 of 137 FirstFirst ... 75797105106107108109117 ... LastLast
Results 1,061 to 1,070 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1061
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Try this and see if it gives us any more information:
    Code:
    sudo mount -v -t cifs //192.168.0.4/My\040Pictures /mnt/winxp_pictures -o credentials=/etc/samba/.smbcredentials,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777
    I'm headed to Korea for a 3 day long business trip. I'll try to check in on my way to the ferry port tomorrow morning, but don't count on anything until Friday.

  2. #1062
    Join Date
    Jan 2008
    Beans
    186

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    That would be "CIFS VFS: Server not responding". There's a fix for that listed in the tutorial under the "Troubleshooting" section.
    Yes right again, that fixed it, thanks for help with all this

  3. #1063
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,100
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Try this and see if it gives us any more information:
    Code:
    sudo mount -v -t cifs //192.168.0.4/My\040Pictures /mnt/winxp_pictures -o credentials=/etc/samba/.smbcredentials,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777
    I'm headed to Korea for a 3 day long business trip. I'll try to check in on my way to the ferry port tomorrow morning, but don't count on anything until Friday.
    thanks for the help thus far. it returned this:

    mount.cifs kernel mount options unc=//192.168.0.4\My040Pictures,user=daniel,pass=notfora nyoneseyes,ver=1,rw,credentials=/etc/samba/.smbcredentials,nounix,iocharset=utf8,file_mode=07 77,dir_mode=0777
    retrying with upper case share name

    mount.cifs kernel mount options unc=//192.168.0.4\MY040PICTURES,user=daniel,pass=mazDA@0 1!,ver=1,rw,credentials=/etc/samba/.smbcredentials,nounix,iocharset=utf8,file_mode=07 77,dir_mode=0777
    mount error(6): No such device or address
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

    yet, smbtree and entering my password returns this (WINXP is 192.168.0.4):
    LINUX
    \\WINXP dans windows computer
    \\WINXP\LexmarkX Lexmark X5400 Series
    \\WINXP\Printer Microsoft XPS Document Writer
    \\WINXP\C$ Default share
    \\WINXP\ADMIN$ Remote Admin
    \\WINXP\My Pictures WINXP Pictures
    \\WINXP\WINXP My Videos
    \\WINXP\I$ Default share
    \\WINXP\print$ Printer Drivers
    \\WINXP\SharedDocs WINXP Shared docs
    \\WINXP\D$ Default share
    \\WINXP\IPC$ Remote IPC
    \\WINXP\daniel
    \\WINXP\xbox_games

    the usernames and password are the same on the windows box as well as the ubuntu machine trying to mount it. ok, i tried
    Code:
    sudo mount -v -t cifs //192.168.0.4/My\ Pictures /mnt/winxp_pictures -o credentials=/etc/samba/.smbcredentials,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777
    and that actually worked but it still isn't writable. see ls -l output:
    dr-xr-xr-x 1 root root 0 2009-08-10 14:32 winxp_pictures

    so without the uid and gid, it's getting mounted with root user and root group. its werid that it just won't mount as writable. I still want to solve this issue but for now, i just moved all my pictures over to the server which is ext3 and i am sharing them out via nfs to linux boxes and samba to windows
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  4. #1064
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    dannyboy79, at this point I'm almost 100% positive that the problem is on the share permissions side of Windows. I'm not sure what is wrong or how to change it, but we've tried just about everything I can think of on the Ubuntu side and we still end up without write permission.

  5. #1065
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,100
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    dannyboy79, at this point I'm almost 100% positive that the problem is on the share permissions side of Windows. I'm not sure what is wrong or how to change it, but we've tried just about everything I can think of on the Ubuntu side and we still end up without write permission.
    i am guessing the same thing but I don't know what else to do. security and sharing is allowing my user FULL CONTROL of the share. what's more weird is the default shared folder in winxp pro isn't even writable over smb. i just moved my pictures over to the file server as that's the machine that is on all the time, but i still can't write to the shared docs folder over smb. very weird. i am not familiar with windows permissions so i really don't know what else to do. i have double and triple checked that it is writable in sharing and security. i don't know what else to try. maybe i'll try to add another group to the machine, and add my username to that group and then give that group write permissions. thanks for trying to help me though.
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  6. #1066
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    What version of XP (and what service pack) are you using?

  7. #1067
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,100
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    What version of XP (and what service pack) are you using?
    win xp pro version 2003 service pack 3
    Check out my Blog about my life and computer software and hardware. http://ubuntuaddicted.blogspot.com/
    My YouTube channel:
    http://www.youtube.com/ubuntuaddicted

  8. #1068
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

  9. #1069
    Join Date
    Sep 2006
    Location
    Canada
    Beans
    52
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Well, I came to this post, found it wasn't really to do with my problem, but couldn't help but keep reading because it was just so comprehensive and well written, and spectacular learning materials. Kudos dmizer! Particularly considering you actually ended up fixing my seemingly unrelated problem!

    Ever since I upgraded to Jaunty, I have been unable to open up TrueCrypt volumes from my Samba server (server is running Hardy). Every time I tried, either the volume was unexplainably read-only, or I would get the error message:
    Code:
    Input/output error:
    /dev/mapper/truecrypt7
    
    The drive is damaged (there is a physical defect on it) or a cable is damaged, or the memory is malfunctioning.
    (etc)
    I noticed the fix regarding troubles opening Open Office files. I hadn't yet had any troubles with Open Office yet, but thought "aw heck, haven't had success with anything else, I should try this". So I added the nobrl option, and unbelievably it fixed my problem!

    Just thought I would let you and your readers know! Thanks again for a great guide!

  10. #1070
    Join Date
    Jul 2008
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Hate to bring this up again, but I'm suddenly having the same problem as dannyboy79.

    I'm trying to mount a few Windows XP shares, but when I perform the mount, the permissions on the mount point itself become "dr-xr-xr-x" no matter what I try.

    I'm using file_mode=744,dir_mode=744, and everything *under* the mount point has the correct modes. Both the mount point and everything under it do have the correct ownership. Specifically, I'm performing the following:
    Code:
    sudo mount -t cifs //NAVI/Code /mnt/smb/navi/code -o rw,iocharset=utf8,credentials=etc/.smbcredentials,file_mode=0744,dir_mode=744,uid=1000,gid=1000
    Basically everything else is as dannyboy79 described. I've done this a bunch of times before, with the same shares, which have not changed recently to my knowledge. But this is on a new server running Jaunty--first time I've used it. I don't know if it's something about Jauny or what, but there's definitely something fishy going on here, and I don't think it's on the windows side. I can interact with the share normally with smbclient.

    Could this have something to do with AppArmor? I'm not very familiar with it...

Page 107 of 137 FirstFirst ... 75797105106107108109117 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •