Page 101 of 137 FirstFirst ... 519199100101102103111 ... LastLast
Results 1,001 to 1,010 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #1001
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Try adding this line to your /etc/fstab file:
    Code:
    //pmde1505/receive /mnt/pmde1505/receive cifs username=*****,password=*****,iocharset=utf8,uid=1000,gid=1000,nounix,file_mode=0555,dir_mode=0555
    and see if that improves things.

  2. #1002
    Join Date
    Sep 2007
    Beans
    29

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Try adding this line to your /etc/fstab file:
    Code:
    //pmde1505/receive /mnt/pmde1505/receive cifs username=*****,password=*****,iocharset=utf8,uid=1000,gid=1000,nounix,file_mode=0555,dir_mode=0555
    and see if that improves things.
    Jammed schedule - may take up to a couple days for me to get this done.

    Will update when completed. Thanks a bunch for your assistance.
    95% switched to Ubuntu
    Hardy 8.04 running on an old Dell Dimension
    House full of Windows boxes for rest of family

  3. #1003
    Join Date
    Jul 2009
    Beans
    1

    Re: Mount samba shares with utf8 encoding using cifs

    Hi,

    I followed all the instructions on the first 2 pages, and I COULD get vim to edit the necessary files on the mounted share. However, and this was frustrating, I could not get Kate or Komodo Editor to edit and save the files - the error was along the lines of no such file or directory.

    I finally found a workaround/solution:
    https://bugs.launchpad.net/ubuntu/+s...28/comments/50

    I was using a Linux box to access a Smb connection on a linux box. I could have used nfsmount, but I have certain restrictions and using CIFS was the fastest and best solution. Once I turned off DFS on the samba server, all was well.

    Not sure if this has already been noted somewhere in this long post, but I hope it helps someone.

  4. #1004
    Join Date
    Sep 2007
    Beans
    29

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by exsysprog View Post
    Jammed schedule - may take up to a couple days for me to get this done.

    Will update when completed. Thanks a bunch for your assistance.
    Experiment results :

    did umount.cifs to unmount the share
    did mount to get list of mounts and confirm that share was unmounted
    modified fstab as described
    did sudo mount -a to reload fstab
    did mount and ls -l /mnt/pmde1505 ... to confirm share was remounted
    all files and directories had read and execute permissions and were owned by me as before, mount shows the share as
    //pmde1505/receive on /mnt/pmde1505/receive type cifs (rw,mand)

    tried to cp an exe file and got same result as before - could not open the file for reading Permission denied.

    This is kinda curious. I feel like I read somewhere about a bug having these properties but I'm not sure and I can't find a reference - I'll keep looking.
    95% switched to Ubuntu
    Hardy 8.04 running on an old Dell Dimension
    House full of Windows boxes for rest of family

  5. #1005
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Just for testing, try changing the file_mode and dir_mode to 777.

  6. #1006
    Join Date
    Sep 2007
    Beans
    29

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Just for testing, try changing the file_mode and dir_mode to 777.

    Test complete. Results unchanged. There must be something simple I'm overlooking.
    95% switched to Ubuntu
    Hardy 8.04 running on an old Dell Dimension
    House full of Windows boxes for rest of family

  7. #1007
    Join Date
    Jul 2009
    Beans
    7
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Mount samba shares with utf8 encoding using cifs

    I'm yet another person having similar problems.
    I just went through the whole set of instructions, and am now stuck with the "mount error(13): Permission denied" problem.
    I'm trying to mount a share from a Buffalo Terastation.

    It (of course) works just fine in the GUI File Browser, but I really need to be able to access it from some command line programs.

  8. #1008
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by exsysprog View Post
    Test complete. Results unchanged. There must be something simple I'm overlooking.
    The only thing left I can think of then is server side. Perhaps a firewall or anti-virus is interfering?

    Otherwise, you may want to open a bug.

    Quote Originally Posted by CasaDelGato View Post
    I'm yet another person having similar problems.
    I just went through the whole set of instructions, and am now stuck with the "mount error(13): Permission denied" problem.
    I'm trying to mount a share from a Buffalo Terastation.

    It (of course) works just fine in the GUI File Browser, but I really need to be able to access it from some command line programs.
    There is a fix for this problem listed in the troubleshooting section.

  9. #1009
    Join Date
    Jul 2009
    Beans
    7
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Mount samba shares with utf8 encoding using cifs

    Already tried adding the "nounix" option.
    Didn't help.

    Couldn't find any mention of the permission denied problem in the referenced thread either.

  10. #1010
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by CasaDelGato View Post
    Already tried adding the "nounix" option.
    Didn't help.

    Couldn't find any mention of the permission denied problem in the referenced thread either.
    Sorry, the reference thread was in the wrong section. I just moved it.

    Try the fix for "Files owned by root."

Page 101 of 137 FirstFirst ... 519199100101102103111 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •