I don't know what my problem is with a manual mount. Still get a mount that is read only to linux user, owned by root 0777, even after I tried the syntax in the trouble shooting section adding my gid and uid. Also tried getting the username and password from .smbcredentials.

This doesn't work:
sudo mount -t cifs //paule6500/elevation /home/paul/elevation -o rw,username=xxxx,password=xxxxx,iocharset=utf8,gid =1000,uid=1000,nounix,file_mode=0777,dir_mode=0777
This doesn't work:
sudo mount -t cifs //paule6500/elevation /home/paul/elevation -o rw,credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,n ounix,file_mode=0777,dir_mode=0777
And now this works doesn't work in fstab:
//paule6500/elevation /home/paul/elevation cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_ mode=0777 0 0
Wait, the problem has been permissions on the Windows side for my test directory (elevation) all this time. I had to give myself full control on windows before I could get a rw samba mount.