Page 250 of 2314 FirstFirst ... 1502002402482492502512522603003507501250 ... LastLast
Results 2,491 to 2,500 of 23132

Thread: Post your .conkyrc files w/ screenshots

  1. #2491
    Join Date
    Jun 2007
    Location
    Jerusalem, IL
    Beans
    106
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Post your .conkyrc files w/ screenshots

    Quote Originally Posted by Kiongku View Post
    After testing, I found out that the actual script for network detection was bugged.
    I could not get that task done in conky itself so I spent some time learning bash script and did my first bash script to detect network.
    From there I called it via conky and set up some rules for conky to detect networks properly. Seems working for now.

    Here updated conky file and the network script
    Attachment 71798
    Attachment 71797

    Any constructive comments are appreciated.
    I'm not sure what bugged in the network detection, but this works for me:
    Code:
    ${color1}${font Eurostile:size=12:bold}${color1}${if_up wlan0}Wi-Fi${else}WIRED${endif}${color3}NETWORK${color1} $stippled_hr ${font}
      ${color0}${if_up eth1}${color0}WIRED: ${alignr 2}${color0}IP address: ${color3}${addr eth1}
      ${color0}Down:${color4} ${downspeed eth1} k/s${color3} ${offset 50}${color0}Up:${color4} ${upspeed eth1} k/s
      ${color3}${downspeedgraph eth1 15,100 f2f2f2 666666} ${color3}${upspeedgraph eth1 15,100 f2f2f2 666666}
      ${else}${alignc}${font sans:size=6:bold}WIRED OFF-LINE${font}${endif}
      ${stippled_hr 1}
      ${color0}${if_up wlan0}${color0}WIRELESS: ${alignr 2}${color0}IP address: ${color3}${addr wlan0}
      ${color0}Down:${color4} ${downspeed wlan0} k/s${color3} ${offset 50}${color0}Up:${color4} ${upspeed wlan0} k/s
      ${color3}${downspeedgraph wlan0 15,100 f2f2f2 666666} ${color3}${upspeedgraph wlan0 15,100 f2f2f2 666666}
      ${color0}Wi-Fi: ${color4} ${wireless_essid wlan0} ${color4} ${wireless_bitrate wlan0} ${color3}${wireless_link_bar 7,75 wlan0} ${color3}${wireless_link_qual_perc wlan0}%
      ${else}${alignc}${font sans:size=6:bold}Wi-Fi  OFF-LINE${font}${endif}
    Attached Images Attached Images
    Last edited by sanus|art; May 28th, 2008 at 02:00 AM. Reason: screenshot added
    Sanus|artificium - FREE VST plug-ins | Music | Web design | Graphics | Sound engineering | Software | Tutorials | PHP scripts and more ...

  2. #2492
    Join Date
    Sep 2007
    Beans
    Hidden!

    Re: Post your .conkyrc files w/ screenshots

    Quote Originally Posted by sanus|art View Post
    I'm not sure what bugged in the network detection, but this works for me:
    Looks good to. Better than some error message.

  3. #2493
    Join Date
    Aug 2006
    Beans
    5

    Re: Post your .conkyrc files w/ screenshots

    Quote Originally Posted by sanus|art View Post
    I'm not sure what bugged in the network detection, but this works for me:
    Code:
    ${color1}${font Eurostile:size=12:bold}${color1}${if_up wlan0}Wi-Fi${else}WIRED${endif}${color3}NETWORK${color1} $stippled_hr ${font}
      ${color0}${if_up eth1}${color0}WIRED: ${alignr 2}${color0}IP address: ${color3}${addr eth1}
      ${color0}Down:${color4} ${downspeed eth1} k/s${color3} ${offset 50}${color0}Up:${color4} ${upspeed eth1} k/s
      ${color3}${downspeedgraph eth1 15,100 f2f2f2 666666} ${color3}${upspeedgraph eth1 15,100 f2f2f2 666666}
      ${else}${alignc}${font sans:size=6:bold}WIRED OFF-LINE${font}${endif}
      ${stippled_hr 1}
      ${color0}${if_up wlan0}${color0}WIRELESS: ${alignr 2}${color0}IP address: ${color3}${addr wlan0}
      ${color0}Down:${color4} ${downspeed wlan0} k/s${color3} ${offset 50}${color0}Up:${color4} ${upspeed wlan0} k/s
      ${color3}${downspeedgraph wlan0 15,100 f2f2f2 666666} ${color3}${upspeedgraph wlan0 15,100 f2f2f2 666666}
      ${color0}Wi-Fi: ${color4} ${wireless_essid wlan0} ${color4} ${wireless_bitrate wlan0} ${color3}${wireless_link_bar 7,75 wlan0} ${color3}${wireless_link_qual_perc wlan0}%
      ${else}${alignc}${font sans:size=6:bold}Wi-Fi  OFF-LINE${font}${endif}
    Well, my first codes were also using if_up.
    Unfortunately even when a network has no ip, the interface is still up and running according to ifconfig.
    Hence the if_up function comes out as true even if the network is down.
    Is it a mistake in my network settings?

  4. #2494
    Join Date
    Jun 2007
    Location
    Jerusalem, IL
    Beans
    106
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Post your .conkyrc files w/ screenshots

    Quote Originally Posted by Kiongku View Post
    Well, my first codes were also using if_up.
    Unfortunately even when a network has no ip, the interface is still up and running according to ifconfig.
    Hence the if_up function comes out as true even if the network is down.
    Is it a mistake in my network settings?
    Are you using some USB modem by any chance?
    Sanus|artificium - FREE VST plug-ins | Music | Web design | Graphics | Sound engineering | Software | Tutorials | PHP scripts and more ...

  5. #2495
    Join Date
    Aug 2006
    Beans
    5

    Re: Post your .conkyrc files w/ screenshots

    Quote Originally Posted by sanus|art View Post
    Are you using some USB modem by any chance?
    No, I'm using a HP laptop.
    So the devices for both ethernet and wireless are integrated.
    lspci command shows the 2 cards.
    Any other clues? thanks

  6. #2496
    Join Date
    Jun 2007
    Location
    Jerusalem, IL
    Beans
    106
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Post your .conkyrc files w/ screenshots

    I'm on HP laptop too. However I use ndiswrapper for wifi and loading the module from the script. As for wired - it is goes up and down with the plug-in/out of a cable.
    Sanus|artificium - FREE VST plug-ins | Music | Web design | Graphics | Sound engineering | Software | Tutorials | PHP scripts and more ...

  7. #2497
    Join Date
    Aug 2006
    Beans
    5

    Re: Post your .conkyrc files w/ screenshots

    I guess something might be wrong with my network setup but oh well.
    I guess I can live with it for now.

  8. #2498
    Join Date
    Apr 2008
    Location
    Stockholm, Sweden
    Beans
    23
    Distro
    Ubuntu Studio 9.04 Jaunty Jackalope

    Re: Post your .conkyrc files w/ screenshots

    I have a problem with my .conkyrc
    If amarok is started before conky there is no problem, everything works fine. Shutting down amarok removes that part from conky on screen and if I restart, it works fine, the amarok part showing up nicely.

    But if Conky is started before Amarok then, when starting Amarok, only part of the amarok-info is shown.

    Someone got any idea what it might be?

    ..and yes I know the code is ugly it's made with copy/paste and some tweaking.



    -------------------------------------------------------------------------

    alignment bottom_right
    maximum_width 200
    background no
    border_width 0
    cpu_avg_samples 2
    draw_borders no
    draw_graph_borders yes
    draw_outline no
    draw_shades no
    use_xft yes
    xftfont HandelGotD:size=8
    xftalpha 0.5
    gap_x 5
    gap_y 0
    minimum_size 5 5
    net_avg_samples 2
    no_buffers yes
    out_to_console no
    own_window yes
    own_window_class Conky
    own_window_type normal
    own_window_transparent yes
    own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
    stippled_borders 0
    update_interval 0.5
    uppercase no
    use_spacer right
    alignment bottom_right
    double_buffer yes

    TEXT
    ${color #6699CC}$hr
    ${font :size=12}${alignc}${color #6699CC}${nodename}$color$font
    ${color #6699CC}$hr
    ${font :size=18}${color #6699CC}${alignc}${time %H:%M}$color$font
    ${font :size=12}${color #6699CC}${alignc}${time %A %d %B %Y}$color$font
    ${font :size=12}${color #6699CC}${alignc}${time V.%V}$color$font
    ${color #6699CC}$hr
    ${voffset -3}$alignc SYSTEM
    ${voffset -7}$hr $color
    ${color #99CCFF}OS:${color #6699CC}${alignr}${execi 100 cat /etc/lsb-release | grep -i "id" | sed -e 's/DISTRIB_ID=//'} ${color #6699CC}${alignr}${execi 100 cat /etc/lsb-release | grep -i "release" | sed -e 's/DISTRIB_RELEASE=//'}
    ${color #99CCFF}Uptime:$alignr ${color #6699CC}$uptime
    ${color #99CCFF}Processes:$alignr ${color #6699CC}$running_processes of $processes
    ${color #6699CC}$hr
    ${color #99CCFF}CPU:
    ${color #6699CC}${alignr}${execi 100 cat /proc/cpuinfo | grep -i "model name" | sed -e 's/model name//' | sed -e 's/://'}

    ${color #99CCFF}CPU 0 Usage:${alignr}${color #6699CC}${cpu cpu0}% ${cpubar cpu0 5,75}
    ${color #99CCFF}CPU 1 Usage:${alignr}${color #6699CC}${cpu cpu1}% ${cpubar cpu1 5,75}
    ${color #99CCFF}CPU 0 Graph: ${color #6699CC}${cpugraph cpu0 20,0 60,0}
    ${color #99CCFF}CPU 1 Graph: ${color #6699CC}${cpugraph cpu1 20,0 60,0}
    ${color #99CCFF}CPU Temperature:${alignr}${color #6699CC}${acpitemp}° C
    ${color #6699CC}$hr
    ${color #99CCFF}RAM Usage: ${alignr}${color #6699CC}${membar 5,75}
    ${alignr}${color #6699CC}$mem of $memmax
    ${color #6699CC}$hr
    ${color #99CCFF}HDD:$alignr ${color #6699CC}${fs_bar 5,75 /}
    ${alignr}${color #6699CC}${fs_used /} of ${fs_size /}
    ${color #6699CC}$hr
    ${voffset -3}$alignc NETWORK
    ${voffset -7}$hr $color
    ${color #99CCFF}Wan IP:${alignr}${color #6699CC}${execi 600 /home/twinned/.scripts/.wan-ip}
    ${color #99CCFF}Local IP:${alignr}${color #6699CC}${addr wlan0}
    ${color #99CCFF}Current Down: ${alignr}${color #6699CC}${downspeed wlan0}kb/s
    ${color #99CCFF}Total Down: ${alignr}${color #6699CC}${totaldown wlan0}
    ${color #99CCFF}Current Up: ${alignr}${color #6699CC}${upspeed wlan0}kb/s

    ${color #99CCFF}Total Up: ${alignr}${color #6699CC}${totalup wlan0}
    ${color #6699CC}$hr
    ${if_running amarokapp}${voffset -3}${alignc}AMAROK
    ${voffset -7}${color #6699CC}$hr
    $alignc Now Playing
    ${color #99CCFF}Artist:${alignr}${color #6699CC}${execi 10 ~/.conky/amarok artist}
    ${color #99CCFF}Song:${alignr}${color #6699CC}${execi 10 ~/.conky/amarok title}
    ${execibar 1 ~/.conky/amarok progress}
    ${color #6699CC}$hr
    ${endif}
    ${color #6699CC}$hr

  9. #2499
    Join Date
    Apr 2007
    Location
    Lancashire, England
    Beans
    87
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Post your .conkyrc files w/ screenshots

    Hi, Read through about 30 pages of this thread and i couldn't find anything related to how to install or configure the temp sensors, Anyone know of a source to show me a step to step guide ?

  10. #2500
    Join Date
    Aug 2005
    Beans
    Hidden!

    Re: Post your .conkyrc files w/ screenshots

    Quote Originally Posted by r5gtt2k3 View Post
    Hi, Read through about 30 pages of this thread and i couldn't find anything related to how to install or configure the temp sensors, Anyone know of a source to show me a step to step guide ?
    Found three posts in this thread regarding lm-sensors.
    http://ubuntuforums.org/showpost.php...postcount=1675
    http://ubuntuforums.org/showpost.php...&postcount=991
    http://ubuntuforums.org/showthread.p...rs#post5049764

    And here is a direct link to a lm-sensors guide.
    http://ubuntuforums.org/showthread.p...ight=lmsensors
    Advantages and Disadvantages of 64bit.(Plus install Guides)

    ‘In search of some small measure of peace, that we all seek, and few of us ever find.’

Page 250 of 2314 FirstFirst ... 1502002402482492502512522603003507501250 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •