Page 13 of 19 FirstFirst ... 31112131415 ... LastLast
Results 121 to 130 of 186

Thread: How to install fonts in Ubuntu?

  1. #121
    Join Date
    Sep 2009
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: How to install fonts in Ubuntu?

    Quote Originally Posted by emiphiste View Post
    I tried using the script, and it looked like it copied the fonts over fine; however, when I opened the GIMP to make sure I had the fonts, they were all defaulted to look like one of the monotypes. This may or may not be a unique issue - just thought I'd let you know (though the most likely reason is that I'm doing something wrong).

    After some research on ubuntuforums.org, I've located a really simple way to install fonts (just to add on to the thread in case you're only looking to install maybe a few fonts at a time).

    1) Download any/all fonts into one location (I'm using /home/"USERNAME"/ttffonts).

    2) Navigate back to your home directory and create a folder called ".fonts". (This directory will disappear from view; don't worry about it, it's still there.)

    3) In terminal, cd to /home/"USERNAME"/ttffonts.

    4) cp all fonts in ttffonts to /home/"USERNAME"/.fonts (The only minor inconvenience about this is that, unlike using the script, you have to type out all fonts by hand - which may suck quite heartily if you're trying to install thousands of fonts from a server.)

    5) Installation complete! (Source: http://ubuntuforums.org/showthread.php?t=263689)


    (By the way, if you can help me get the script to work 100%, that would be awesome. It looks to be a very handy and well-written tool. I thought it might be because I'm using Breezy Badger instead of Dapper - could that be the culprit?)
    Well, I just ended up using this method, after trying both the gksudo nautilus command and the script by mssever.

    Even though there are easier ways, especially when hadling multiple files, I found this one rather simple, though since I'm still a green user, I had some difficulties working it out at first (probably one of the reasons for my nautilus/script issue) but then I saw there were missing some really basic stuff.

    In this example, I set /home/user/Documents as the original font location.

    Code:
    user@user-desktop:~$ sudo su
    root@user-desktop:/home/user# cd /home/user/Documents
    root@user-desktop:/home/user/Documents# cp /home/user/.fonts Font-Name.ttf
    cp: folder omit `/home/user/.fonts'
    root@user-desktop:/home/user/Documents# sudo fc-cache -fv
    Notes: "user" should be your current session's username, "user-desktop" should be your computer's name and "/home/user/Documents" should have "Documents" replaced by the name of the folder containing the fonts to install.

    Hope this turns out to be useful for someone in the future

  2. #122
    Join Date
    Jun 2006
    Location
    Gwangju, Korea
    Beans
    3,479

    Re: How to install fonts in Ubuntu?

    Quote Originally Posted by Catarina View Post
    Well, I just ended up using this method, after trying both the gksudo nautilus command and the script by mssever.

    Even though there are easier ways, especially when hadling multiple files, I found this one rather simple, though since I'm still a green user, I had some difficulties working it out at first (probably one of the reasons for my nautilus/script issue) but then I saw there were missing some really basic stuff.

    In this example, I set /home/user/Documents as the original font location.
    I've cleaned up your script:
    Code:
    $: sudo su # Omit this command. You should only use sudo when you need to be root. (In other words, try doing it first as a normal user.)
    #: cd /home/user/Documents # Or, cd ~/Documents (or ~user/Documents if you want another user's home)
    #: cp /home/user/.fonts Font-Name.ttf # This is backwards, hence the message below from cp.
    cp: folder omit `/home/user/.fonts'
    #: cp *.{ttf,TTF} ~/.fonts #Use this instead. You can modify the wildcard as appropriate.
    #: sudo fc-cache -fv # Because of the first sudo, this sudo is unnecessary.

  3. #123
    Join Date
    Sep 2009
    Beans
    6

    Re: How to install fonts in Ubuntu?

    thinking of trying the solution.only one successful in getting it all right.anyone else?let me try it myself...lets see
    Last edited by stephy123; September 3rd, 2009 at 02:08 PM.

  4. #124
    Join Date
    Mar 2007
    Beans
    646

    Re: How to install fonts in Ubuntu?

    Quote Originally Posted by stephy123 View Post
    thinking of trying the solution.only one successful in getting it all right.anyone else?let me try it myself...lets see
    Try the link in my sig.

  5. #125
    Join Date
    May 2006
    Beans
    Hidden!

    Re: How to install fonts in Ubuntu?

    People. What is all this about shell scripts and whatnot? It's very simple to add fonts to Ubuntu:

    1. Copy your TTF files to ~/.fonts (create the dir if it doesn't exist). Yes, that's .fonts, with a dot.

    2. Open a console and run fc-cache -fv ~/.fonts

    That's ALL.

    Long explanation:

    Font handling in modern Linux systems is delegated to the "fontconfig" package. It's what gives you fc-cache. The system settings are in /etc/fonts but you're better off not touching that. You have a ~/.fonts.conf files which you can tweak (but be warned that System>Preferences>Appearance>Fonts will override it, so write-protect it if you customize it).

    A simple tweak would be to add a <dir>~/multimedia/myfonts</dir> line inside the <fontconfig></fontconfig> block. Or several such entries. It helps if you want to keep you fonts organized in individual dirs. But I for one am perfectly happy throwing them all in ~/.fonts.

    Hope this helps.

  6. #126
    Join Date
    Jan 2006
    Beans
    27

    Re: How to install fonts in Ubuntu?

    I just installed a bunch of ttf fonts by copying them in a folder inside /usr/share/fonts/ (to make them available to all users), gave them the proper permissions and ownership, and ran fc-cache -fv. The fonts installed fine and are available to OpenOffice and other apps.

    But for some weird reason, the default system font has changed to "Segoe Print", one of the fonts I installed.

    When any app tries to display a font and it's not available in my system, it falls back to displaying "Segoe Print".

    When I run OpenOffice Writer, the default font for a new document is now "Segoe Print" as well. I changed this to Arial through Tools->Options->OOoWriter->Basic Fonts, and after a restart, I went there again and clicked the "Default" button, sure enough, the default was again "Segoe Print".

    Uninstalling "Segoe Print" simply sets the next one, "Segoe Script", as default.

    I'm not running Gnome nor gnome-settings-daemon (I use Fluxbox) but the default Gnome UI font is set to Arial. The GTK theme is set to Arial as well.

    I've already checked all the fontconfig files (/etc/fonts/fonts.conf and local.conf). I have no ~/.fonts.conf file.

    Might be related to this bug: https://bugs.launchpad.net/ubuntu/+bug/125949

    Is there some other way to set the default fallback font?

  7. #127
    Join Date
    Sep 2009
    Beans
    1

    Re: How to install fonts in Ubuntu?

    Quote Originally Posted by wirespot View Post
    People. What is all this about shell scripts and whatnot? It's very simple to add fonts to Ubuntu:

    1. Copy your TTF files to ~/.fonts (create the dir if it doesn't exist). Yes, that's .fonts, with a dot.

    2. Open a console and run fc-cache -fv ~/.fonts
    I just ran this in terminal step by step and got it to copy and everything, I run fc-cache and it appears to find the files and succeed to do whatever it does. But the fonts are still unavailable to GIMP and OpenOffice. Can anyone help me out? I didn't do anything with permissions, but I don't have any clue what I would need to change with those to get it working.

  8. #128
    Join Date
    Oct 2009
    Beans
    1

    Re: How to install fonts in Ubuntu?

    I also had this issue. But I found an easy way out. Do the following steps.

    1. copy all new founts to a folder (any folder name)
    2. use the command line terminal to go to the folder.
    3. within the folder type this:
    chmod 644 *.*
    4.go to an existing folder like "thai" as follows:
    cd /usr/share/fonts/truetype/thai
    5. then copy the new fonst to this folder.
    cp /replace with your full folder path/*.* .

    NOTE: DO NOT IGNORE THE LAST DOT IN THE ABOVE COMMAND.

    THAT'S IT. OPEN THE WORD PROCESSOR. THE FONTS ARE THERE.
    Last edited by smr1lk; October 5th, 2009 at 06:05 AM.

  9. #129
    Join Date
    Aug 2009
    Location
    Mississippi, USA
    Beans
    460
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How to install fonts in Ubuntu?

    Quote Originally Posted by Aleksandersen View Post
    Hi,

    I have a .ttf font file here and I am wondering how I install it into the system?
    In you home folder just make a folder called .fonts and drop them in there. That simple.
    Linux User: 380654
    CIW Certified Internet Web Professional: 435668

  10. #130
    Join Date
    Oct 2009
    Beans
    3

    Re: How to install fonts in Ubuntu?

    You can still drag and drop to install fonts using a different folder: .fonts in your home folder. This folder may not exist by default. Open your home folder in the file browser, and select View->Show Hidden Files. If you can’t find the .fonts folder, create it.
    You can copy any TTF font file into this folder and it will become available immediately to applications after they are restarted. You can get TTF fonts from the Internet, or even a Windows system.
    ____________________________________________
    business opportunity directory humor blog

Page 13 of 19 FirstFirst ... 31112131415 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •