Page 2 of 18 FirstFirst 123412 ... LastLast
Results 11 to 20 of 180

Thread: HowTo: Disable Synaptics Touchpad While Typing

  1. #11
    Join Date
    Jul 2005
    Beans
    366

    Re: HowTo: Disable Synaptics Touchpad While Typing

    This method was more convenient for me:

    To disable the touchpad:

    Code:
    synclient TouchpadOff=1
    To enable the touchpad:

    Code:
    synclient TouchpadOff=0

    And: you can put each on a launcher in your desktop. The result works pretty neat in my case. If you are at your desk with a mouse, or typing, just disable the touchpad.

  2. #12
    Join Date
    Nov 2005
    Beans
    127
    Distro
    Ubuntu 5.10

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Brilliant! Thank you very much for the how to!

  3. #13
    Join Date
    Jan 2007
    Beans
    3

    Re: HowTo: Disable Synaptics Touchpad While Typing

    hello!

    i did, but takes no effect....
    i can run syndaemon is terminal, and it says enable/disable, but takes no effect

  4. #14
    Join Date
    Nov 2006
    Beans
    111

    Re: HowTo: Disable Synaptics Touchpad While Typing

    What is SHMCONFIG and how do I turn it on?

  5. #15
    Join Date
    Jun 2006
    Location
    A galaxy far, far away...
    Beans
    2,800

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Quote Originally Posted by tee2 View Post
    What is SHMCONFIG and how do I turn it on?
    SHMConfig is what lets applications configure your touchpad while the XServer is running. To turn it on, open a terminal and type
    Code:
    gksudo gedit /etc/X11/xorg.conf
    Now find the section that starts with this:
    Code:
    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    And add this line inside that section:
    Code:
    Option "SHMConfig" "on"
    Save the file, then reboot the computer.
    "Whoever said sunshine brings happiness has never danced in the rain." - K. Jackson
    Exaile Media Player | Arch Linux
    Click here to have your brain eaten

  6. #16
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu 6.10 Edgy

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Very useful and simple.

    Thank you very much.

  7. #17
    Join Date
    Feb 2007
    Beans
    29

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Hey,

    Great guide. One problem though for my xorg.conf file there is no where that says "Synaptics Touchpad" for me it says the following

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Any ideas why I dont have a Synaptics Touchpad?

  8. #18
    Join Date
    Aug 2006
    Location
    Hong Kong or Northern NM
    Beans
    322
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Wow! This was an excellent howto that solved a really irritating problem.

    Thank you!

  9. #19
    Join Date
    Aug 2006
    Location
    Hong Kong or Northern NM
    Beans
    322
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Osofast,

    There are several input devices, each with a different "Identifier". Open your xorg.conf again and keep scrolling through the input devieces until you find the touchpad.

  10. #20
    Join Date
    Feb 2007
    Beans
    29

    Re: HowTo: Disable Synaptics Touchpad While Typing

    lol thanks for making me look like an idiot.

    Just kidding, I really appreciate the help, thanks

Page 2 of 18 FirstFirst 123412 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •