Page 12 of 18 FirstFirst ... 21011121314 ... LastLast
Results 111 to 120 of 180

Thread: HowTo: Disable Synaptics Touchpad While Typing

  1. #111
    Join Date
    Jun 2006
    Location
    A galaxy far, far away...
    Beans
    2,800

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Quote Originally Posted by wladicus View Post
    Hi reacocard: I tried all of what you said but it is not working for me. I am running Kubuntu and but my laptop's touchpad is NOT a Synaptics touchpad. I wonder if that is why this does not work for me?
    I created file syndaemon.sh in the Autostart folder and rebooted but it is not working for me. I put the following two code lines into the file:
    -----------------------
    File: syndaemon.sh
    -----------------------
    #!/bin/sh
    syndaemon -i 5 -d
    -----------------------
    I also did a chmod a+x syndaemon.sh to make it executable. I really am a novice at this...have been using Linux for about 2 weeks now, so I am guessing at most of this.
    Did I write the file correctly? Is it NOT working because the laptop does not have a Synaptics touchpad?
    walt
    Did you enable SHMConfig? without that syndaemon can't do anything.
    "Whoever said sunshine brings happiness has never danced in the rain." - K. Jackson
    Exaile Media Player | Arch Linux
    Click here to have your brain eaten

  2. #112
    Join Date
    Sep 2008
    Location
    St. Thomas, ON, Canada
    Beans
    33
    Distro
    Ubuntu

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Hi reaocard,
    Quote Originally Posted by reacocard View Post
    Did you enable SHMConfig? without that syndaemon can't do anything.
    Yes, I did enable SHMConfig with [Option "SHMConfig" "on"] and still no go.
    [_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
    walt
    St. Thomas, Ontario = 42.77°N, 81.11°W =
    RASC: Royal Astronomical Society of Canada
    Last edited by wladicus; September 17th, 2008 at 12:51 AM.

  3. #113
    Join Date
    Sep 2008
    Location
    St. Thomas, ON, Canada
    Beans
    33
    Distro
    Ubuntu

    Re: HowTo: Disable Synaptics Touchpad While Typing

    If anybody knows what these exerpts from the Xorg.O.log file mean in terms of solving the touchpad annoyance then please help. I noticed that the log reports that my laptop has no Synaptics touchpad.
    Xorg.O.log.txt
    [_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
    walt
    St. Thomas, Ontario = 42.77°N, 81.11°W =
    RASC: Royal Astronomical Society of Canada
    Last edited by wladicus; September 17th, 2008 at 12:51 AM.

  4. #114
    Join Date
    Feb 2007
    Beans
    641
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Thanks to all of you. I was seriously considering cellotaping all over the touchpad because it was driving me crazy...

    One thing which would be great would be if there was a way to configure the laptop so that plugging in a mouse automatically disables the touchpad completely. Anyone knows a way to do this, please?

    synclient TouchpadOff=1
    and
    synclient TouchpadOff=0

    Are a great substitude, though, it's really nice to be able to control the thing even if I have to type these commands each time.

    Mariane
    Last edited by Mariane; September 11th, 2008 at 09:44 PM.

  5. #115
    Join Date
    Sep 2008
    Location
    St. Thomas, ON, Canada
    Beans
    33
    Distro
    Ubuntu

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Quote Originally Posted by Mariane View Post
    synclient TouchpadOff=1
    and
    synclient TouchpadOff=0
    Are a great substitute...
    Mariane
    Thank you Mariane for the contribution, but as I have said many times in many threads, I have already tried all the basic suggestions, including the one you just mentioned and about 3 or 4 different variations of that including an automated file that should have taken care of everything on boot-up. Alas, nothing seems to work! The Kubuntu development team did not make it on this one. I hope they improve on development of these kind of 'basics'.
    Thank you,
    walt
    _/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
    walt
    St. Thomas, Ontario = 42.77°N, 81.11°W =
    http://wladicus.blogspot.ca/

  6. #116
    Join Date
    Sep 2008
    Location
    St. Thomas, ON, Canada
    Beans
    33
    Distro
    Ubuntu

    SOLVED * FINALLY * Re: HowTo: Disable Synaptics Touchpad While Typing

    From a terminal enter the following code:
    To disable the Touchpad -
    Code:
    sudo rmmod psmouse
    To re-enable a disabled Touchpad -
    Code:
    sudo modprobe psmouse
    I suppose this can be automated in a file somehow or even attached to a function key probably if someone has the knowhow.
    I received this solution from the following link:
    http://ubuntuforums.org/showpost.php...9&postcount=13

    I managed to work out a detailed HOW TO for setting up a shortcut key version of this can be found in the last post at the following link:
    Last edited by wladicus; September 21st, 2008 at 03:49 AM. Reason: Added link to HOW TO on setting up a shortcut key version.
    _/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
    walt
    St. Thomas, Ontario = 42.77°N, 81.11°W =
    http://wladicus.blogspot.ca/

  7. #117
    Join Date
    Sep 2007
    Beans
    54
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Great tutorial, I used to do this on my older Dell laptop. Now, I have a FN + <Function> key combo I can press to turn off my touchpad. Its on my Acer Aspire.

    Bb

  8. #118
    Join Date
    Aug 2006
    Beans
    69
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Is there a way to achieve this in Intrepid Ibex?
    You can't put SHMConfig in xorg.conf, since it doesn't have any entries. You can't use gsynaptics or syndaemon either because it says you don't have shared memory turned on. Why can't they fix this once and for all with simple gui?

  9. #119
    Join Date
    Nov 2007
    Beans
    101

    Re: HowTo: Disable Synaptics Touchpad While Typing

    intrepid 64bit laptop

    This is my xorg.conf, as you see, i might have a problem, cuz I can't see a section synaptic, I search this thread but I didnt get a real answer
    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	DefaultDepth	24
    EndSection
    
    Section "Module"
    	Load	"glx"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver	"fglrx"
    EndSection
    ASUS F8P
    C2D T8100 3GB ram
    Radeon HD2400 256MB fixed up to 1534MB shared
    Ubuntu 8.10 64bit eyecandied to the bone, 8.04 32bit Vista home premium

  10. #120
    Join Date
    Nov 2007
    Beans
    101

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Bump
    ASUS F8P
    C2D T8100 3GB ram
    Radeon HD2400 256MB fixed up to 1534MB shared
    Ubuntu 8.10 64bit eyecandied to the bone, 8.04 32bit Vista home premium

Page 12 of 18 FirstFirst ... 21011121314 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •