Page 10 of 18 FirstFirst ... 89101112 ... LastLast
Results 91 to 100 of 180

Thread: HowTo: Disable Synaptics Touchpad While Typing

  1. #91
    Join Date
    Oct 2006
    Beans
    93

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Hi reacocard,

    Yes, I forgot to mention that I tried rebooting and also tried using CTRL-ALT-BS (control alt backspace) which restarts X11. So I'm thinking that either this hardware is misidentified as a Synaptics -- or there's a syntax problem in xorg.conf, but I can't find it.

  2. #92
    Join Date
    Jun 2006
    Location
    A galaxy far, far away...
    Beans
    2,800

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Quote Originally Posted by DantePasquale View Post
    Hi reacocard,

    Yes, I forgot to mention that I tried rebooting and also tried using CTRL-ALT-BS (control alt backspace) which restarts X11. So I'm thinking that either this hardware is misidentified as a Synaptics -- or there's a syntax problem in xorg.conf, but I can't find it.
    I just looked at your post again, and saw you're running synclient with sudo. That shouldn't be necessary, try it again without the sudo, perhaps that was the problem.
    "Whoever said sunshine brings happiness has never danced in the rain." - K. Jackson
    Exaile Media Player | Arch Linux
    Click here to have your brain eaten

  3. #93
    Join Date
    Oct 2006
    Beans
    93

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Hi, same results using sudo or not. I thought I'd try sudo in case there was something restricted about accessing the memory, but it didn't matter. Any more ideas?

  4. #94
    Join Date
    May 2008
    Beans
    3

    Re: HowTo: Disable Synaptics Touchpad While Typing

    Thank you. I am on Kubuntu and with a little playing around with Autostart folder I have been able to do it.


  5. #95
    Join Date
    Apr 2008
    Beans
    81
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HowTo: Disable Synaptics Touchpad While Typing

    This tutorial is amazing!! Thank you so much

  6. #96
    Join Date
    Jan 2007
    Beans
    162

    Re: HowTo: Disable Synaptics Touchpad While Typing

    I have been researching this problem since installing Hardy. I have done all the things suggested regarding

    xorg.conf

    syndaemon

    synclient

    and System -> Preference -> Mouse, Go to Touchpad tab, uncheck "Enable Touchpad"

    None of this has any effect on my touchpad, much less making it work better while typing (also, vertical scrolling does not work even though in xorg.conf it says it's enabled).

    The only software that modifies the touchpad behavior is Mousetweaks pointer capture. That is sort of inconvenient, though, to have to take my hands from the home position.

    Any ideas? I would love it if I could get syndaemon working (the following has no effect, even though it shows "Disable").

    Code:
    $ syndaemon -i 3 -t -K
    eeDisable
    Enable
    Here is part of my xorg.conf, just for reference.

    Code:
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"		"/dev/psaux"
    	Option		"Protocol"		"auto-dev"
    	Option		"HorizEdgeScroll"	"0"
    	Option		"VertEdgeScroll"	"1"
    	Option		"SHMConfig"		"on"
    #	Option		"MaxTapTime"		"0"
    EndSection
    This is the thread I started for this issue: http://ubuntuforums.org/showthread.php?t=812128. I'll be looking back here, though, since this thread has so much activity.
    Last edited by raequin; May 31st, 2008 at 07:04 AM.

  7. #97
    Join Date
    Jun 2007
    Location
    West Indies
    Beans
    148
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HowTo: Disable Synaptics Touchpad While Typing

    many thanks my friend for this fantastic tutorial

  8. #98
    Join Date
    May 2008
    Beans
    22

    Re: HowTo: Disable Synaptics Touchpad While Typing

    i wish someone could make a little script so that the mouse doesn't "click" so often, too

    aside from distinguishing the pressure of the stubbier palm and the pointier finger, i think there should be a way to distinguish when the pointer is moving compared to a quick tap to click.

    This is what i mean: I don't have a very sensitive touchpad. I often do short burst of strokes so that i can get across the screen faster. but the problem with this in ubuntu is that it registers as a tap. I went over to windows to compare how the Synaptics driver works there, and it doesn't tap whenever the pointer position is not in the same spot. I have to tap in the same spot for it to register a click. This is something i don't think the Synaptics driver in ubuntu does, which really annoys me

  9. #99
    Join Date
    May 2008
    Location
    Down Under
    Beans
    225
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HowTo: Disable Synaptics Touchpad While Typing

    This is excellent,

    took me ages to get it going especially step 2.D

    After alot of difficulty (white spaces error kept coming up), I thought I would have a go with typing in syndaemon -i 1 -d in both "Name" and "Command". It worked right away.

    Now my only question... with my touch pad being disabled (YAY!), as soon as I finish typing and start using the touchpad, theres a delay of about 2 seconds.
    Can I get the delay time a bit faster?

    Thanks heaps for this how to tutorial.
    Australian Open Office Users: You can get an Aussie dictionary for OOO. ie colour not color.

  10. #100
    Join Date
    Oct 2007
    Beans
    Hidden!

    Re: HowTo: Disable Synaptics Touchpad While Typing

    I think its better to use this:

    syndaemon -i 1 -d -t

    The -t makes sure the touchpad still works while typing, except you can't tap (click) for 1 second (or whatever you set it at) so the cursor can't jump either. This is slightly less annoying than the 1 second delay. With -t you can already position the mouse pointer, and it will probably take 1 second between typing and being ready to click, so its almost unnoticeable.

    Still I'm curious why we need this workaround at all. It seems many (most?) Ubuntu users with a synaptic touchpad have issues with jumping cursor even when not using the touchpad. When I pay careful attention not to touch it, the cursor still jumps. This problem doesnt exist in Windows.

    I tried various other fixes, like adding i8042.nomux=1 to the kernel parameters, I tried fiddling in xorg.conf by increasing FingerLow sensitivity, but none of it really cures it. This workaround makes it bearable but its hardly an ideal solution as I do pause for a second now and then between sentences

Page 10 of 18 FirstFirst ... 89101112 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •