Page 27 of 29 FirstFirst ... 172526272829 LastLast
Results 261 to 270 of 285

Thread: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

  1. #261
    Join Date
    Apr 2005
    Beans
    220

    Re: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

    "Mission-critical or other stability conscious systems probably should not use backports, as they are not tested as heavily as the software that ships with your stable release."

    "Pinning" helps alleviate concerns about that. I had problems with backports many versions ago (not lately), and got pinning advice from Debian. I'm very glad the Ubuntu devs included instructions in the wiki now. As far as I know, it's not done as a default when enabling the Backports repository, and it really should be IMHO.

    https://help.ubuntu.com/community/UbuntuBackports

  2. #262
    Join Date
    Sep 2006
    Beans
    22

    Re: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

    Here's a tricky dependency problem when backporting libclassworlds-java from Hardy to Gutsy:
    1. prevu libclassworlds-java
      (prevu fails saying a dependency on maven-ant-helper >= 3 was not satisfied because there is no package named 'maven-ant-helper' in Gutsy)
    2. prevu maven-ant-helper
      (prevu successfully creates maven-ant-helper_3~7.10prevu1)
    3. sudo prevu-update
      (prevu will now see maven-ant-helper_3~7.10prevu1 in all future prevu runs)
    4. prevu libclassworlds-java
      (prevu fails because the version of maven-ant-helper_3~7.10prevu1 is less than 3 and libclassworlds-java requires maven-ant-helper >=3)

    I know that the "~7.10prevu1" suffix is added to the version for a good reason -- it's to make sure that the backported package is upgraded when you do a dist-upgrade. However, it means that dependencies can break as in the above example. Is there a way that I can get around this?

  3. #263
    Join Date
    Oct 2004
    Location
    Cupertino, CA
    Beans
    5,092
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

    You should apt-get source libclassworlds-java and edit debian/control to depend on a lower version (i.e. one with the ~7.10prevu1) of the package in question, and run "prevu" with no arguments to build that modified source.

  4. #264
    Join Date
    Sep 2006
    Beans
    22

    Re: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

    Quote Originally Posted by jdong View Post
    You should apt-get source libclassworlds-java and edit debian/control to depend on a lower version (i.e. one with the ~7.10prevu1) of the package in question, and run "prevu" with no arguments to build that modified source.
    Brilliant! Worked like a charm.

    Would it be worthwhile to change prevu to automatically modify dependencies to add the "~7.10prevu1" suffix when backporting?

    Thanks for your help!

  5. #265
    Join Date
    Aug 2006
    Beans
    3

    Dependencies with a ~ already

    Hi. Thanks for such an awesome tool!!!

    This is kinda related to sfp's question above:
    I'm backporting Festival from Hardy to Gutsy.

    Building it and it's deps were successful.
    However, installing them gives me some problems.
    Specifically, Festival needs a library dependency:
    libestools1.2 (>= 1:1.2.96~beta-2)

    The version prevu built is called:
    libestools1.2_1.2.96~beta-2~7.10prevu1_i386.deb

    In the control file "depends" of Festival, I have put:
    libestools1.2-dev (>= 1:1.2.96~beta-2~7.10prevu1)

    Edit: Just to be clear, in the control file:
    Build-Depends: ... libestools1.2-dev (>= 1:1.2.96~beta-2~7.10prevu1) ...
    Package: festival
    Depends: ${shlibsepends}, ${miscepends} ...

    when I try to install using apt-get -s install festival, I get:
    The following packages have unmet dependencies:
    festival: Depends: libestools1.2 (>= 1:1.2.96~beta-2) but 1:1.2.96~beta-2~7.10prevu1 is to be installed

    Is this because libestools already has a ~beta-2, and ~7.10prevu1 after it is ignored? I'm not too sure on how this kind of naming works in Debian/Ubuntu.
    In any case I would like to keep the beta-2 in there for future reference.

    How would I work around something like this?

    P.S. I've tried removing the debs and remade them, always apt-get update-ing afterwards, with no luck. Also the Package file in /var/cache/prevu/gutsy-debs/ states that festival depends on:
    libestools1.2, libestools1.2 (>= 1:1.2.96~beta-2) [without the ~7.10prevu1]
    Kinda interesting to have 2 entries there.
    Last edited by vik_777; March 15th, 2008 at 07:52 AM.

  6. #266
    Join Date
    Aug 2006
    Beans
    3

    Re: Dependencies with a ~ already

    Figured the above out with the help of the good folks at #ubuntu-motu.
    I had to edit festival's debian/shlibs.local and add the ~7.10prevu1 in to the libestools entry.

    Thanks jpatrick and Hobbsee for the help.
    And thanks jdong once again for such a cool util!

    [note to self] Always grep if in doubt.

  7. #267
    Join Date
    Sep 2006
    Beans
    22

    Re: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

    How do I get prevu to generate signed packages? I want to eliminate those authentication warnings.

    Also, is it safe to backport dpkg? I need a newer version of dpkg-dev to satisfy a build dependency of another package I want to backport.
    Last edited by sfp-a7x; March 25th, 2008 at 05:18 AM. Reason: thought of another question to ask

  8. #268
    Join Date
    Oct 2004
    Beans
    38

    Re: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

    Hello,

    I'm trying to backport php 5.2 from hardy to dapper. prevu stops at :

    Setting DEBBUILDOPTS=
    -> Attempting to parse the build-deps : pbuilder-satisfydepends,v 1.22 2005/12/04 05:16:40 dancer Exp $
    -> Considering apache2-prefork-dev (>= 2.0.53-3)
    -> Trying apache2-prefork-dev
    -> Considering autoconf
    -> Trying autoconf
    -> Considering automake1.4
    -> Trying automake1.4
    -> Considering bison
    -> Trying bison
    -> Considering chrpath
    -> Trying chrpath
    -> Considering debhelper (>= 3)
    -> Trying debhelper
    -> Considering flex (>= 2.5.4)
    -> Trying flex
    -> Considering freetds-dev
    -> Trying freetds-dev
    -> Considering libapr1-dev (>= 1.2.7-8)
    W: Unable to locate package libapr1-dev
    E: No packages found
    Tried versions:
    -> Does not satisfy version, not trying
    E: Could not satisfy build-dependency.
    Copying back the cached apt archive contents
    -> unmounting /var/cache/prevu/src/10556 filesystem
    -> unmounting /var/cache/prevu/dapper-debs filesystem
    -> unmounting dev/pts filesystem
    -> unmounting proc filesystem
    -> cleaning the build env
    -> removing directory /var/cache/prevu/builds/10662 and its subdirectories
    ========================
    Prevu Error: Build failed.
    Prevu encountered an error performing your build. The actual
    error message may be further up in the scrollback before pbuilder
    exited. Please look for a failed dependency or compile error in
    the full output.
    The package libapr1-dev seem to be the problem, but I don't know what to do with that. Any ideas ?

    Thanks !

  9. #269
    Join Date
    Jan 2005
    Beans
    403

    Re: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

    I'm running on PowerPC, 8.04. When I try to use Prevu Iget this:

    Code:
     prevu totem
    I: Building against currently running distro: hardy
    
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Need to get 4184kB of source archives.
    Get:1 http://ports.ubuntu.com intrepid/main totem 2.24.2-0ubuntu4 (dsc) [2667B]
    Get:2 http://ports.ubuntu.com intrepid/main totem 2.24.2-0ubuntu4 (tar) [3714kB]
    Get:3 http://ports.ubuntu.com intrepid/main totem 2.24.2-0ubuntu4 (diff) [468kB]
    Fetched 4184kB in 31s (134kB/s)                                                
    gpg: Signature made Fri 24 Oct 2008 01:26:11 PM MDT using DSA key ID A2D7D292
    gpg: Can't check signature: public key not found
    dpkg-source: extracting totem in totem-2.24.2
    dpkg-source: unpacking totem_2.24.2.orig.tar.gz
    dpkg-source: applying ./totem_2.24.2-0ubuntu4.diff.gz
    dch warning: new version (2.24.2-0ubuntu4~8.04prevu1) is less than
    the current version number (2.24.2-0ubuntu4).
    W: /home/brianokeefe/.pbuilderrc does not exist
    W: /home/brianokeefe/.pbuilderrc does not exist
    Building the build Environment
     -> extracting base tarball [/var/cache/prevu/hardy.tgz]
    
    gzip: stdin: unexpected end of file
    tar: Child returned status 1
    tar: Error exit delayed from previous errors
    E: failed to extract /var/cache/prevu/hardy.tgz to /var/cache/prevu/builds/8324
    ========================
    Prevu Error: Build failed.
    Prevu encountered an error performing your build. The actual
    error message may be further up in the scrollback before pbuilder
    exited. Please look for a failed dependency or compile error in
    the full output.
    Prevu used to work. Now it doesn't.

  10. #270
    Join Date
    Oct 2004
    Location
    Cupertino, CA
    Beans
    5,092
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Build (backport) an newer Ubuntu package to run on an older Ubuntu version

    Re-run prevu-init; the base image tarball somehow is corrupt; prevu-init rebuilds it.
    Quote Originally Posted by tuxradar
    Linux's audio architecture is more like the layers of the Earth's crust than the network model, with lower levels occasionally erupting on to the surface, causing confusion and distress, and upper layers moving to displace the underlying technology that was originally hidden

Page 27 of 29 FirstFirst ... 172526272829 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •