Page 9 of 66 FirstFirst ... 78910111959 ... LastLast
Results 81 to 90 of 654

Thread: HOWTO: ipw2200 + wpa

  1. #81
    Join Date
    May 2005
    Location
    Chesaning, MI
    Beans
    49
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: ipw2200 + wpa

    I was able to fix this error:

    Makefile:484: .config: No such file or directory

    From this reference: http://www.linuxquestions.org/questi...hreadid=311810

    No clue on the rest, though.

  2. #82
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by gondoi
    Man I don't know what's going on here... Everyone seems to be able to get wpasupplicant in a snap. Maybe it's because i'm new to Ubuntu and i'm missing a repository, but I keep getting this when i try to apt-get the wpasupplicant:

    Code:
    ~$ sudo apt-get install wpasupplicant
    Reading package lists... Done
    Building dependency tree... Done
    E: Couldn't find package wpasupplicant
    Yes, you're missing a repository: you have to enable te universe one: look here for how to do: http://www.ubuntuguide.org/#extrarepositories

  3. #83
    Join Date
    May 2005
    Location
    Chesaning, MI
    Beans
    49
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: ipw2200 + wpa

    I downloaded and installed the latest .deb package from here: http://linux.org.by/debian/pool/contrib/i/ipw2200/

    But when I did a modprobe and a dmesg, it still says that the 0.19 is loaded.
    Last edited by MonkeyWrench32; May 15th, 2005 at 06:06 PM.

  4. #84
    Join Date
    May 2005
    Location
    Chesaning, MI
    Beans
    49
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: ipw2200 + wpa

    I did a little checking and I had to run module-assistant to install that package. I did all of that and copied the files like it says in the first post, but I've got a situation here:

    Code:
    jon@UbuntuMonkey:~$ dmesg | grep ipw
    ipw2200: disagrees about version of symbol ieee80211_wx_set_encode
    ipw2200: Unknown symbol ieee80211_wx_set_encode
    ipw2200: disagrees about version of symbol ieee80211_wx_get_encode
    ipw2200: Unknown symbol ieee80211_wx_get_encode
    ipw2200: disagrees about version of symbol ieee80211_crypt_delayed_deinit
    ipw2200: Unknown symbol ieee80211_crypt_delayed_deinit
    ipw2200: disagrees about version of symbol ieee80211_wx_get_scan
    ipw2200: Unknown symbol ieee80211_wx_get_scan
    ipw2200: disagrees about version of symbol ieee80211_rx
    ipw2200: Unknown symbol ieee80211_rx
    ipw2200: disagrees about version of symbol ieee80211_rx_mgt
    ipw2200: Unknown symbol ieee80211_rx_mgt
    Please help!

  5. #85
    Join Date
    May 2005
    Location
    Chesaning, MI
    Beans
    49
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: ipw2200 + wpa

    Well, I uninstalled all of that package crap and actually got make to work! Apparently I didn't have the linux headers installed after all.

    Now to work on the WPA...

  6. #86
    Join Date
    May 2005
    Location
    Chesaning, MI
    Beans
    49
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: ipw2200 + wpa

    GOT IT!

    Thank you so much, Luca!

  7. #87
    Join Date
    May 2005
    Beans
    22

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by luca_linux
    Then you have to copy all the modules (ieee80211*.ko) it installs from /lib/modules/$(KVER)/drivers/net/wireless/ to /lib/modules/$(KVER)/kernel/drivers/net/wireless/ and /lib/modules/$(KVER)/drivers/net/wireless/ipw2200.ko to /lib/modules/$(KVER)/kernel/drivers/net/wireless/ipw2200/, since there's currently a bug in their location: in fact ipw2200 installs its modules in the first directory, while Ubuntu loads them from the second directory.
    Quote Originally Posted by kiranos
    EDIT: found the problem, the modules should go in wireless/ieee81102/ and not straight into wireless as I did
    Ahh, that fixes my problem

    Kiranos has it right; the ieee80211*.ko files should go in /lib/modules/$(KVER)/kernel/drivers/net/wireless/ieee80211/

    Luca, could you edit your post to read:

    "Then you have to copy all the modules (ieee80211*.ko) it installs from /lib/modules/$(KVER)/drivers/net/wireless/ to /lib/modules/$(KVER)/kernel/drivers/net/wireless/ieee80211"

    for people who come after me? Thanks bunches, in any case

  8. #88
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Yes, you're right...I meant that directory...I didn't pay attention to it.

    HowTo edited.

  9. #89
    Join Date
    May 2005
    Location
    Bordeaux, France
    Beans
    11

    Lightbulb Re: HOWTO: ipw2200 + wpa

    Hi everybody,

    After some painful hours on this install, i finally found why I had these messages:

    Code:
    $ dmesg | grep ipw
    ipw2200: disagrees about version of symbol ieee80211_wx_set_encode
    ipw2200: Unknown symbol ieee80211_wx_set_encode
    ipw2200: disagrees about version of symbol ieee80211_wx_get_encode
    ipw2200: Unknown symbol ieee80211_wx_get_encode
    ipw2200: disagrees about version of symbol ieee80211_crypt_delayed_deinit
    ipw2200: Unknown symbol ieee80211_crypt_delayed_deinit
    ipw2200: disagrees about version of symbol ieee80211_wx_get_scan
    ipw2200: Unknown symbol ieee80211_wx_get_scan
    ipw2200: disagrees about version of symbol ieee80211_rx
    ipw2200: Unknown symbol ieee80211_rx
    ipw2200: disagrees about version of symbol ieee80211_rx_mgt
    ipw2200: Unknown symbol ieee80211_rx_mgt
    It was very easy, i just needed to reboot the computer

    So now, 'cause i'm a lazy boy, i decided to automate the install, so i made a script.
    I give it for everyone who is interessed in.
    You need to be root to execute this script, and remember that you have to edit some vars in the script in order to match your network config.

    You can install the latest version of the driver , all you need is to change to variables in the script and put these names of files ipw2200-1.0.4 and ipw2200-fw-2.3 instead of ipw2200-1.0.3 and ipw2200-fw-2.2.

    Hope it will help
    Attached Files Attached Files
    Last edited by Emerick; May 21st, 2005 at 12:29 AM. Reason: Putting file in the post

  10. #90
    Join Date
    Dec 2004
    Location
    Utah, USA
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: ipw2200 + wpa

    With ipw2200 1.0.4 you will get error while compiling unless you run the remove_old script from the ipw2200 1.0.4 sources. Also I'm getting a ton of firmware errors, so you may want towait till 1.0.5.

    Mike
    Mike: "The hardest questions in life are the ones worth answering"
    E-Mail | Blog | Gmail | technoviking on irc.freenode.net, identi.ca , and Twitter

Page 9 of 66 FirstFirst ... 78910111959 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •