Page 65 of 66 FirstFirst ... 155563646566 LastLast
Results 641 to 650 of 654

Thread: HOWTO: ipw2200 + wpa

  1. #641
    Join Date
    Aug 2006
    Beans
    33

    Re: HOWTO: ipw2200 + wpa

    Problem solved in Windows by disabling/enabling MAC filter on the router
    ( don't even ask how that comes! )

    Now, in Kubuntu, it still doesn't work

    The card gets recognized, but

    Code:
    jochus@bacardi:~$ dmesg | grep -i intel
    [4294667.296000] ACPI: FADT (v001 INTEL  ALVISO   0x06040000 LOHR 0x0000005f) @
    0x3fee9e88
    [4294667.296000] ACPI: MADT (v001 INTEL  ALVISO   0x06040000 LOHR 0x0000005f) @                                                                                                    0x3fee9efc
    [4294667.296000] ACPI: MCFG (v001 INTEL  ALVISO   0x06040000 LOHR 0x0000005f) @                                                                                                    0x3fee9f9c
    [4294667.296000] ACPI: DSDT (v001 INTEL  ALVISO   0x06040000 MSFT 0x0100000e) @                                                                                                    0x00000000
    [4294671.448000] CPU: Intel(R) Pentium(R) M processor 1.73GHz stepping 08
    [4294686.686000] agpgart: Detected an Intel 915GM Chipset.
    [4294688.469000] ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@                                                                                                   linux.intel.com>
    [4294688.966000] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.0
    [4294688.966000] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    [4294688.966000] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    ... now, there's something wrong with my eth1

    Code:
    jochus@bacardi:~$ dmesg | grep eth1
    [4294693.947000] ADDRCONF(NETDEV_UP): eth1: link is not ready
    What could be the problem?

  2. #642
    Join Date
    Dec 2004
    Location
    Austria (Upper Austria)
    Beans
    52

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by mech7 View Post
    mmm it is weird i dont even have this directory:

    Code:
    sudo tar xvzf ipw2200-fw-2.3.tgz
    sudo cp ipw-2.3-*.fw /usr/lib/hotplug/firmware/
    There is no hotplug and firmware
    try /lib/firmware/ on dapper

  3. #643
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 5.10

    Exclamation ipw2200-1.0.6 code bug

    Hello,

    When going through the make of ipw2200:
    Code:
    cd ipw2200-1.0.6
    make
    The following output is given:
    Code:
    mkdir -p /home/bruno/wireless/ipw2200-1.0.6/tmp/.tmp_versions
    cp /lib/modules/2.6.15-26-386/net/ieee80211/.tmp_versions/*.mod /home/bruno/wireless/ipw2200-1.0.6/tmp/.tmp_versions
    make -C /lib/modules/2.6.15-26-386/build M=/home/bruno/wireless/ipw2200-1.0.6 MODVERDIR=/home/bruno/wireless/ipw2200-1.0.6/tmp/.tmp_versions modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.15-26-386'
      CC [M]  /home/bruno/wireless/ipw2200-1.0.6/ipw2200.o
    /home/bruno/wireless/ipw2200-1.0.6/ipw2200.c: In function 'ipw_pci_probe':
    /home/bruno/wireless/ipw2200-1.0.6/ipw2200.c:10748: error: 'struct iw_handler_def' has no member named 'spy_offset'
    make[2]: *** [/home/bruno/wireless/ipw2200-1.0.6/ipw2200.o] Error 1
    make[1]: *** [_module_/home/bruno/wireless/ipw2200-1.0.6] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.15-26-386'
    make: *** [modules] Error 2
    Notice the message: ipw2200.c:10748: error: 'struct iw_handler_def' has no member named 'spy_offset'.

    This is obviously an error in the script, right?

    Bruno.

  4. #644
    Join Date
    Oct 2005
    Location
    Hamburg, the north
    Beans
    10
    Distro
    Ubuntu Breezy 5.10

    Re: HOWTO: ipw2200 + wpa

    Hello Bruno,

    this is not an error in the source code of the driver.

    As you are trying to compile the driver with kernel version 2.6.15, you should use a more recent version of the IPW source code. ipw2200-1.0.6 is a little outdated.

    Please use
    http://ipw2200.sourceforge.net/#downloads
    to download the newest driver and
    http://ipw2200.sourceforge.net/firmware.php
    in order to download the according firmware.

    Or... upgrade your Ubuntu installation to Dapper Drake

    Good Luck
    Carsten

  5. #645

    Re: HOWTO: ipw2200 + wpa

    Funny I'm getting the same error about eth1 link not ready. This is a brand new install of edgy, I riped out the org ipw2200 ieee and ipw2200 firmware, download new drivers off SF and installed them.

    this was in my dmesg using the original drivers

    Oct 25 08:41:58 laptop kernel: [17179586.312000] Driver 'ipw2200' needs updating - please use bus_type methods
    after updating to the latest and greatest that msg is gone

    Oct 25 10:47:29 laptop kernel: [17179586.840000] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.0dmq
    Oct 25 10:47:29 laptop kernel: [17179586.840000] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    Oct 25 10:47:29 laptop kernel: [17179587.088000] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    Oct 25 10:47:29 laptop kernel: [17179587.356000] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
    sudo lshw -C network even shows eth1 info and wifi-radar even picks up other networks..


    *-network
    description: Ethernet interface
    product: NetXtreme BCM5751M Gigabit Ethernet PCI Express
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@10:00.0
    logical name: eth0
    version: 11
    serial: 00:14:c2:da:b5:6b
    size: 100MB/s
    capacity: 1GB/s
    width: 64 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegociation
    configuration: autonegociation=on broadcast=yes driver=tg3 driverversion=3.59.1 duplex=full firmware=5751m-v3.29a ip=10.0.100.121 link=yes multicast=yes port=twisted pair speed=100MB/s
    resources: iomemory:c8000000-c800ffff irq:169
    *-usb
    description: Bluetooth wireless interface
    product: HP integrated Bluetooth module
    vendor: Broadcom
    physical id: 2
    bus info: usb@2:2
    version: 0.17
    capabilities: bluetooth usb-1.10
    configuration: driver=hci_usb maxpower=0mA speed=12.0MB/s
    *-network
    description: Wireless interface
    product: PRO/Wireless 2200BG Network Connection
    vendor: Intel Corporation
    physical id: 4
    bus info: pci@02:04.0
    logical name: eth1
    version: 05
    serial: 00:15:00:1f:9f:dd
    width: 32 bits
    clock: 33MHz
    capabilities: bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=ipw2200 driverversion=1.2.0dmq firmware=ABG:9.0.2.6 (Mar 22 2005) link=no multicast=yes wireless=unassociated
    resources: iomemory:c8400000-c8400fff irq:50
    output of ifconfig notice the missing ip?

    ifconfig
    eth0 Link encap:Ethernet HWaddr 00:14:C2A:B5:6B
    inet addr:10.0.100.121 Bcast:10.0.100.255 Mask:255.255.255.0
    inet6 addr: fe80::214:c2ff:feda:b56b/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2127 errors:0 dropped:0 overruns:0 frame:0
    TX packets:907 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1049811 (1.0 MiB) TX bytes:262819 (256.6 KiB)
    Interrupt:169

    eth1 Link encap:Ethernet HWaddr 00:15:00:1F:9FD
    inet6 addr: fe80::215:ff:fe1f:9fdd/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:9585 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2578 errors:0 dropped:0 overruns:0 carrier:1
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:50 Base address:0xe000 Memory:c8400000-c8400fff

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)
    and when I try and start the wifi eth1 link via NetworkMangler err NetworkManager in Gnome I see this in messages.

    kernel: [17182505.884000] ADDRCONF(NETDEV_UP): eth1: link is not ready
    Any ideas anybody? I'm fresh out

  6. #646

    Re: HOWTO: ipw2200 + wpa

    forgot to add my /etc/network/interfaces and iwconfig output

    cat /etc/network/interfaces
    auto lo
    iface lo inet loopback
    #auto eth0
    #iface eth0 inet dhcp
    #iface eth2 inet dhcp
    #wireless-essid goaway
    #wireless-key s:secretkey
    #auto eth2
    #iface eth1 inet dhcp
    #wireless-essid QcS1-M4B-01s
    #wireless-key s:secretkey
    I commented out all except lo and rebooted

    get this in dmesg |grep eth1

    [17179590.768000] eth1: Tigon3 [partno(BCM95751M) rev 4101 PHY(5750)] (PCI Express) 10/100/1000BaseT Ethernet 00:14:c2:da:b5:6b
    [17179590.768000] eth1: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[1] TSOcap[1]
    [17179590.768000] eth1: dma_rwctrl[76180000] dma_mask[64-bit]
    [17179606.484000] ADDRCONF(NETDEV_UP): eth1: link is not ready
    dmesg |grep ipw2200
    [17179590.528000] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.0dmq
    [17179590.528000] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    [17179590.528000] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    [17179590.736000] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
    Last edited by Styles; October 25th, 2006 at 08:01 PM. Reason: add

  7. #647
    Join Date
    Mar 2005
    Location
    the South
    Beans
    471

    Re: HOWTO: ipw2200 + wpa

    Hmmmm..... lots of questions and not many answers. Luca has moved on to his own website with its own forum. I think it might be time to move this thread over there. I can't get wireless to work either BTW; but I am using Elive so its an entirely different set of problems.

  8. #648
    Join Date
    Dec 2006
    Beans
    2

    Re: HOWTO: ipw2200 + wpa

    hi...
    i got this error message:
    [4294698.284000] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.4dmq
    [4294698.284000] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    [4294698.289000] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    [4294698.377000] ipw2200: ipw2200-bss.fw request_firmware failed: Reason -2
    [4294698.377000] ipw2200: Unable to load firmware: -2
    [4294698.377000] ipw2200: failed to register network device
    [4294698.381000] ipw2200: probe of 0000:06:07.0 failed with error -5

    i copy the firmware to /usr/lib/hotplug/firmware
    this is not the error.

  9. #649
    Join Date
    Dec 2006
    Beans
    2

    Re: HOWTO: ipw2200 + wpa

    ok, my mistake ... wrong driver.
    sorry

  10. #650
    Join Date
    Sep 2006
    Beans
    10

    Re: HOWTO: ipw2200 + wpa

    hi there, I have installed ubuntu edgy on my laptop and facing problem with activating the wireless. Here is some info regarding wireless hardware and software
    # uname -r
    2.6.17-10-generic
    # dmesg | grep 2200
    [17179572.800000] MEM window: 22000000-23ffffff
    [17179573.220000] i8042.c: Detected active multiplexing controller, rev 1.1.
    [17179573.220000] serio: i8042 AUX0 port at 0x60,0x64 irq 12
    [17179573.220000] serio: i8042 AUX1 port at 0x60,0x64 irq 12
    [17179573.220000] serio: i8042 AUX2 port at 0x60,0x64 irq 12
    [17179573.220000] serio: i8042 AUX3 port at 0x60,0x64 irq 12
    [17179573.220000] serio: i8042 KBD port at 0x60,0x64 irq 1
    [17179573.220000] EISA: Probing bus 0 at eisa.0
    [17179573.220000] EISA: Detected 0 cards.
    [17179602.052000] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.1dmq
    [17179602.052000] ipw2200: Copyright(c) 2003-2006 Intel Corporation
    [17179608.472000] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    [17179608.700000] ipw2200: Radio Frequency Kill Switch is On:
    [17179608.700000] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)

    I have tried every solution what I can find through google; but unfortunately still not working. and as instructed on ubuntu forum regarding copy the firmware into /usr/lib/hotplug/firmware but in my system there is no folder called /usr/lib/hotplug....

    If any one have a idea to fix this problem would be great.

Page 65 of 66 FirstFirst ... 155563646566 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •