Page 54 of 66 FirstFirst ... 444525354555664 ... LastLast
Results 531 to 540 of 654

Thread: HOWTO: ipw2200 + wpa

  1. #531
    Join Date
    Feb 2005
    Beans
    51

    Re: HOWTO: ipw2200 + wpa

    I just looked back at my original posting and I see more than a few typos. I'll try to correct those off-line and then repost.

    Rick Knight

  2. #532
    Join Date
    Feb 2005
    Beans
    51

    Re: HOWTO: ipw2200 + wpa

    Bennettg,

    I've just made some corrections and a couple of additions to my HOWTO post. Your cut and pastes should work now.

    Rick Knight

  3. #533
    Join Date
    Feb 2005
    Beans
    122

    Re: HOWTO: ipw2200 + wpa

    The line in your post that should copy the firmware to the porper directory...

    bennettg@ubuntu:~$ cd /home/bennettg/Share/ipw2200
    bennettg@ubuntu:~/Share/ipw2200$ sudo cp ipw-2.4-fw* /usr/lib/hotplug/firmware
    Password:
    cp: cannot stat `ipw-2.4-fw*': No such file or directory
    bennettg@ubuntu:~/Share/ipw2200$

    Still is not working.

    Is there anything this nOOb can do to help? Do you have a project that I can donate to? Thank you for your continued patience and support

  4. #534
    Join Date
    Feb 2005
    Beans
    122

    Re: HOWTO: ipw2200 + wpa

    Also, there is not a file called .config in /home/share/ipw2200/wpa_supplicant-0.4.7 (I even looked for hidden files)

    In you HowTO where you call for:

    Copy this code to .config in /home/share/ipw2200/wpa_supplicant-0.4.7/
    Code:

    CONFIG_IEEE8021X_EAPOL=y CONFIG_EAP_MD5=y CONFIG_EAP_MSCHAPV2=y CONFIG_EAP_TLS=y CONFIG_EAP_PEAP=y CONFIG_EAP_TTLS=y #CONFIG_EAP_GTC=y #CONFIG_EAP_OTP=y #CONFIG_EAP_SIM=y #CONFIG_EAP_AKA=y CONFIG_EAP_PSK=y #CONFIG_EAP_PAX=y CONFIG_EAP_LEAP=y CONFIG_WIRELESS_EXTENSION=y #CONFIG_DRIVER_HOSTAP=y #CONFIG_DRIVER_HERMES=y #CONFIG_DRIVER_MADWIFI=y #CFLAGS += -I../madwifi #CONFIG_DRIVER_ATMEL=y CONFIG_DRIVER_WEXT=y CONFIG_DRIVER_NDISWRAPPER=y #CONFIG_DRIVER_BROADCOM=y CONFIG_DRIVER_IPW=y CONFIG_CTRL_IFACE=y

  5. #535
    Join Date
    Feb 2005
    Beans
    122

    Re: HOWTO: ipw2200 + wpa

    Rick,

    I may be closer. Since last night, I stopped everything, deleted all files ipw2200.ko and ieee80211*.ko and started from scratch with luca_linux's how to in post 1 of this thread.

    I followed his instructions step by step (only substitutiing newer versions of drivers and firmware). I did not encounter any errors when installing.

    However, the wireless is nto working. when booting it hangs with networking.

    prior to using wpa, i had configured wep through the kde gui system settings. those setting are still there and I cannot remove them. Is there a conflict here?

    I also took luca_linux's advice and modified my /etc/wpa_supplicant.conf file as follows (this is it's current state):

    ctrl_interface=/var/run/wpa_supplicant
    ap_scan=2

    network={
    ssid="acorn"
    scan_ssid=1
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=TKIP
    psk="24334B4A44412423486A736B61"
    }


    The following terminal outputs are form commands that luca_linux says to do. I dont understand what it means, but maybe you or someone else can help. this is the last thing I need to configure and then I am deleting Windows from my partition. Bye Bye M$!


    bennettg@ubuntu:~$ sudo wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -w -dd
    Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'ipw'
    Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    ap_scan=2
    Line: 4 - start of a new network block
    ssid - hexdump_ascii(len=5):
    61 63 6f 72 6e acorn
    scan_ssid=1 (0x1)
    proto: 0x1
    key_mgmt: 0x2
    pairwise: 0x8
    PSK (ASCII passphrase) - hexdump_ascii(len=26): [REMOVED]
    PSK (from passphrase) - hexdump(len=32): [REMOVED]
    Line 11: removed CCMP from group cipher list since it was not allowed for pairwise cipher
    Priority group 0
    id=0 ssid='acorn'
    Daemonize..
    bennettg@ubuntu:~$ sudo wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -dd
    Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'ipw'
    Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    ap_scan=2
    Line: 4 - start of a new network block
    ssid - hexdump_ascii(len=5):
    61 63 6f 72 6e acorn
    scan_ssid=1 (0x1)
    proto: 0x1
    key_mgmt: 0x2
    pairwise: 0x8
    PSK (ASCII passphrase) - hexdump_ascii(len=26): [REMOVED]
    PSK (from passphrase) - hexdump(len=32): [REMOVED]
    Line 11: removed CCMP from group cipher list since it was not allowed for pairwise cipher
    Priority group 0
    id=0 ssid='acorn'
    Initializing interface (2) 'eth1'
    EAPOL: SUPP_PAE entering state DISCONNECTED
    EAPOL: KEY_RX entering state NO_KEY_RECEIVE
    EAPOL: SUPP_BE entering state INITIALIZE
    EAP: EAP entering state DISABLED
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    wpa_driver_ipw_init is called
    ioctl[SIOCSIWPMKSA]: Operation not supported
    SIOCGIWRANGE: too old (short) data - assuming WPA is not supported
    Own MAC address: 00:0c:f1:2a:f3:c8
    wpa_driver_ipw_set_wpa: enabled=1
    wpa_driver_ipw_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
    wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
    wpa_driver_ipw_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
    wpa_driver_ipw_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
    wpa_driver_ipw_set_countermeasures: enabled=0
    wpa_driver_ipw_set_drop_unencrypted: enabled=1
    Setting scan request: 0 sec 100000 usec
    Using existing control interface directory.
    bind(PF_UNIX): Address already in use
    ctrl_iface exists and seems to be in use - cannot override it
    Delete '/var/run/wpa_supplicant/eth1' manually if it is not used anymore
    Failed to initialize control interface '/var/run/wpa_supplicant'.
    You may have another wpa_supplicant process already running or the file was
    left by an unclean termination of wpa_supplicant in which case you will need
    to manually remove this file before starting wpa_supplicant again.
    wpa_driver_ipw_set_wpa: enabled=0
    wpa_driver_ipw_set_drop_unencrypted: enabled=0
    wpa_driver_ipw_set_countermeasures: enabled=0
    No keys have been configured - skip key clearing

  6. #536
    Join Date
    Feb 2005
    Beans
    51

    Re: HOWTO: ipw2200 + wpa

    Bennettg,

    Code:
    bind(PF_UNIX): Address already in use
    ctrl_iface exists and seems to be in use - cannot override it
    Delete '/var/run/wpa_supplicant/eth1' manually if it is not used anymore
    Failed to initialize control interface '/var/run/wpa_supplicant'.
    You may have another wpa_supplicant process already running or the file was
    left by an unclean termination of wpa_supplicant in which case you will need
    to manually remove this file before starting wpa_supplicant again.
    I found this near the end of your last message. To do what it suggests,
    Code:
    sudo rm -f /var/run/wpa_supplicant/eth1
    And try to start wpa_supplicant again and see what happens.

    Rick Knight

  7. #537
    Join Date
    Jan 2006
    Beans
    4

    Re: HOWTO: ipw2200 + wpa

    Hey everyone, I seriously need some help here.

    I went through the entire guide with the help of all these replies. However, after installing the ipw2200 driver, my card still isn't detected. I tried the lsmod command but nothing comes up. The wifi light is not on either, I'm pretty sure I installed everything correctly. Does anything need to be enabled in order for this to work?

    My ethernet works fine but my wireless is still down.


    Please help!

    Thanks

  8. #538
    Join Date
    Feb 2005
    Beans
    122

    Re: HOWTO: ipw2200 + wpa

    Rick (or anyone kinf enough to help),


    I am soooo close. I wiped my hard drive and did a fresh install of kubuntu/ubuntu. I followed luca_linux's instructions in post 1 of this thread. Upon rebooting, I was connected!!!! The speed was much slower than in windows with wpa or in kubuntu with wep, but I was pleased.

    However, since that time, I have only been able to connect wirelessly 1 out of 7 times. I wonder if it is something in my /etc/wpa_supplicant.conf file.

    To help solve this probelm, I will post a picture of the wireless security settings from my router, and my /etc/wpa_supplicant.conf file. Does it have anything to do with TPIK? My WPA passphrase in ascii and i do not broadcast my ssid.

    [IMG]/home/bennettg/Desktop/snapshot1.png[/IMG]

    see attached snapshot





    Here is my etc/wpa_supplicant.conf:


    # Minimal /etc/wpa_supplicant.conf to associate with open
    # access points. Please see
    # /usr/share/doc/wpasupplicant/wpa_supplicant.conf.gz for more complete
    # configuration parameters.

    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0

    eapol_version=1
    ap_scan=1
    fast_reauth=1

    ### Associate with any open access point
    ### Scans/ESSID changes can be done with wpa_cli
    network={
    ssid=""
    key_mgmt=NONE
    }

    ctrl_interface=/var/run/wpa_supplicant

    network={
    ssid="acorn"
    scan_ssid=1
    psk="24334B4A44412423486A736B61"
    priority=2
    }


    Thank you so very much for your assistance. If I can just get this to connect reliabily, I will delete windoze from my partitions. Bye Bye M$ and Bill Gates
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	snapshot1.png 
Views:	26 
Size:	157.0 KB 
ID:	5382  
    Last edited by bennettg; January 16th, 2006 at 09:49 PM.

  9. #539
    Join Date
    Feb 2005
    Beans
    51

    Re: HOWTO: ipw2200 + wpa

    Bennettg,

    I notice you didn't pot key management and proto in your wpa_supplicant.conf. You might try adding them.
    Code:
    proto = WPA
    key_mgmt = WPA-PSK
    They go in the 'network' stanza.

    Good luck,
    Rick Knight

  10. #540
    Join Date
    Feb 2005
    Beans
    122

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by RickKnight
    Bennettg,

    I notice you didn't pot key management and proto in your wpa_supplicant.conf. You might try adding them.
    Code:
    proto = WPA
    key_mgmt = WPA-PSK
    They go in the 'network' stanza.

    Good luck,
    Rick Knight
    Does it matter if I am using a ascii passphrase (i.e. 8-63 characters) as opposed to a hexadecimal (64 characters)? I tried to use the examples in the /usr/share/doc/wpasupplicant/examples/wpa_supplicant.conf.gz file.

    Why would I have been able to connect sporadically with the current /etc/wpa_supplicant.conf?

Page 54 of 66 FirstFirst ... 444525354555664 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •