Page 42 of 66 FirstFirst ... 32404142434452 ... LastLast
Results 411 to 420 of 654

Thread: HOWTO: ipw2200 + wpa

  1. #411
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by netox
    Wow. Thanks so much for this. Ever since I installed Hoary I was getting a Fatal Error message, and then I upgraded to the latest ipw drivers with another tutorial and it didn't solve the problem. I followed your tutorial and I didn't get one single error message, so, once again, thanks a lot.
    Glad to have helped you out.

  2. #412

    Re: HOWTO: ipw2200 + wpa

    Thanks for the suggestions Bryan and Luca but still no joy. This is what my iwconfig looks like
    Code:
    eth1      IEEE 802.11-DS  ESSID:"Transmatofluffer 5000"  Nickname:"HERMES I"
    Mode:Managed  Frequency:2.457 GHz  Access Point: 00:00:00:00:00:00 
    Bit Rate:11 Mb/s   Tx-Power=15 dBm   Sensitivity:1/3
    Retry limit:4   RTS thr:off   Fragment thr:off
    Encryption key:off
    Power Management:off
    and here is my wpa_supplicant.conf
    Code:
    root@terrormachine:~# more /etc/wpa_supplicant.conf
    ctrl_interface=/var/run/wpa_supplicant
    ap_scan=2
    network={
    ssid="Transmatofluffer 5000"
    scan_ssid=1
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=TKIP
    psk="supursekrutpassword"
    }
    I've tried with and without both ap_scan and pairwise options.
    If anyone can point out what I'm doing wrong lemme know! Thanks!

  3. #413
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Try to first take "ap_scan" out, then "pairwise" and then both of them.

  4. #414
    Join Date
    Aug 2005
    Location
    Denmark
    Beans
    4

    Re: HOWTO: ipw2200 + wpa

    Im getting an error because i cant delete one of the files:

    troels@troels:~/download/ieee80211-1.0.3$ make
    Checking in /lib/modules/2.6.10-5-386/build/ for ieee80211 components...

    /lib/modules/2.6.10-5-386/build/include/config/ieee80211

    Above files found. Remove? [y],n y

    Old ieee80211 references found. In order to build the ieee80211
    subsystem, prior versions must first be removed. You can perform
    this task by running this makefile as root via:

    % sudo make check_old

    and answering Y to remove the file references.

    Aborting make.

    make: *** [check_old] Fejl 1

    all the prior steps have worked without errors..

    What is wrong??

    Billeman

  5. #415

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by billeman
    Im getting an error because i cant delete one of the files:
    troels@troels:~/download/ieee80211-1.0.3$ make
    Checking in /lib/modules/2.6.10-5-386/build/ for ieee80211 components...
    /lib/modules/2.6.10-5-386/build/include/config/ieee80211
    Above files found. Remove? [y],n y
    Old ieee80211 references found. In order to build the ieee80211
    subsystem, prior versions must first be removed. You can perform
    this task by running this makefile as root via:
    % sudo make check_old
    and answering Y to remove the file references.
    Aborting make.
    make: *** [check_old] Fejl 1
    all the prior steps have worked without errors..
    What is wrong??
    Billeman
    You'll need to remove that dir manually, as there is a bug with the script that causes it to not be removed (I can only guess it's because Ubuntu uses sudo to issue all root permissioned commands)
    Try:
    Code:
    sudo rm -rf /lib/modules/2.6.10-5-386/build/include/config/ieee80211
    If you don't feel comfortable deleting it you can move it out of the /lib/modules/2.6.10-5-386/build path.


    As for my own problems, I have tried the config file all 3 ways and could not get this to work. Since in iwconfig it states my AP mac is 00:00:00:00:00:00 I was assuming it wasn't seeing my AP, possibly because I have my WPA config on the router to not broadcast my SSID. Anyhow, I've given up hope. I will just wait until the powers that be decide to listen to the suggestions and make WPA standard in future releases. Thanks for all input though!
    Last edited by megan at terrormachine; October 2nd, 2005 at 02:39 PM.

  6. #416
    Join Date
    Oct 2005
    Beans
    4

    Re: HOWTO: ipw2200 + wpa

    Hi.
    I have a Fedora Core 4. A few days ago I followed the instructions in the Luca_Linux's how-to and all was Ok. I installed ieee80211, ipw2200, wpa_supplicant (I use WPA) and I was able to connect regularly.

    A few days later I had to reinstall the system, since I wasn't able to boot anymore.
    I updated the kernel from 2.6.11-1.1369_FC4 to 2.6.13-1.1526_FC4 (in the previous installation I didn't do that... so I installed the wireless card with the old kernel).

    Well, I tried to follow the instructions in the how-to another time, but now, at the end of installation, after typing

    # wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -w -dd

    nothing happens
    if i type iwconfig i receive "Encryption keyff" when in the previous installation i could see the exadecimal format of my key and after typing

    ifconfig eth1 up
    dhclient eth1

    i can't receive an ip address from DHCP....

    I tried to follow the instructions reported here
    which should be just for my kernel, but nothing...... I cant't connect anyway.....

    I can't understand where I'm wrong! I'm sure to do the same things I did the previous time....

    This is my /etc/wpa_supplicant.conf file:

    ctrl_interface=/var/run/wpa_supplicant
    network={
    ssid="3Com"
    scan_ssid=1
    proto=WPA
    key_mgmt=WPA-PSK
    psk="<my password>"
    }


    (the same information I wrote the previous time)

    Here is what I get when I type

    [root@localhost ~]# wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -w -dd
    Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'ipw'
    Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    Line: 2 - start of a new network block
    ssid - hexdump_ascii(len=4):
    33 43 6f 6d 3Com
    scan_ssid=1 (0x1)
    proto: 0x1
    key_mgmt: 0x2
    PSK (ASCII passphrase) - hexdump_ascii(len=31): [REMOVED]
    PSK (from passphrase) - hexdump(len=32): [REMOVED]
    Priority group 0
    id=0 ssid='3Com'
    Daemonize..
    [root@localhost ~]#



    And here is the output of iwconfig after typing the instruction above:

    [root@localhost ~]# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    Warning: Driver for device eth1 has been compiled with version 18
    of Wireless Extension, while this program supports up to version 17.
    Some things may be broken...


    eth1 unassociated ESSID:"3Com"
    Mode:Managed Frequency=2.462 GHz Access Point: 00:0F:CB:A9B:B6
    Bit Rate=0 kb/s Tx-Power=20 dBm
    Retry limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    sit0 no wireless extensions.


    Are there any other information I have to post?
    Have you got any idea?
    Thank you

  7. #417
    Join Date
    Oct 2005
    Beans
    4

    Re: HOWTO: ipw2200 + wpa

    Hi. My problem must be about WPA.
    In fact today I tried to disable security mode in my access point and then I was able to reach the network and connect to the Internet via Wireless.

    Then I retried to set WPA-PSK in the wireless configuration, I retried to type

    ifconfig eth1 up
    sudo wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -w -dd
    dhclient eth1

    but nothing. I can't reach the network.

    I controlled in autoconf.h and i have:
    CONFIG_CRYPTO
    CONFIG_CRYPTO_ARC4
    CONFIG_CRC32
    CONFIG_CRYPTO_MICHAEL_MIC
    CONFIG_CRYPTO_AES_586
    regularly set to 1

    Any idea? What can I control or do to be able to use WPA-PSK??
    (I remember you that in the previous installation all was OK....)

    Thanks in advance

    P.S. Today I have updated wireless-tools to version 28 from 27, and wpa_supplicant to 0.4.5 from 0.3.9

  8. #418
    Join Date
    May 2005
    Location
    BC, Canada
    Beans
    64
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: ipw2200 + wpa

    I just want to thank you for this howto. I updated to "breezy badger" and it comes with the latest driver/firmware (ipw2100 for me), so i was able to install wpa_supplicant, follow the rest of the howto and now i'm using wpa in ubuntu on my hp nc8000 laptop. Thanks again!

  9. #419
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    @ Marstell: Does it work if you use static IP instead of DHCP?

  10. #420
    Join Date
    Oct 2005
    Beans
    4

    Re: HOWTO: ipw2200 + wpa

    Hi Luca_linux and thanks for you reply.

    No. I tried typing
    ifconfig eth1 192.168.1.8
    but i can't reach the network .

    But today I discovered a "nice" thing..
    if I type
    wpa_supplicant -c /etc/wpa_supplicant.conf -i eth1 -D ipw -w -dd
    instead of
    wpa_supplicant -B -c /etc/wpa_supplicant.conf -i eth1 -D ipw -w -dd

    i get more information. This is the output:

    Initializing interface 'eth1' conf '/etc/wpa_supplicant.conf' driver 'ipw'
    Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    Line: 2 - start of a new network block
    ssid - hexdump_ascii(len=4):
    33 43 6f 6d 3Com
    scan_ssid=1 (0x1)
    proto: 0x1
    key_mgmt: 0x2
    PSK (ASCII passphrase) - hexdump_ascii(len=31): [REMOVED]
    PSK (from passphrase) - hexdump(len=32): [REMOVED]
    Priority group 0
    id=0 ssid='3Com'
    Initializing interface (2) 'eth1'
    EAPOL: SUPP_PAE entering state DISCONNECTED
    EAPOL: KEY_RX entering state NO_KEY_RECEIVE
    EAPOL: SUPP_BE entering state INITIALIZE
    EAP: EAP entering state DISABLED
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    wpa_driver_ipw_init is called
    ioctl[SIOCSIWPMKSA]: Operation not supported

    SIOCGIWRANGE: WE(compiled)=18 WE(source)=16 enc_capa=0x0
    capabilities: key_mgmt 0x0 enc 0x3
    Own MAC address: 00:0e:35:67:88:81
    wpa_driver_ipw_set_wpa: enabled=1
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    wpa_driver_ipw_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Failed to set encryption.
    wpa_driver_ipw_set_key: alg=none key_idx=1 set_tx=0 seq_len=0 key_len=0
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Failed to set encryption.
    wpa_driver_ipw_set_key: alg=none key_idx=2 set_tx=0 seq_len=0 key_len=0
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Failed to set encryption.
    wpa_driver_ipw_set_key: alg=none key_idx=3 set_tx=0 seq_len=0 key_len=0
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Failed to set encryption.
    wpa_driver_ipw_set_countermeasures: enabled=0
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    wpa_driver_ipw_set_drop_unencrypted: enabled=1
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported

    Setting scan request: 0 sec 100000 usec
    Wireless event: cmd=0x8b06 len=8
    RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
    RTM_NEWLINK, IFLA_IFNAME: Interface 'eth1' added
    State: DISCONNECTED -> SCANNING
    Starting AP scan (specific SSID)
    Scan SSID - hexdump_ascii(len=4):
    33 43 6f 6d 3Com
    Scan timeout - try to get results
    Received 271 bytes of scan results (1 BSSes)
    Scan results: 1
    Selecting BSS from priority group 0
    0: 00:0f:cb:a9:db:b6 ssid='3Com' wpa_ie_len=24 rsn_ie_len=0 caps=0x11
    selected
    Trying to associate with 00:0f:cb:a9:db:b6 (SSID='3Com' freq=0 MHz)
    Cancelling scan request
    WPA: clearing own WPA/RSN IE
    Automatic auth_alg selection: 0x1
    wpa_driver_ipw_set_auth_alg: auth_alg=0x1
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    WPA: using IEEE 802.11i/D3.0
    WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2
    WPA: set AP WPA IE - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
    WPA: clearing AP RSN IE
    WPA: using GTK TKIP
    WPA: using PTK TKIP
    WPA: using KEY_MGMT WPA-PSK
    WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
    No keys have been configured - skip key clearing
    wpa_driver_ipw_set_drop_unencrypted: enabled=1
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    State: SCANNING -> ASSOCIATING
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
    Setting authentication timeout: 5 sec 0 usec
    EAPOL: External notification - EAP success=0
    EAPOL: External notification - EAP fail=0
    EAPOL: External notification - portControl=Auto
    Wireless event: cmd=0x8b1a len=17
    Authentication with 00:00:00:00:00:00 timed out.
    Added BSSID 00:00:00:00:00:00 into blacklist
    State: ASSOCIATING -> DISCONNECTED



    It seems that the problem is in wpa_supplicant, or in the driver which is not enabled to wpa, or what other....
    In fact the driver works well without wpa or wep encryption...

    Where is the matter?

    I've tried with wpa_supplicant 0.39 and 0.45
    ipw2200 v. 1.0.6 and 1.0.7 (firmware 2.3 and 2.4)
    ieee80211 1.0.3 and 1.1.4

    I really don't know what to think...

    Thanks
    Marco

Page 42 of 66 FirstFirst ... 32404142434452 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •