Page 11 of 66 FirstFirst ... 9101112132161 ... LastLast
Results 101 to 110 of 654

Thread: HOWTO: ipw2200 + wpa

  1. #101
    Join Date
    Feb 2005
    Location
    Babylon
    Beans
    189
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by Emerick
    I didn't see this script. How silly i am
    In fact, it's logical, because i used my script to install this driver
    Yea I wanted to try your script but I kept getting connection refused. Try attaching it to your post.
    "We do not want a world in which the guarantee that we will not die of starvation is bought by accepting the risk of dying of boredom." -Vaneigem

  2. #102
    Join Date
    May 2005
    Location
    Bordeaux, France
    Beans
    11

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by dejitarob
    Yea I wanted to try your script but I kept getting connection refused. Try attaching it to your post.
    Very strange.
    I put the file on this message, and i edit the other post.

    You need to edit some vars on the file, and need to be root.
    Attached Files Attached Files

  3. #103
    Join Date
    May 2005
    Beans
    12

    Re: HOWTO: ipw2200 + wpa for newbies

    Quote Originally Posted by luca_linux
    Yes, just those 3 lines have to be shown.
    The latest driver version 1.0.4 has fixed many bugs especially about the power management stuff: so, you'd better give it a try.
    You need hotplug and in particular the kernel option "Device Drivers -> Generic Driver Options -> Hotplug firmware loading support", that's enabled by default.
    I don't think that driver version is a problem. I guess that the hotplug support is an issue as I have to disable the hotplug to make Ubuntu boot. I am new to Linux and never build the Linux kernel before. What does this kernel option mean?

    Thanks!
    hshen

  4. #104
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa for newbies

    Quote Originally Posted by hshen
    I don't think that driver version is a problem. I guess that the hotplug support is an issue as I have to disable the hotplug to make Ubuntu boot. I am new to Linux and never build the Linux kernel before. What does this kernel option mean?

    Thanks!
    hshen
    If you've never recompiled the kernel before, yours has already included that option by default, so don't worry about. Anyway, try to update the driver.

  5. #105
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by MechR
    1.0.4 Upgrade successful I have a couple questions, though...

    1. Is it necessary to remove the old 2.2 firmware files? They don't get overwritten by the 2.3 files because of their different names. I removed them myself just to be sure.

    2. Both times I've tried this, after the reboot I'd find that wireless isn't working, and that "dmesg | grep ipw" would give no output. Trying "modprobe ipw2200" would show that Linux is looking in the wrong places for the files (i.e., the places that the driver "make install" installs to, as opposed to the places I moved them to afterward). Running "sudo depmod" seems to straighten things out.

    (Note, I'm not really knowledgeable about Linux I just figured #2 out from bits of prior info and trial-and-error by man-page reading. Still happy with getting everything working, though )
    Yeah, it's better to remove the old firmware files.
    About the second point, you're right, in fact, as said in the howto, you need to copy the files to one directory to another...

  6. #106
    Join Date
    May 2005
    Beans
    22

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by luca_linux
    About the second point, you're right, in fact, as said in the howto, you need to copy the files to one directory to another...
    Sorry, I was unclear I meant that even though I had moved the files as instructed, Linux kept looking in the wrong places until I ran depmod.

  7. #107
    Join Date
    May 2005
    Location
    Chesaning, MI
    Beans
    49
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: ipw2200 + wpa

    I completely removed the old drivers and firmware and installed all of the new stuff. Here's the errors that I'm getting:

    jon@UbuntuMonkey:~$ dmesg | grep ipw
    ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.0.4
    ipw2200: Copyright(c) 2003-2004 Intel Corporation
    ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
    ipw2200: failed to send ASSOCIATE command
    ipw2200: failed to send SSID command
    ipw2200: failed to send SYSTEM_CONFIG command
    ipw2200: ipw_send_system_config failed
    ipw2200: failed to send SSID command
    ipw2200: failed to send SSID command
    ipw2200: No space for Tx
    ipw2200: failed to send SSID command
    ipw2200: No space for Tx
    ipw2200: failed to send SSID command
    ipw2200: No space for Tx
    ipw2200: failed to send SSID command
    ipw2200: No space for Tx
    ipw2200: failed to send SSID command
    ipw2200: No space for Tx
    ipw2200: failed to send SSID command
    ipw2200: No space for Tx
    ipw2200: failed to send SSID command
    ipw2200: No space for Tx
    ipw2200: failed to send SSID command
    Please help me!

  8. #108
    Join Date
    May 2005
    Beans
    8

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by juicewvu
    when trying to follow this tutorial i recieve the following error(s) when trying to compile the ipw2200 driver:

    Code:
    make -C /lib/modules/2.6.10-5-386/build SUBDIRS=/home/jcsmith/ipw2200-1.0.3 MODVERDIR=/home/jcsmith/ipw2200-1.0.3 modules
    make: *** /lib/modules/2.6.10-5-386/build: No such file or directory.  Stop.
    make: *** [modules] Error 2
    I tried making the /lib/modules/2.6.10-5-386/build directory as it infact does not exist, after which I recieve the following error(s):
    Code:
    make -C /lib/modules/2.6.10-5-386/build SUBDIRS=/home/jcsmith/ipw2200-1.0.3 MODVERDIR=/home/jcsmith/ipw2200-1.0.3 modules
    make[1]: Entering directory `/lib/modules/2.6.10-5-386/build'
    make[1]: *** No rule to make target `modules'.  Stop.
    make[1]: Leaving directory `/lib/modules/2.6.10-5-386/build'
    make: *** [modules] Error 2
    I'm kind of stuck here, do i need to copy the source files to the /lib/modules/2.6.10-5-386/build directory before trying to compile?


    -Juice

    Ok i crawled through the post and i have no clue how to make the systemlink correctly I think i have the kernel headers updated i ran this command
    Code:
    $ sudo apt-get install linux-headers-2.6.10-5-386
    btw im a complete newb when it comes to linux and drivers

  9. #109
    Join Date
    Jan 2005
    Location
    Laurel, MD
    Beans
    40
    Distro
    Ubuntu 8.04 Hardy Heron

    Smile Re: HOWTO: ipw2200 + wpa

    Somehow the new firmware (2.3) and the new drivers (1.0.6) make all the difference. I had no trouble compiling them using the same settings I've been using.

    However, an old problem is popping back up. I can't connect to a WiFi router that is using DHCP and WEP. It just times out. Any suggestions?

    *EDIT* I got it working. Forgot about changing the router to Open System for WEP Authentication Type. Oops.

    Quote Originally Posted by ChamPro
    Wow... I really don't know what the #*&$ is going on. I haven't had this much trouble with Ubuntu ever.

    Here's the beginning of the list of warnings I get when executing make. I tried changing the permissions of a lot of directories to no avail. The make and make install creates no kernel modules whatsoever.
    Code:
    zoph@nebosuke:~/Desktop/Downloads/ipw2200/ipw2200-1.0.3$ make
    make -C /lib/modules/2.6.10-5-686/build SUBDIRS=/home/zoph/Desktop/Downloads/ipw 2200/ipw2200-1.0.3 MODVERDIR=/home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3 modules
    make[1]: Entering directory `/usr/src/linux-source-2.6.10'
    Makefile:484: .config: No such file or directory
      CC [M]  /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200.o
    In file included from include/linux/module.h:9,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .h:32,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .c:33:
    include/linux/config.h:4:28: linux/autoconf.h: No such file or directory
    In file included from include/linux/module.h:10,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .h:32,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .c:33:
    include/linux/sched.h:4:37: asm/param.h: No such file or directory
    In file included from include/linux/types.h:13,
                     from include/linux/capability.h:16,
                     from include/linux/sched.h:7,
                     from include/linux/module.h:10,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .h:32,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .c:33:
    include/linux/posix_types.h:47:29: asm/posix_types.h: No such file or directory
    In file included from include/linux/capability.h:16,
                     from include/linux/sched.h:7,
                     from include/linux/module.h:10,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .h:32,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .c:33:
    include/linux/types.h:14:23: asm/types.h: No such file or directory
    In file included from include/linux/capability.h:16,
                     from include/linux/sched.h:7,
                     from include/linux/module.h:10,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .h:32,
                     from /home/zoph/Desktop/Downloads/ipw2200/ipw2200-1.0.3/ipw2200 .c:33:
    include/linux/types.h:18: error: syntax error before "__kernel_dev_t"
    include/linux/types.h:18: warning: type defaults to `int' in declaration of `__k ernel_dev_t'
    include/linux/types.h:18: warning: data definition has no type or storage class
    include/linux/types.h:21: error: syntax error before "dev_t"
    include/linux/types.h:21: warning: type defaults to `int' in declaration of `dev _t'
    Maybe I'm heading for a another format. Lovely.
    Last edited by ChamPro; May 24th, 2005 at 02:34 AM.

  10. #110
    Join Date
    May 2005
    Location
    Chesaning, MI
    Beans
    49
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: HOWTO: ipw2200 + wpa

    I rolled back to 1.0.3 and everything almost works. I am able to connect and what not, but I don't get a response when doing a ping. It does the DNS resolution, but that's all. Any suggestions?

Page 11 of 66 FirstFirst ... 9101112132161 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •