Page 5 of 16 FirstFirst ... 3456715 ... LastLast
Results 41 to 50 of 155

Thread: HowTo: WPA with wpa_supplicant

  1. #41
    Join Date
    Apr 2005
    Beans
    514

    Re: HowTo: WPA with wpa_supplicant

    Please, post the wpa_supplicant.conf you are using at the moment.

  2. #42
    Join Date
    Sep 2006
    Beans
    54
    Distro
    Ubuntu 6.06

    Re: HowTo: WPA with wpa_supplicant

    Here is my current wpa_supplicant.conf

    You will see that I put the RSN back in since taking it out was actually not the problem.

    ctrl_interface=/var/run/wpa_supplicant
    #ap_scan=2

    network={
    ssid="my_network_id"
    scan_ssid=1
    proto=WPA RSN
    # proto=WPA
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group=CCMP TKIP
    psk=9ae6b101b503bedc93b2570b0c2d77e161932e752a82e0 ffc5db9317fb390ee4
    }
    ASUS A8N32-SLI, AMD X2 4200+ (200x11=2.2GHz)
    Corsair XMS 2048 2-3-3-6-1T @ 2.6V, eVGA 7800GT , WD 74GB Raptor,WD 250GB Sata2
    Windows XP Pro, Ubuntu 6.06
    Dell C840 Lappy Ubuntu 6.06 w/WPA wifi, Dell P3 500 Ubuntu 6.06 w/SCSI scanner,samba

  3. #43
    Join Date
    Apr 2005
    Beans
    514

    Re: HowTo: WPA with wpa_supplicant

    First of all, I suggest you removing the psk key from your post for your privacy.
    Then, as for your problem, try to uncomment the second line and rebooting wpa_supplicant. If that doesn't help, try changing its value to 0 and/or 1.
    In the meanwhile, also try taking "CCMP" out, even though that shouldn't help as "RSN".

  4. #44
    Join Date
    Sep 2006
    Beans
    54
    Distro
    Ubuntu 6.06

    Re: HowTo: WPA with wpa_supplicant

    Thanks luca...

    Just so you know, I too was concerned about putting the psk key in there too, so I changed a few numbers in there. I figured you wanted to make sure I had one in there, so left it in (altered) for demonstration purposes.

    I assume by rebooting wpa_supplicant, you want me to either reboot the lappy or do a...

    Code:
    wpa_supplicant -Bw -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf
    at a terminal window prompt. After I do the wpa_supplicant command, do I have to do an...

    sudo ifconfig ath0 down
    sudo ifconfig ath0 up

    Thanks again.
    ASUS A8N32-SLI, AMD X2 4200+ (200x11=2.2GHz)
    Corsair XMS 2048 2-3-3-6-1T @ 2.6V, eVGA 7800GT , WD 74GB Raptor,WD 250GB Sata2
    Windows XP Pro, Ubuntu 6.06
    Dell C840 Lappy Ubuntu 6.06 w/WPA wifi, Dell P3 500 Ubuntu 6.06 w/SCSI scanner,samba

  5. #45
    Join Date
    Oct 2004
    Location
    Trailer Park
    Beans
    345
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HowTo: WPA with wpa_supplicant

    there is a bug in the 1.1.1 version of the ipw2200 driver that is included with ubuntu dapper/edgy etc and kernels (from linus) including 2.6.17

    the bug will show you the following messages repeatedly
    [4295722.986000] eth1: NETDEV_TX_BUSY returned; driver should report queue full via ieee_device->is_queue_full.

    this bug causes connection problems like disconnects - its behind alot of my connection troubles
    im compiling the new driver from source to try to solve my problems

  6. #46
    Join Date
    Apr 2005
    Beans
    514

    Re: HowTo: WPA with wpa_supplicant

    Quote Originally Posted by onioneater36 View Post
    Thanks luca...

    Just so you know, I too was concerned about putting the psk key in there too, so I changed a few numbers in there. I figured you wanted to make sure I had one in there, so left it in (altered) for demonstration purposes.

    I assume by rebooting wpa_supplicant, you want me to either reboot the lappy or do a...

    Code:
    wpa_supplicant -Bw -Dmadwifi -iath0 -c/etc/wpa_supplicant.conf
    at a terminal window prompt. After I do the wpa_supplicant command, do I have to do an...

    sudo ifconfig ath0 down
    sudo ifconfig ath0 up

    Thanks again.
    Yeah, that's what I meant.

  7. #47
    Join Date
    Apr 2005
    Beans
    514

    Re: HowTo: WPA with wpa_supplicant

    Quote Originally Posted by Magneto View Post
    there is a bug in the 1.1.1 version of the ipw2200 driver that is included with ubuntu dapper/edgy etc and kernels (from linus) including 2.6.17

    the bug will show you the following messages repeatedly
    [4295722.986000] eth1: NETDEV_TX_BUSY returned; driver should report queue full via ieee_device->is_queue_full.

    this bug causes connection problems like disconnects - its behind alot of my connection troubles
    im compiling the new driver from source to try to solve my problems
    Ok, good to know.
    Then let us know how it goes.

  8. #48
    Join Date
    Oct 2004
    Location
    Trailer Park
    Beans
    345
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HowTo: WPA with wpa_supplicant

    Quote Originally Posted by luca_linux View Post
    Ok, good to know.
    Then let us know how it goes.
    well I installed the latest ieee80211, wireless tools, ipw2200 firmware and ipw2200 drivers and its a big improvement

    no more queue full problems , no more disconnects every time I attempt to use the network

    its much more reliable now - no need for the hwcrypto=0 module option because the issue has been fixed

    one thing I did have to do is re-enable the apscan option in wpa_supplicant.conf because my essid is hidden and without that option I have serious problems trying to authenticate

    its pretty much the same process as your old howto although some make processes run the removal scripts automatically

    for me its really worth it - i have no idea why stable drivers and tools that have been out more than 6 months havent been included in ubuntu
    wireless tools is at 28 ubuntu is at 18
    ipw2200 is at 1.2.0 ubuntu is at 1.1.1
    ipw firmware is at 3.0 ubuntu is at 2.4
    same with ieee

  9. #49
    Join Date
    Sep 2006
    Beans
    26

    Re: HowTo: WPA with wpa_supplicant

    good to find this how-to. is it advisable to delete anything before trying this...ie network-manager, network-manager-gnome etc? thankyou.

  10. #50
    Join Date
    Apr 2005
    Beans
    514

    Re: HowTo: WPA with wpa_supplicant

    No, they shouldn't be a problem.

Page 5 of 16 FirstFirst ... 3456715 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •