Page 16 of 16 FirstFirst ... 6141516
Results 151 to 153 of 153

Thread: HowTo: WPA with wpa_supplicant

  1. #151
    Join Date
    Jan 2010
    Location
    India
    Beans
    16
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HowTo: WPA with wpa_supplicant

    @_cvt_

    I am facing the same issue.

    Surprisingly I am able to connect using network manager

    Successful connection using Network Manager (ubuntu 10.10 native)


    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) starting connection 'Auto safari'
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 3 -> 4 (reason 0)
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): bringing up device.
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0/wireless): access point 'Auto safari' has security, but secrets are required.
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 5 -> 6 (reason 0)
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 6 -> 4 (reason 0)
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0/wireless): connection 'Auto safari' has security, and secrets exist. No new secrets needed.
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: added 'ssid' value 'safari'
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: added 'scan_ssid' value '1'
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: added 'psk' value '<omitted>'
    Jan 5 15:14:21 Latitude NetworkManager[1005]: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
    Jan 5 15:14:21 Latitude NetworkManager[1005]: nm_setting_802_1x_get_pkcs11_module_path: assertion `NM_IS_SETTING_802_1X (setting)' failed
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> Config: set interface ap_scan to 1
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: inactive -> disconnected
    Jan 5 15:14:21 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: disconnected -> scanning
    Jan 5 15:14:23 Latitude wpa_supplicant[1130]: Trying to associate with 00:15:c7:fe:e0:60 (SSID='safari' freq=2437 MHz)
    Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: scanning -> associating
    Jan 5 15:14:23 Latitude wpa_supplicant[1130]: Associated with 00:15:c7:fe:e0:60
    Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: associating -> associated
    Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: associated -> 4-way handshake
    Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: 4-way handshake -> group handshake
    Jan 5 15:14:23 Latitude wpa_supplicant[1130]: WPA: Key negotiation completed with 00:15:c7:fe:e0:60 [PTK=TKIP GTK=TKIP]
    Jan 5 15:14:23 Latitude wpa_supplicant[1130]: CTRL-EVENT-CONNECTED - Connection to 00:15:c7:fe:e0:60 completed (reauth) [id=0 id_str=]
    Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> (wlan0): supplicant connection state: group handshake -> completed
    Jan 5 15:14:23 Latitude NetworkManager[1005]: <info> Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful. Connected to wireless network 'safari'.




    When I try doing so using terminal command line, getting to below issue :

    Wireless event: cmd=0x8b15 len=20
    Wireless event: new AP: 00:15:c7:fe:e0:60
    Association info event
    resp_ies - hexdump(len=42): 01 08 82 84 8b 0c 12 96 18 24 32 04 30 48 60 6c dd 18 00 50 f2 02 01 01 81 00 03 a4 00 00 27 a4 00 00 42 43 bc 00 62 32 66 00
    State: ASSOCIATING -> ASSOCIATED
    wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
    WEXT: Operstate: linkmode=-1, operstate=5
    Associated with 00:00:00:00:00:00
    WPA: Association event - clear replay counter
    WPA: Clear old PTK
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    EAPOL: External notification - EAP success=0
    EAPOL: External notification - portEnabled=1
    EAPOL: SUPP_PAE entering state CONNECTING
    EAPOL: SUPP_BE entering state IDLE
    Setting authentication timeout: 10 sec 0 usec
    Cancelling scan request
    RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
    RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
    Wireless event: cmd=0x8b15 len=20
    Wireless event: new AP: 00:00:00:00:00:00
    Setting scan request: 0 sec 100000 usec
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
    wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
    State: ASSOCIATED -> DISCONNECTED



    ctrl_interface=/var/run/wpa_supplicant

    network={
    ssid="safari"
    scan_ssid=1
    key_mgmt=WPA-PSK
    pairwise=TKIP
    group=TKIP
    psk="key is mine"


    All, Any help would appreciated !

  2. #152

    Talking Big thanks for this tutorial!

    I have an ancient(!) laptop that is running Ubuntu Desktop. However, I mainly (99.5%) use it as a server with console connections. Truth is, neither GNOME nor KDE runs very smoothly on P3/1.2GHz with 512MiB of SDRAM. In fact, the only reason I got the 'gdm' running at all is because I've never had time to learn the routines for "manually" connecting to a router with WPA2 security (after all, the 'nm-applet' is really smooth). But today I just had it. Lately, X has been eating up my RAM (and swap), and it's just not efficient. I looked in /etc/ but I had no 'wpa_supplicant.conf' file there, but(!) a directory called 'wpa_supplicant/' that contained three files (action_wpa.sh, functions.sh, ifupdown.sh). I looked at those but they were very confusing and I really don't seem needy to care for those.

    As it turned out, the only thing I needed to do to successfully connect was the following:

    Code:
    sudo -i
    wpa_passphrase NAMEOFMYSSID myactualwpapassphrase > /etc/wpa_supplicant.conf
    wpa_supplicant -B -ieth1 -c/etc/wpa_supplicant.conf
    dhclient eth1
    Done!

    I am now online with my machine. Of course, I will probably get issues when I eventually decide to reboot it. Oh, wait. In fact, as I'm running Ubuntu Desktop it will launch GDM and automatically connect with the nm-applet then anyways, so it's cool. However...
    gewone@LOSANGELES:~$ uptime
    22:47:53 up 163 days, 14:17, 6 users, load average: 0.00, 0.00, 0.03
    As you may realize, I have no plans on rebooting my laptop anytime soon. But when I do, I guess those few lines in '/etc/network/interfaces' will do the trick; sort of like an 'AUTOEXEC.BAT' executing (more or less) the commands I ran just now. Awesome.

    Again, big thanks for this thread!

  3. #153

    Re: HowTo: WPA with wpa_supplicant

    Hi. I'm new with these stuff so I hope I'm not being very stupid here. My problem is that in step 6, where you have to add the two lines, my
    "sudo gedit /etc/network/interfaces" doesn't look like the example "iface eth0 inet static
    address 192.168.1.15
    netmask 255.255.255.0
    wireless-essid my_essid
    gateway 192.168.1.1
    pre-up wpa_supplicant -Bw -Dwext -ieth0 -c/etc/wpa_supplicant.conf
    post-down killall -q wpa_supplicant"

    but it looks like this:
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    #NetworkManager#auto eth0
    #NetworkManager#iface eth0 inet dhcp


    Does anybody know what am I to do? Also, when my laptop starts I get this message "the disk drive for /dev/mapper/crypyswap1 is not ready yet or not present.
    Any help is very appreciated. Thank you

Page 16 of 16 FirstFirst ... 6141516

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •