Page 11 of 16 FirstFirst ... 910111213 ... LastLast
Results 101 to 110 of 153

Thread: HowTo: WPA with wpa_supplicant

  1. #101
    Join Date
    Dec 2005
    Location
    capital of beer
    Beans
    547

    Re: HowTo: WPA with wpa_supplicant

    Have you tried installing knetworkmanager? This is a superb KDE networking tool, which took care of all my wpa1+wpa2 worries in a jiffy.
    sudo apt-get install knetworkmanager
    will do the trick...
    repartitioning your installation / forever noob / Desktop on Debian Lenny / IBM T41 purring along on bog Kubuntu

  2. #102
    Join Date
    Apr 2007
    Beans
    30

    Re: HowTo: WPA with wpa_supplicant

    MY GOD!!! No wonder so few people are using Linux!

    This is ridiculous! I've been trying for days to get my wireless network running with WEP and it won't work. Runs fine with no encryption but no connection if I enable WEP. Someone referred me to this thread which is a real laugh. Imagine having to write all that code to get it going and to figure out that it's not working because you missed a space or put a coma in the wrong place. Guess I'll just run the unprotected connection and hope for the best - or maybe go back to Windows.

    Yes, yes, I know, WEP doesn't afford much protection, but it's better than nothing, so....

  3. #103
    Join Date
    May 2005
    Location
    Alpicat
    Beans
    223
    Distro
    Ubuntu Intrepid Ibex (testing)

    Re: HowTo: WPA with wpa_supplicant

    Just wanted to thank you for this. I really think it's worth the small effort.
    Incidentally, theblueray, if you don't want to miss a space or a coma (and save time and efforts), you can use copy+paste (just like in Windows).
    Last edited by Ferri; April 15th, 2007 at 08:48 AM.

  4. #104
    Join Date
    Apr 2007
    Beans
    28

    Re: HowTo: WPA with wpa_supplicant

    I too am having problems. I've read the thread and it feels like I'm close, but no cigar so far! The WLAN nic is an Intel 3945 which seems to be seeing the AP when using the wext driver (first I tried ipw3945 which didn't work at all).

    Here are the two scripts:

    /etc/network/interfaces

    auto eth1
    iface eth1 inet dhcp
    wireless-essid my_ssid
    pre-up wpa_supplicant -Bw -Dwext -i eth1 -c/etc/wpa_supplicant.conf
    post-down killall -q wpa_supplicant

    /etc/wpa_supplicant.conf

    ctrl_interface=/var/run/wpa_supplicant
    ap_scan=1

    network={
    ssid="my_ssid"
    scan_ssid=1
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group=CCMP TKIP
    psk=**HEX SSID PSK HERE**
    }


    I have tried altering the ap_scan parameter to no effect. Below is the output I'm getting:

    wpa_supplicant:

    gmason@gmason-laptop:~$ sudo wpa_supplicant -w -D wext -i eth1 -c/etc/wpa_supplicant.conf
    Trying to associate with 00:12:17:c6:d6:21 (SSID='my_ssid' freq=0 MHz)
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Associated with 00:12:17:c6:d6:21
    WPA: Invalid EAPOL-Key MIC when using TPTK - ignoring TPTK
    WPA: Could not verify EAPOL-Key MIC - dropping packet
    WPA: Invalid EAPOL-Key MIC when using TPTK - ignoring TPTK
    WPA: Could not verify EAPOL-Key MIC - dropping packet
    Authentication with 00:12:17:c6:d6:21 timed out.
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Trying to associate with 00:12:17:c6:d6:21 (SSID='my_ssid' freq=0 MHz)
    Associated with 00:12:17:c6:d6:21
    WPA: Key negotiation completed with 00:12:17:c6:d6:21 [PTK=TKIP GTK=TKIP]
    CTRL-EVENT-CONNECTED - Connection to 00:12:17:c6:d6:21 completed (auth) [id=0 id_str=]
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Trying to associate with 00:12:17:c6:d6:21 (SSID='my_ssid' freq=0 MHz)
    Associated with 00:12:17:c6:d6:21
    WPA: Key negotiation completed with 00:12:17:c6:d6:21 [PTK=TKIP GTK=TKIP]
    CTRL-EVENT-CONNECTED - Connection to 00:12:17:c6:d6:21 completed (reauth) [id=0 id_str=]
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Trying to associate with 00:12:17:c6:d6:21 (SSID='my_ssid' freq=0 MHz)
    WPA: EAPOL-Key Replay Counter did not increase - dropping packet
    Associated with 00:12:17:c6:d6:21
    WPA: Invalid EAPOL-Key MIC - dropping packet
    WPA: Invalid EAPOL-Key MIC - dropping packet
    Authentication with 00:12:17:c6:d6:21 timed out.
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Trying to associate with 00:12:17:c6:d6:21 (SSID='my_ssid' freq=0 MHz)
    Associated with 00:12:17:c6:d6:21


    iwevent:

    gmason@gmason-laptop:~$ iwevent
    Waiting for Wireless Events from interfaces...
    22:47:41.808334 eth1 Set Mode:Managed
    22:48:18.692070 eth1 Set Mode:Managed
    22:48:18.825691 eth1 Set Mode:Managed
    22:48:18.825989 eth1 New Access Point/Cell address:Not-Associated
    22:48:18.829216 eth1 Set ESSID:"my_ssid"
    22:48:21.954493 eth1 Set Mode:Managed
    22:48:21.954526 eth1 Set ESSID:"my_ssid"
    22:48:24.168036 eth1 New Access Point/Cell address:00:12:17:C66:21
    22:48:34.182031 eth1 New Access Point/Cell address:Not-Associated
    22:48:37.219635 eth1 Set Mode:Managed
    22:48:37.219666 eth1 Set ESSID:"my_ssid"
    22:48:37.289930 eth1 Set Mode:Managed
    22:48:37.289969 eth1 Set ESSID:"my_ssid"
    22:48:39.569407 eth1 New Access Point/Cell address:00:12:17:C66:21
    22:48:49.577559 eth1 New Access Point/Cell address:Not-Associated
    22:48:52.602852 eth1 Set Mode:Managed
    22:48:52.602886 eth1 Set ESSID:"my_ssid"
    22:48:52.682934 eth1 Set Mode:Managed

    Any help you could offer would be very gratefully received - I'm a new Linux convert and could really do with some wireless networking so I can stop using XP!!

    Thanks.

  5. #105
    Join Date
    Apr 2007
    Beans
    17

    Re: HowTo: WPA with wpa_supplicant

    I use a wpa-SPK wifi connection in my university and i have the same problem . I had followed many tutorials and links on the internet but havn't found yet the solution for the problem of connexion / deconnexion and this damn : access point/cell adress not associated

  6. #106
    Join Date
    Apr 2007
    Beans
    17

    Re: HowTo: WPA with wpa_supplicant

    Just a minute after the previous post , And i don't really know exactly how but the connexion on my laptop is working again ( im writing this post on it).
    So i ll post my /etc/networks/interface , and the last things i have done , perhaps that will help :
    Code:
    auto eth1
    wireless-essid ecole2007
    wpa-proto WPA 
    wpa-driver wext
    wpa-ssid ecole2007
    wpa-psk 84a4541e8458fa5a2c55erhdaadgt9d93823ebc62ecba40da2d9b5201d930cea1 
    wpa-key-mgmt WPA-PSK
    wpa-pairwise TKIP 
    wpa-group TKIP 
            
       # wpa-auth-alg shared
    iface eth1 inet static
    address 192.168.1.193
    netmask 255.255.255.0
    gateway 192.168.1.1
    and then i typed in the terminal : sudo ifup eth1

    Code:
    16:40:44.476515   eth1     Set ESSID:"ecole2007"
    16:40:47.524171   eth1     New Access Point/Cell address:Not-Associated
    16:40:57.481198   eth1     Set Mode:Managed
    16:40:57.481336   eth1     Set ESSID:"ecole2007"
    16:40:58.102992   eth1     New Access Point/Cell address:00:08:A1:92:CE:A8
    16:41:09.369986   eth1     New Access Point/Cell address:Not-Associated
    16:41:12.374007   eth1     Set Mode:Managed
    16:41:12.374140   eth1     Set ESSID:"ecole2007"
    16:41:15.354509   eth1     New Access Point/Cell address:Not-Associated
    16:41:25.375204   eth1     Set Mode:Managed
    16:41:25.375350   eth1     Set ESSID:"ecole2007"
    16:41:25.752524   eth1     New Access Point/Cell address:00:08:A1:92:CE:A8
    16:41:36.868107   eth1     New Access Point/Cell address:Not-Associated
    16:41:39.871704   eth1     Set Mode:Managed
    16:41:39.871836   eth1     Set ESSID:"ecole2007"
    16:41:42.803981   eth1     New Access Point/Cell address:Not-Associated
    16:41:52.872471   eth1     Set Mode:Managed
    16:41:52.872604   eth1     Set ESSID:"ecole2007"
    16:41:53.219041   eth1     New Access Point/Cell address:00:08:A1:92:CE:A8
    16:42:04.378317   eth1     New Access Point/Cell address:Not-Associated
    Wich was the same damn output meaning no permanent connexion .I finally typed in the terminal :



    finally typed in the terminal
    Code:
    $  iwlist  eth1 scan ;sleep 2
    And then the iwevent stopped and the connexion was finnaly established , but i don't really know if the last command i typed resolved the problem or it is simply by chance .Im now effrayed that if i shutdown my pc i l not be enabled to get reconnected
    Last edited by aminesay; April 21st, 2007 at 10:42 AM.

  7. #107
    Join Date
    Mar 2005
    Location
    Seattle
    Beans
    161
    Distro
    Edgy Eft Testing

    Re: HowTo: WPA: EAPOL-Key Replay Counter did not increase - dropping packet

    here is my first attempt at getting wpa_supplicant working. Everytime I try using network-manager my computer crashed so I'm trying to get wpa_supplicant working. If you scroll down to the end I think I'm most sucessful there. I tried most of the hints on the post about removing RSN and changing the ap number from 0 to 1 etc. Anybody know how i can get this to work?

    colin@multiX:~$ sudo wpa_supplicant -Dwext -i wlan0 -c/etc/wpa_supplicant.conf
    Password:
    Trying to associate with 00:0f:b3:48:f4:65 (SSID='blarghjr' freq=2427 MHz)
    Authentication with 00:00:00:00:00:00 timed out.

    here i tried specifying ndiswrapper
    colin@multiX:~$ sudo wpa_supplicant -Dndiswrapper -i wlan0 -c/etc/wpa_supplicant.conf
    Trying to associate with 00:0f:b3:48:f4:65 (SSID='blarghjr' freq=2427 MHz)
    Association request to the driver failed

    here I started changing some of the settings suggested from 0 to 1 etc.
    colin@multiX:~$ sudo wpa_supplicant -Dwext -i wlan0 -c/etc/wpa_supplicant.conf
    bind(PF_UNIX): Address already in use
    Trying to associate with 00:0f:b3:48:f4:65 (SSID='blarghjr' freq=2427 MHz)
    Authentication with 00:00:00:00:00:00 timed out.
    Trying to associate with 00:00:00:00:00:00 (SSID='blarghjr' freq=2427 MHz)
    WPA: EAPOL-Key Replay Counter did not increase - dropping packet
    WPA: EAPOL-Key Replay Counter did not increase - dropping packet
    WPA: EAPOL-Key Replay Counter did not increase - dropping packet


    finally i changed some more settings inside wpa_supplicant.conf and now it associates but has that key replay counter message

    colin@multiX:~$ sudo wpa_supplicant -Dwext -i wlan0 -c/etc/wpa_supplicant.conf
    Trying to associate with 00:0f:b3:48:f4:65 (SSID='blarghjr' freq=2427 MHz)
    Associated with 00:0f:b3:48:f4:65
    WPA: EAPOL-Key Replay Counter did not increase - dropping packet
    Authentication with 00:0f:b3:48:f4:65 timed out.
    CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    Trying to associate with 00:0f:b3:48:f4:65 (SSID='blarghjr' freq=2427 MHz)
    Associated with 00:0f:b3:48:f4:65
    WPA: EAPOL-Key Replay Counter did not increase - dropping packet

  8. #108
    Join Date
    May 2007
    Beans
    1

    Re: HowTo: WPA with wpa_supplicant

    This thread is great. However, I am trying to setup a WPA2 connection using an internal Cisco WLAN + ACS connection. It woks fine with WIN***, but I can't get connected with Linux.

    I have a Cisco B/G card (using the Atheros chipset = 'madwifi' driver)

    My wpa_supplicant.conf file contains:

    ssid="ap1"
    auth_alg=OPEN
    key_mgmt=WPA-EAP
    proto=WPA2
    eap=PEAP
    identity="[username]"
    password="[password]"
    phase2="auth=MSCHAPV2"
    scan_ssid=1

    I am not able to connect. Anyone have any suggestions for using WPA2 with EAP/PEAP? Basically, the problem is that i am not able to associate with the AP. The AP is able to see my connection attempt for about 1 second, then shows no connections.

    **********************************************

    Answering my own question (for anyone else who might be interested).

    Looks like the madwifi driver (and probably wext also) doesn't support WPA2. Time to try ndiswrapper?
    Last edited by eCartman; May 23rd, 2007 at 11:34 PM. Reason: Update

  9. #109
    Join Date
    Apr 2007
    Beans
    27

    Re: HowTo: WPA with wpa_supplicant

    I wouldn't even bother with Gnome-Network-Manager, it seems only to work for the few privileged . Ive spent 40 hrs plus and got nowhere. I ended up giving Wicd a try (ver 1.3.1), and HEY BINGO !!!! WPA Encryption works everytime. And for a newbie (GUI Girlie) like me, it was easy as hell.
    The guy who wrote the software has made a great piece of kit, can (X)buntu get this into the repos as standard, Id even be happy to write a howto for it as well.

  10. #110
    Join Date
    Jun 2006
    Beans
    19

    Re: HowTo: WPA with wpa_supplicant

    Quote Originally Posted by phillipchandler View Post
    I wouldn't even bother with Gnome-Network-Manager, it seems only to work for the few privileged . Ive spent 40 hrs plus and got nowhere. I ended up giving Wicd a try (ver 1.3.1), and HEY BINGO !!!! WPA Encryption works everytime. And for a newbie (GUI Girlie) like me, it was easy as hell.
    The guy who wrote the software has made a great piece of kit, can (X)buntu get this into the repos as standard, Id even be happy to write a howto for it as well.
    I would like to second that. Network Manager (Fiesty) does not detect my Intel 2915ABG wireless (Dell 630M laptop). I did get it working by setting up wpa supplicant and the etc/network/interfaces file, but it was coded only for my home network so roaming was a challenge!

    Wicd installed and ran in a couple of minutes and everything just works!!!

    A great piece of work.

    T

Page 11 of 16 FirstFirst ... 910111213 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •