Page 1 of 9 123 ... LastLast
Results 1 to 10 of 82

Thread: HOWTO: Get your microphone to work

  1. #1
    Join Date
    Feb 2007
    Location
    In my chair
    Beans
    1,485

    HOWTO: Get your microphone to work

    I wrote this when I was new to Ubuntu. Most of the time people are having microphone problems it is from driver problems and not just the sound settings as described in this guide. I'm leaving the guide up because it contains some potentially useful information for a small minority of newcomers.

    A big thanks to pppoe_dude who initially helped me get my microphone working on IRC when I didn't know what I was doing.

    If you have a problem then say what steps you tried and what didn't work about it. For instance, you should make your post as specific as possible: "I tried enabling all of the check boxes in the preferences but after I raised the volume and turned the "Capture on" for the "Capture Control" I still don't have my mic working!". Without such information it is impossible to diagnose anything. Finally, you can attach a screenshot if you're confused (Alt+PrintScreen).
    This Guide is specifically for Ubuntu (GNOME).

    Overall Objective: Explain how to enable and configure the microphone capture for a sound card.

    Specific Objective: Enable hidden sound channels, raise the volume and enable the capture for them, and test the microphone.
    If all else fails, use alsamixer (console) to select which channels to capture from.
    Finally, "Common Fixes" are listed at the bottom.



    Before you do this, you'll want to make sure your Sound Capture in System-->Preferences-->Sound is set to ALSA (or OSS if you know ALSA doesn't work for some reason).


    Goto your Volume Control


    Goto Edit-->Preferences inside the volume control and check every check box.
    (The controls you need to enable may be named something such as "Microphone", "Mix Capture", "Capture", or "Front Mic". If you are unsure then just enable everything.)
    (For instance, if you hear yourself echoing when you have a playback control called "Analog Mix" enabled, the control that needs to be enabled will be named something like "Analog Mix Capture" or "Analog Mix Mic".)


    Now, click on the Capture tab and you should see a few (or a lot!) of controls here. Make sure every control on the Capture tab doesn't have an
    "X" on the microphone icon. Now, raise the volume of each control to maximum.

    [Sidenote: On one of my sound cards I have the PCM's Capture (the microphone icon) turned off because that Captures (records) anything that
    is playing on my speakers.]

    My Audigy 4 Non-Pro's Capture settings:


    My nForce2 sound card's Capture settings:


    Now, on the Switches tab you'll want to make sure "Mic Boost (+20dB)" and "Microphone Capture" are checked (if you have them).

    My Audigy 4 Switches Tab:


    My nForce2 Switches Tab:


    Hopefully, now your microphone works! You can test your settings by running
    Code:
    vumeter -r &
    on the shell. You should see vumeter light up while you tap on the microphone (I recommend tapping in case there is a temporary problem with the capture volume being too low). If you change your sound settings correctly, you should immediately be able to see your microphone activity on the vumeter (without restarting vumeter, that is).





    Finally, if you are still having problems, your capture may be set on the wrong channels.

    http://www.ubuntuforums.org/showthread.php?t=255071#10
    Quote Originally Posted by danielph
    Run
    Code:
    alsamixer
    in console.. Go into the playback "tab" and mute mic. Go into the capture tab, I think f4 and hit space on Mic and space on capture until L R Capture is red under both Mic and Capture. make sure you turn up the volume using the up arrows.


    Here are screenshots from alsamixer for each of my soundcards.






    List of other common fixes:
    Enable "Full Duplex" for your sound card.
    Disabling "IEC958" on the capture tab.
    In Volume Control, when you goto File-->Change Device.. make sure your (Alsa mixer) is the device enabled.

    If anyone has criticisms or additions to this post I'll update it.
    Last edited by Cappy; November 28th, 2007 at 08:24 AM.

  2. #2
    Join Date
    Feb 2006
    Beans
    60

    Re: HOWTO: Get your microphone to work

    I only have one soundcard and alsamixer shows something similar to your second last screenshot, except that I only have line, mic and capture. How do I turn the volume under mic to full. I tried the arrow up but nothing happen.

    Thanks.

  3. #3
    Join Date
    Feb 2007
    Location
    In my chair
    Beans
    1,485

    Re: HOWTO: Get your microphone to work

    You control the volume on the Capture control, not the microphone control. Turn the L R CAPTURE on for both of those controls with the Space Bar.

  4. #4
    Join Date
    Feb 2006
    Beans
    60

    Re: HOWTO: Get your microphone to work

    The volume on the Capture control is already at maximum from beginning but my microphone is still not working. My card is HDA Intel.

    Please advise.
    Thanks.

  5. #5
    Join Date
    Feb 2007
    Location
    In my chair
    Beans
    1,485

    Re: HOWTO: Get your microphone to work

    *bump*
    Currently favorite songs:
    Miss Hyde, This Song Is About Monsters, Masagin, I Will Try to Blow it Out, La Resistance
    Visit www.cherrypeel.com for more free indie music =)

  6. #6
    Join Date
    Mar 2007
    Location
    India
    Beans
    24
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: HOWTO: Get your microphone to work

    none of the above worked for me, but I changed from ubuntu to kubuntu, at first the mic still wasn't working, then I used automatrix and all the problems with the mic and sound were gone!
    I don't know if it was to do with the codex s or what. On ubuntu I hadn't installed them yet, so I don't know. I just thought it might help some one.

  7. #7
    Join Date
    Feb 2007
    Location
    In my chair
    Beans
    1,485

    Re: HOWTO: Get your microphone to work

    Quote Originally Posted by brigit View Post
    none of the above worked for me, but I changed from ubuntu to kubuntu, at first the mic still wasn't working, then I used automatrix and all the problems with the mic and sound were gone!
    I don't know if it was to do with the codex s or what. On ubuntu I hadn't installed them yet, so I don't know. I just thought it might help some one.
    If you had problems with sound also then it would be a completely different problem. It is possible you were missing some kind of library and automatix installed it while installing other things.
    Currently favorite songs:
    Miss Hyde, This Song Is About Monsters, Masagin, I Will Try to Blow it Out, La Resistance
    Visit www.cherrypeel.com for more free indie music =)

  8. #8
    Join Date
    Aug 2007
    Beans
    12

    Re: HOWTO: Get your microphone to work

    Hi,

    I tried exactly what this guide said:

    1. I made sure that on the recording tab (which contains microhphone only), the Capture slider is at it's max, and the microphone icon is not with red x.
    2. On the switches tab, I checked:
    Microphone Capture, microphone boost, iec958 capture, Analog to iec958 output.

    Why can't I still get the mic to work?

  9. #9
    Join Date
    Feb 2007
    Beans
    65

    Re: HOWTO: Get your microphone to work

    My first post, after reading 17646823787364 ones about mic not working, here is what i did after trial and error to get my mic working (also the crashing of sound recorder stopped . Right click sound icon in tray > open volume control > edit > preferences > checkmark all what is there > close. At the playback tab microphone should be UNMUTED. At the capture tab, CAPTURE should be UNMUTED, both "columns". At the switches tab, THE CULPRIT SEEMED TO BE "IEC958 CAPTURE", UNCHECK IT!, check microphone capture, micboost, iec958 (the clear one), duplicate front and external amplifier. At the options tab mic select > mic1. Close everything. Applications > Sound & Video > Sound Recorder, record from input: microphone (worked with capture for me, too). HIt record, say alphabet, hit stop. To not crash the sound recorder don't hit the toolbar save icon, use file > save as, and finally play button. Hope this will work for you too.

  10. #10
    Join Date
    Oct 2005
    Beans
    654
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Re: HOWTO: Get your microphone to work

    Hi Cappy and all--

    Sure hope you can help me get this working.

    I have 6.06, with an HDA intel card, ALSA mixer is selected. I have checked my microphone (external) on another computer, and it works there. System >preferences > sound is set to enable ESD; play system sounds. System beep is enabled, but not visual system beep.

    gnome-volume-control has all these things in playback, all enabled and set to highest level: PCM, front, front mic, surround, center, lfe, line-in, cd, microphone, pc speaker. (I have no blue plug on the front for the microphone--only on the back. Yup, it is plugged in!) There are no other options.

    Under the capture tab, both capture and capture 1 are enabled and at full volume. There are no other options.

    Under the switches tab, headphone is checked. There are no other options.

    Under the options tab, the only options are Channel Mode (set to 2 ch); input source (set to Mic) and a second input source (also set to Mic).

    Under preferences the selected tracks are all that are available: headphone, pcm, front, front mic, surround, center, lfe, line-in cd, microphone, pc speaker, capture, capture 1, channel mode, input source, input source.

    When I run vumeter -r & I get two bars: the top one has one green bar that flashes, the bottom one has one bar lit continually, and the second flashes a little less often than the top one. It does not react to talking into the microphone.

    Sound Recorder records no sound.

    I am wondering: is it possible that I need to install some software to make this work? Seems to me I needed to do so on my Feisty laptop yesterday....

    Other ideas? How should I trouble-shoot this?

    Thanks for your help!
    :- Doug.

Page 1 of 9 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •