Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: HOWTO: Fluxbox inside GNOME (BETA)

  1. #1
    Join Date
    Feb 2005
    Location
    Planet NoVA
    Beans
    2,091
    Distro
    Ubuntu 11.04 Natty Narwhal

    HOWTO: Fluxbox inside GNOME (BETA)

    Earlier, I asked whether it would be possible to run Fluxbox as Gnome's default windowmanager instead of metacity.

    I am pleased to report that this is possible. Consider this a draft howto, as I am busy trying to tweak things.

    I am indebted to poofyhairguy's "enlightened gnome" howto, as well as Stormy Eyes' excellent advice on running Openbox within Gnome

    STEP ONE: Installing Fluxbox

    This is the easy part. Fluxbox is in universe; enable universe, fire up your terminal, and
    Code:
    $ sudo apt-get install fluxbox
    that sucker.

    You can restart the Xsession here, if you like. When GDM comes up, you'll see Fluxbox added to your "Sessions" menu.

    However, I would NOT restart the Xsession at this point. Fire up your terminal and
    Code:
    $ sudo /usr/share/xsessions/fluxbox.desktop
    where you see
    Code:
    exec=fluxbox
    replace that line with
    Code:
    exec=startfluxbox
    If you do this, Fluxbox will, on its first execution, generate a configuration file:

    ~/.fluxbox/startup

    For a more complete discussion of what the startup file does in Fluxbox, please see This page in the Gentoo Wiki

    Log into fluxbox, and confirm that it does, indeed work. We are now ready for

    STEP TWO: Cramming Fluxbox into Gnome

    This next section is essentially ripped off of poofyhairguy's excellent, and recently slashdotted, Enlightened Gnome Howto.

    First, execute the following in a regular terminal:
    Code:
    $ sudo cp /usr/share/gnome/default.session ~/.gnome2/session
    Then, edit that session file:
    Code:
     sudo gedit ~/.gnome2/session
    Find this line:
    Code:
     1,RestartCommand=gnome-wm --sm-client-id default1
    and change it to this:
    Code:
     1,RestartCommand=gnome-wm --default-wm fluxbox --sm-client-id default1
    Save the file, restart your Xsession (CTRL+ALT+BKSPACE), and log back into gnome.

    This will take a while. You will see fluxbox first, then the gnome-panel, and finally the desktop will appear and draw over all the fluxbox desktop.

    Fluxbox in Gnome: First impressions

    Fluxbox is a very lightweight windowmanager. Not for nothing is it the wm of choice of DamnSmallLinux From what I can tell, it takes up VERY little RAM.

    It also draws and redraws faster than metacity, at least on my equipment--AMD k7, 512 MB RAM, nvidia geforce 5200 128mb VRAM-- and much neater as well.

    Here's a neat trick that Fluxbox does: open two windows. Now middle-click drag one onto another. The two windows are now docked together: clicking on the titlebar will switch between windows. In this way, you can tab through any number of windows. This is particularly nice if you run stuff from terminals--that way, you can have the app in one window, then click the window itself and get the debug output.

    Things I've got to figure out:

    The nautilus desktop draws over fluxbox. Thus, no flux taskbar and no slit (the flux name for the dock).

    Also, I can't get flux's right-click menu. Middle-click works.

    Comments are ALWAYS welcome. A huge shout and thanks to the whole Ubuntu community--y'all rock, hard.

    And of course, a screenshot of my desktop. The wm is fluxbox, and an assload of gdesklets running.
    Last edited by Brunellus; September 9th, 2005 at 03:24 AM. Reason: Beta

  2. #2
    Join Date
    Jan 2005
    Beans
    50
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    After doing the E16 into Gnome, I think you can get the right click menus and get some of Flux back by going into the Configuration Editor and telling Nautilus to not draw the desktop. I forget exactly where it is, but that should do it.

  3. #3
    Join Date
    Aug 2005
    Location
    Canada
    Beans
    284
    Distro
    Ubuntu Breezy 5.10

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    It worked decently, just gnome and fluxbox conflict... Fluxbox brings along its bottom bar thingy...

    Also, wikipedia says fluxbox isnt good in ubuntu because of some utf-8 encoding or something.

    But, good trick to change WMs

  4. #4
    Join Date
    Jun 2005
    Location
    USA
    Beans
    103
    Distro
    Dapper Drake Testing/

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    Quote Originally Posted by Brunellus
    Fire up your terminal and
    Code:
    $ sudo /usr/share/xsessions/fluxbox.desktop
    Should be:
    Code:
    $ sudo gedit /usr/share/xsessions/fluxbox.desktop
    Want an invite to Gmail? Email or PM me!

  5. #5
    Join Date
    Sep 2005
    Beans
    1

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    Thank you for this guide. I love this mix

    One problem I seem to have is that Gnome takes about 2 mins to load up every time. Fluxbox starts straight away but the splash screen for gnome seems to stop at the Windows Manager stage for 2 mins then it loads up fine.

    Anyone else have this problem?

    thanks in advance

  6. #6
    Join Date
    Jun 2006
    Location
    Brisbane
    Beans
    1,457
    Distro
    Hardy Heron (Ubuntu Development)

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    Quote Originally Posted by Brunellus View Post
    Things I've got to figure out:

    The nautilus desktop draws over fluxbox. Thus, no flux taskbar and no slit (the flux name for the dock).
    If you run nautilus from the terminal with
    Code:
    nautilus --no-desktop
    it won't draw over fluxbox.
    "Total paranoia is just total awareness." - Charles Manson

  7. #7
    Join Date
    Mar 2007
    Beans
    14

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    I'm going to try this, will report any problems here.

  8. #8
    Join Date
    Feb 2008
    Location
    U.S.A
    Beans
    782

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    is there an updated version of this? i am trying to do this and the files mention are either not there or somewhere else.

  9. #9
    Join Date
    Jan 2009
    Location
    Bucharest,Romania.
    Beans
    104
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    Somehow I screwed my pseudo-transparency and especially menu alpha transparency in my fluxbox session.I installed xcompmgr too but I didn't know I have to disable the force pseudo-transparency first.So,despite the fact I removed completely xcompmgr and transset,the problem still persists.
    I can't even disable the pseudo-transparency from configuration menu,it remained stuck with focused window alpha:255,unfocused window alpha:175,and menu alpha:255.
    Do I have to reinstall the fluxbox wm again?
    Edit:Solved in the end.Disabled pseudo-transparency from init file from ~/fluxbox/,reinstalled xcompmgr,restart,and now all is OK.Fluxbox in its maximum way:
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2009-07-27-223647_1280x1024_scrot.jpg 
Views:	133 
Size:	199.5 KB 
ID:	122636  
    Last edited by stanca; July 27th, 2009 at 08:53 PM.

  10. #10
    Join Date
    Dec 2009
    Location
    Alberta, Canada
    Beans
    1

    Re: HOWTO: Fluxbox inside GNOME (BETA)

    Hi.
    Just found this great HOWTO. I am trying it on Ubuntu 8.04 (equivalent). Have a few questions if I may:

    1. Everything seems to be running fine. Just as Brunellus mentioned: windows do appear to be drawing faster. How do I know if I really am running Flux? I tried 'ps -elf | grep flux' and got nothing.
    2. The application tabbing, which is the primary reason why I wanted to do this, does not seem to be working. When I middle-click on a window, it gets sent to the background! I think this may be some sort of GNOME setting, however I have no idea where it is. Any help?

    Thank You.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •