Page 16 of 25 FirstFirst ... 61415161718 ... LastLast
Results 151 to 160 of 250

Thread: 32-Bit Chroot How-To

  1. #151
    Join Date
    Oct 2005
    Location
    Salem, OR
    Beans
    16
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: 32-Bit Chroot How-To

    Quote Originally Posted by Alabama_Man
    my usb-gamepad only works with a generic driver(2 buttons, 2 axis!!!) in chroot, although it works perfect in my normal enviroment.
    I have the same problem with my xbox controller. If you figure anything out, post here.

  2. #152

    Re: HOWTO: 32-Bit Chroot on 64-Bit Installs

    Hi all,
    I've followed your instructions but cannot apt-get install anything after "dchroot -d".

    The system complains:
    > dpkg: syntax error: unknown user `postfix' in statusoverride file

    Have I missed something? Note that I'm using shadowed passwords.

    Thanks for your advice,
    Pieter Van Gorp

  3. #153

    Re: HOWTO: 32-Bit Chroot on 64-Bit Installs

    I solved the problem by creating a user 'postfix' in group 'postdrop':
    adduser --ingroup postdrop postfix

    This was suggested in another thread.

    Cheers,
    Pieter.

  4. #154
    Join Date
    Apr 2005
    Beans
    7

    Re: 32-Bit Chroot How-To

    In response to the perl locale problems mentioned earlier (perl: warning: Setting locale failed), installing language-pack-en-base seemed to fix it for me.

  5. #155
    Join Date
    Feb 2006
    Location
    Phoenix, Az
    Beans
    28
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Question Re: 32-Bit Chroot How-To

    n00b question:
    Everthing went well... even ran synaptic, but after restarting my machine, I can't run anything using X. Here's my output...
    Code:
    (synaptic:11343): Gtk-WARNING **: cannot open display:
    Any ideas?


  6. #156
    Join Date
    Feb 2006
    Location
    Phoenix, Az
    Beans
    28
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: 32-Bit Chroot How-To

    Quote Originally Posted by jinxed
    n00b question:
    Everthing went well... even ran synaptic, but after restarting my machine, I can't run anything using X. Here's my output...
    Code:
    (synaptic:11343): Gtk-WARNING **: cannot open display:
    Any ideas?

    Nevermind... I'm a moron

    forgot to use the -d option...

  7. #157
    Join Date
    Mar 2006
    Location
    Venice, ITALY
    Beans
    37
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: 32-Bit Chroot How-To

    I have been reading this looooong thread but I haven't found any answer to my (simple) problem.

    I applied the how-to and it worked fine (btw GREAT thanks a lot).

    My problem is that the 32 bit applications (such as firefox32) are in english and not in my own language (as all other apps).

    Does anybody have a tip?

    Thanks

    Fede

  8. #158
    Join Date
    Mar 2006
    Location
    Venice, ITALY
    Beans
    37
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: 32-Bit Chroot How-To

    I can live with en_US messages.

    I had big big huge problem: all the applications x32 couldn't print. Now it is worse.

    I thought "I do a smart thing: I install cups+gnome-cups-manager, in the 32 environment and I'll be allset".

    I end up that I can't print from the original 64 bit environment and I still can't print from the x32 application.

    What can I do, now?

    Thanks

    Fede

  9. #159
    Join Date
    Mar 2006
    Beans
    7

    Re: 32-Bit Chroot How-To

    When ever I run "dpkg-reconfigure locales" and select and of the en_US locales, I get this error.
    root@dragon64:/# dpkg-reconfigure locales
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = "en",
    LC_ALL = (unset),
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    /usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
    I've also tried setting to a different english, such as GB, but I still get that error.

  10. #160
    Join Date
    Dec 2005
    Beans
    4

    Re: 32-Bit Chroot How-To

    Quote Originally Posted by mune
    I can live with en_US messages.

    I had big big huge problem: all the applications x32 couldn't print. Now it is worse.

    I thought "I do a smart thing: I install cups+gnome-cups-manager, in the 32 environment and I'll be allset".

    I end up that I can't print from the original 64 bit environment and I still can't print from the x32 application.

    What can I do, now?

    Thanks

    Fede
    I had the same problem. I found that there were 2 different problems not allowing me to print. The first: upgrading my kernel to 2.6.12-10-amd64-generic caused all printing to stop. I reverted to the previous kernel ( 2.6.12-9-amd64-generic) and printing started again.

    The second problem was printing in my chroot. I saw on another thread that I should also install cupsys-bsd in my chroot environment. That seems to have solved the problem of not printing.

Page 16 of 25 FirstFirst ... 61415161718 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •