Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

  1. #1
    Join Date
    May 2009
    Beans
    12

    Smile HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    You experience Screen Tearing when watching video in Compiz? Here is the solution:

    First:
    Type in Terminal
    Code:
    sudo apt-get install compizconfig-settings-manager
    Open: CompizConfig Settings Manager: (System -> Preferences -> CompizConfig Settings Manager)
    Find: General Options - Display Settings
    Change:

    • "Sync To VBlank" to "enabled"


    Second:

    Open: Nvidia X Server Settings: (System -> System Settings -> Nvida X Server Settings)
    Find: OpenGL Settings
    Change:

    • "Sync To VBlank" to "enabled"


    Third:

    Open: System -> Preferences -> Startup Applications
    Add a new entry:

    • Name: "Nvidia Settings"
    • Command: "nvidia-settings --load-config-only "


    Optional:

    For a smoother window movement and compiz-cube rotation, set "refresh rate" equal to the refresh rate of your monitor (nvidia-settings -q RefreshRate).
    Compiz incorrectly detects a bogus refresh rate because of nvidias dynamic-twinview solution.

    Open: CompizConfig Settings Manager: (System -> Preferences -> CompizConfig Settings Manager)
    Find: General Options - Display Settings
    Change:

    • "Detect Refresh Rate" to "disabled"
    • "Refresh Rate" to "60"

    Hint: You could set the refresh rate of compiz double the refresh rate of your monitor (120 in my case) for extra smoothiness!



    restart X. (sudo restart gdm)


    There you go, no more tearing.
    Last edited by kopiwe; January 29th, 2010 at 03:33 AM. Reason: Update: Added Optional Setting

  2. #2
    Join Date
    Aug 2009
    Location
    Las Vegas
    Beans
    62
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Cool...i did a search for sync to vblank but came up with nothing...is this for weaker gcards?

  3. #3
    Join Date
    Jan 2010
    Beans
    1

    Smile Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Hi, thank you for you How To. I was waiting for these since 1 year

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Unfortunately, that doesn't work for everyone. On my machine, the tearing is fixed this way.

  5. #5
    Join Date
    Jan 2010
    Beans
    1

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Wow! Nice tutorial. It worked like a charm on my side.
    Thanks!
    -Daniel

  6. #6
    Join Date
    Feb 2008
    Beans
    8

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Doesn't work for me, my pdf are still unreadable. The only solution at the moment is using Metacity.

  7. #7
    Join Date
    Dec 2005
    Location
    Wisconsin, USA
    Beans
    20
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    This worked perfectly for me - thank you so much! Excellent tutorial.

  8. #8
    Join Date
    Dec 2006
    Location
    Hornbeck, La
    Beans
    426
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Is the command "nvidia-settings -(one)" or nvidia-settings -(small L)" ??
    When I use the copy and paste in terminal I can't tell which one is input for the command. I used the copy and paste, but just wondering which one it is.
    HP Pavilion -- 4 Gig RAM -- 750 GIG HD -- Zorin 7.0 // Still Rockin' 13.10 -- Testing 14.04 -- Nuttin' but LINUX !

  9. #9
    Join Date
    Apr 2007
    Beans
    1,110
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Here don't listen to those guys...just kidding!

    if you want nvidia-settings to globally stick, you need to put nvidia-settings -l into Xsessions

    in kubuntu it is

    #sudo kate /etc/X11/Xsession


    in ubuntu it is


    #sudo gedit /etc/X11/Xsession

    and paste the "its little l by the way"

    the portion should look like this

    Code:
    #!/bin/sh
    #
    # /etc/X11/Xsession
    #
    # global Xsession file -- used by display managers and xinit (startx)
    
    # $Id: Xsession 967 2005-12-27 07:20:55Z dnusinow $
    nvidia-settings -l
    set -e
    and then you have the rest of the code which im not posting.

    anyway, reboot and it takes effect. If you want to test it out, open up nvidia-settings, then raise the brightness, close and reboot. then you will see that the drivers take effect. This is the perfect way to get nvidia-settings to stick in all user desktops.

    Now I recommend kaffeine for kde and smplayer or kaffeine for gnome. Make sure in smplayer, you use direct rendering and ......damn i forgot..ohh yeah use opengl. This syncs video playback. Fix compiz normaly like you do. Since nvidia-settings kicks in before compiz fusion, this fixes all problems because compiz kicks in after. so nvidia settings will stick.


    Everybody has been looking for the secret sauce and here it is. The guy who posted ontop is partially correct but it only works for hary and lower. You need to have nvidia-settings start off before compiz starts or settings will not stick.


    do the brightness check and you'll see the difference and dont forget to reset brightness before you forget..... also if your using a compositor, nvidia-settings will take effect after a reboot. If your not, then you need to not reboot....lol
    Last edited by Cresho; January 28th, 2010 at 10:25 AM.

  10. #10
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Kubuntu 11.04 Natty Narwhal

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Quote Originally Posted by Cresho View Post
    Here don't listen to those guys...just kidding!

    if you want nvidia-settings to globally stick, you need to put nvidia-settings -l into Xsessions

    in kubuntu it is

    #sudo kate /etc/X11/Xsession


    in ubuntu it is


    #sudo gedit /etc/X11/Xsession

    and paste the "its little l by the way"

    the portion should look like this

    Code:
    #!/bin/sh
    #
    # /etc/X11/Xsession
    #
    # global Xsession file -- used by display managers and xinit (startx)
    
    # $Id: Xsession 967 2005-12-27 07:20:55Z dnusinow $
    nvidia-settings -l
    set -e
    and then you have the rest of the code which im not posting.

    anyway, reboot and it takes effect. If you want to test it out, open up nvidia-settings, then raise the brightness, close and reboot. then you will see that the drivers take effect. This is the perfect way to get nvidia-settings to stick in all user desktops.

    Now I recommend kaffeine for kde and smplayer or kaffeine for gnome. Make sure in smplayer, you use direct rendering and ......damn i forgot..ohh yeah use opengl. This syncs video playback. Fix compiz normaly like you do. Since nvidia-settings kicks in before compiz fusion, this fixes all problems because compiz kicks in after. so nvidia settings will stick.


    Everybody has been looking for the secret sauce and here it is. The guy who posted ontop is partially correct but it only works for hary and lower. You need to have nvidia-settings start off before compiz starts or settings will not stick.


    do the brightness check and you'll see the difference and dont forget to reset brightness before you forget..... also if your using a compositor, nvidia-settings will take effect after a reboot. If your not, then you need to not reboot....lol
    I use a script which runs nvidia-settings -l before compiz starts to have AntiAliasing running (Cube looks much better)...thought with your solution I could get rid of it,but your solution does not work.
    Tested it on Karmic and Lucid....(did not test brightness but AA and AF)

    Edit:
    Surprisingly nvidia-settings -l in autostart does the job on Lucid....
    Last edited by realzippy; January 28th, 2010 at 11:39 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •