Page 9 of 19 FirstFirst ... 7891011 ... LastLast
Results 81 to 90 of 190

Thread: HOWTO: Set your system up for Wake On LAN (WOL)

  1. #81
    Join Date
    Dec 2006
    Beans
    165

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    I think you've probably set it to wake on a unicast message rather than a magic packet. One way to test this is to send anything (e.g. a ping) to that machine and see if it wakes up. This would explain why it doesn't work after a long time, as your router might cache the physical location of the IP address for some time then clear it. Try experimenting with the umbg switches (e.g. ethtool -s eth0 wol bg) - u = unicast, m= multicast, g = magic packet and b = broadcast address I think, or maybe that's not quite right but you get the idea.

  2. #82
    Join Date
    Jan 2007
    Location
    London, UK
    Beans
    3,520
    Distro
    Ubuntu Development Release

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by lowebb View Post
    Has anyone got WOL working frin the Internet with a BT Home Hub router? I'm having difficulty and the 'Big_Croc' method isnt helping. The BT Home Hub is pretty configurable so I'm hoping someone has worked out how to do it
    This may help port forwarding-
    http://www.smallnetbuilder.com/conte.../29941/53/1/3/

    I haven't tried by myself yet, I am currently sshing my server over internet but WOL I have to still configure. Probably will try UDP port forwarding for that.
    You came empty handed, that is how you shall leave. Whatever you claim as yours today, belonged to someone else yesterday, will be someone else's tomorrow. This false happiness is the true cause of your sorrows!

  3. #83
    Join Date
    Jan 2008
    Location
    Poland, Warszawa
    Beans
    7
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    I suggest using etherwake instead of wakeonlan
    (sudo apt-get install etherwake)

    I experienced problems, when using wakeonlan script on OpenVPN server bridged with local lan with Shorewall enabled. No such problems with etherwake.

  4. #84
    Join Date
    May 2008
    Beans
    245
    Distro
    Ubuntu Karmic Koala (testing)

    Thumbs down Re: HOWTO: Set your system up for Wake On LAN (WOL)

    What if you have 3 Ethernet Cards like me? lol
    CPU: 4ghz AMD 6 core | RAM: 16gb 1800mhz | HDD: 2*1TB (Striped lvm) 4*30GB SSD (Striped lvm) | Nvidia 9800GTX+ | ASUS Xonar D2X | Marantz 2265B Audio Console With Vacuum Tube Preamps

  5. #85
    Join Date
    May 2008
    Location
    Camp Pendleton, CA
    Beans
    348
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hey everyone, I have a few questions about WOL
    I've gotten WOL to work within my home network with the comand
    wakeonlan 00:00:00:00:00:00 and my server powers up fine, but when at home it's not that much of a convience because I can just walk to the box and press power. I dont know however how to get this to work outside my network.
    also Im not sure how to use wakeonlaa properly, the -i and -p options dont seem to work for me. Im not sure how to type them
    for example i've tried to wake up the server from outside the network with the command
    wakeonlan -i 76.120.108.232 and I get (ip address) is not a hardware address and could not resolve it as an ip address. just the command
    wakeonlan -i gives me the menu of commands
    do i need to braket the ip address?
    i've got my router fowarding port 9 udp to the servers priviate ip, and that is assigned by it's mac address.

  6. #86
    Join Date
    Nov 2007
    Beans
    8

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hey

    WakeOnLan needs the mac address of the machine you wish to power up so what I do is put the mac address in a text file and run the following

    wakeonlan -i YOU_IP_ADDRESS -f mac_address.txt

  7. #87
    Join Date
    Oct 2008
    Beans
    1

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hello,

    I want to share my findings of WOL using the 3c905b-tx NIC.

    My computer is an old HP Vli8 pIII with an 3c905b-tx NIC with a WOL cable connected to the Mobo

    Following two ways worked (first connect the cable to the mobo and enable network wakeup in BIOS):

    1. manual way
    rmmod 3c59x
    modprobe 3c59x enable_wol=1 global_enable_wol=1
    shutdown -h now
    Then send magic packet (UDP, port 9)

    But this way i had to arm the computer manually after each startup

    2. Automatic way
    Added to /etc/modprobe.d/network
    alias eth0 3c59x
    options 3c59x enable_wol=1
    options 3c59x global_enable_wol=1

    rmmod -f 3c59x
    update-initramfs -u

    shutdown -h
    Then send magic packet (UDP, port 9)

    Note that i used the -f flag on rmmod, it was not possible to unload the 3c59x module otherwise (please use with care)


    Both two ways worked fine on my old computer, hope it helps someone else with the 3c905B-Tx card

    (don't forget the sudo above, i did not include it to be more clear)

    regards,
    Anders

  8. #88
    Join Date
    Apr 2006
    Beans
    9

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hi everyone

    I have a new mainboard GIGABYTE GA-EP35-DS4 and have problem with WOL. After shutdown I can't wake my pc. Bios is set ok, but led on ethernet port is after shutdown off. On my ASUS P5N-E board ether script with ubuntu hardy works perfec, but with Gigabyte and hardy doesn't work
    I'm using ether-wake.

    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: Twisted Pair
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
    Link detected: yes

    any idea?
    Thx

  9. #89
    Join Date
    Nov 2007
    Beans
    9
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    I have the same problem with a Gigabyte mobo. I have a feeling that it may not support WOL. See this post:

    http://www.tomshardware.com/forum/25...ake-integrated

  10. #90
    Join Date
    Oct 2007
    Beans
    4

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    It should work with the Gigabyte board. I have a Gigabyte P35-DQ6 board and WOL works just fine (unfortunately I haven't tested it with Ubuntu since I'm only running XP on that pc).

    Recently I built a server with a Abit A-S78-H board with a 780G chipset and it has a Marvell 88E8056 PCI-E Gigabit Ethernet Controller. Although I set Wake On Lan in the BIOS and used ethtool to use WOL, it still doesn't work. I also adjusted the halt script to remove the -i option but no luck. The light on my LAN-port doesn't light up when I shutdown the server. Btw, I'm using 8.10 server amd64.

    Are there others that have the same problem?

Page 9 of 19 FirstFirst ... 7891011 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •