Page 2 of 19 FirstFirst 123412 ... LastLast
Results 11 to 20 of 190

Thread: HOWTO: Set your system up for Wake On LAN (WOL)

  1. #11
    Join Date
    Sep 2006
    Beans
    1

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    hm...I still have problems with this wol-stuff.

    I followed the HOWTO and I did set the wol setting to 'g'.
    But it don't wanna work.
    By the way, if I shut down WinXP, it WORKS!, just when I worked with Kubuntu before, even if the wol setting is set correctly, I can't wake up the computer.

    I tried to do this via ssh from my Asus wl-500g Premium.

    Any ideas?

    thx!!

    Thassilo

  2. #12
    Join Date
    Jan 2005
    Beans
    Hidden!

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Thassilo,

    Have you tried the other flags? Do you have proper support for your card in linux?
    $ sudo ethtool ethX

    In my case I have a realtek card which supports WOL in windows, but not in linux. (Even with the latest r1000 module) I've already contacted realtek. They acknowledged the problem and said they would work on it, but this is the kind of thing that requires a lot of people requesting.

    incubus

  3. #13
    Join Date
    Sep 2006
    Beans
    2

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hi,
    first off, thanks for helping educate the masses (including myself) about the intricacies of wol...

    Here's where I am with trying to get it going: I have Kubuntu 6.06 Drakey-whatsit on a Dell Optiplex with a 3Com 3c905 NIC. Last night I successfully executed one remote wake up on my LAN but I did it by turning on the Kubuntu PC and turning it off about two seconds later. I noted at that point that the LED at the back of the NIC was still lit. Then I sent a magic packet from my other PC and lo and behold the Kubuntu machine turned on.

    Now, the problem is that when I shut down Kubuntu (properly or otherwise), the LED on the NIC goes out and consequently WOL doesn't work.

    I tried your script and I tried manually issuing the command

    % sudo ethtool -s eth0 wol g

    but it gives the following error:
    Cannot get current wake-on-lan settings: Operation not supported
    not setting wol

    So, I know the hardware supports WOL and it is enabled in the BIOS but for some reason, Linux does not shut down to the correct power state and the ethtool does not seem to work with my NIC.

    Any help would be greatly appreciated,
    Eugene

  4. #14
    Join Date
    Jan 2005
    Beans
    Hidden!

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hey wheatear,

    I got the same problem. In my case, the linux module doesn't support WOL. It works in windows.

    What do you get from:
    $ sudo ethtool eth0

    And what is your network card, by the way?

    incubus

  5. #15
    Join Date
    Sep 2006
    Beans
    2

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hi Incubus.

    Thanks for the reply. The command you asked about produces the following for me:
    ---------------------------------------
    Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Full
    100baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 10Mb/s
    Duplex: Half
    Port: MII
    PHYAD: 24
    Transceiver: internal
    Auto-negotiation: on
    Current message level: 0x00000001 (1)
    Link detected: yes
    ---------------------------------------

    As I mentioned earlier, I have a 3Com 3c905 network card.

    By the way, have you come across this yet:

    http://www.linuxquestions.org/questi...d.php?t=444793

    The guy there seems to have overcome the same problem by installing some alternative network driver... Haven't looked into that yet myself.

    Thanks again,
    wheatear

  6. #16
    Join Date
    Jan 2005
    Beans
    Hidden!

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hi wheatear,

    I see good and bad news.

    The bad news is that, as you already noticed, your current netcard module (for this specific linux distribution) doesn't support WOL. You can see that you don't have the lines like the other guy has:

    ....
    Supports Wake-on: g
    Wake-on: g
    Now the good news: from what you said and from the other forum thread, you can compile a module for your network card that does support WOL. That's huge. And it's not so complicated. I would:
    $ sudo apt-get install build-essential checkinstall linux-headers-`uname -r`

    Then at your gunzipped module directory:
    $ ./configure
    $ sudo checkinstall -D

    Note that this doesn't work for me. I don't have an option except for waiting the Realtek guys to sit down, have mercy, and make the module for linux that supports WOL.

    Let us know if you're gonna try to compile it and need help.

    best,
    incubus

  7. #17
    Join Date
    Sep 2006
    Beans
    2

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hi
    I also have problems with the wake on LAN function on my system, I have tried following the guide, but with no luck.

    But when I power off just after start(mechanical, using poweroff button) or from windows. I can get it started with magic packages.
    I have tried both etherwake and wakeonlan.

    ethtool gives me.

    Settings for eth0:
    Supported ports: [ MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: external
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: g
    Link detected: yes
    So looks like it supports WOL with magic packeges, could it be the power state my system goes into on Halt. As far as I know it should be soft-off.

    Hviid

  8. #18
    Join Date
    Sep 2006
    Beans
    2

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    I found the answer for my problem.

    http://www.nvnews.net/vbulletin/showthread.php?t=70384
    Last reply.

    Hviid

  9. #19
    Join Date
    Feb 2006
    Beans
    26

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Thank you Chris for this description. I have one important question: what is a purpose for that script that was added to the description? As far as I know WON (Wake On Lan) mechanism is fully based on hardware and is OS (operating system) independent. If you want to use WON you need just a motherboard with BIOS enabled feature of WON and NIC with WON enabled future. That is all. If you are able to boot up a PC remotely that you are able to load any OS. Did I miss something?

    Kind regards,
    Maciej

  10. #20
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    @mslonik

    I assumed the same until I had to use it practically.

    Now I think it is like this:

    When wol is enabled and the computer is powered down, not all components of the computer are shutdown: for example I suppose that at least the ethernet port has to remain active in order to process the wol magic packet.

    I suppose that the script configures the computer to keep the ethernet active.

    Moreover, I have discovered the following with my hardware: if I pull the power supply plug from my computer and connect it again, the wol does not work any more. I have to start the computer with the poweron button. Afterwards wol works again.

    frafu

Page 2 of 19 FirstFirst 123412 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •