Page 19 of 19 FirstFirst ... 9171819
Results 181 to 190 of 190

Thread: HOWTO: Set your system up for Wake On LAN (WOL)

  1. #181
    Join Date
    Feb 2008
    Beans
    722

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    This thread is way too technical.

    NIC is Intel Gigabit 82574L using driver e1000e

    How to configure WOL for magic packet only?

    How to enable Power saving mode?

    I've installed ethtool, what next?

    Thanks.

  2. #182
    Join Date
    Mar 2010
    Location
    USA
    Beans
    92
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Thanks for a helpful guide.
    I meant to also add that while computers connected with a true "wireless" connection will very rarely work with WOL, if you want a desktop that is too far away to be wired to the router to have WOL, consider using an older router flashed with DD-WRT.

    For example, I have several computers connected to a Linksys WRT54G with DD-WRT, configured as a Client Bridge. However, the difference is, the router is always on, and the computers are physically using wired ethernet (and get 100mpbs speeds among themselves). Now this way, you can use the WOL feature of the ethernet adapter, while still having, to some degree, a "wireless" connection.

    Obviously that's recommended only for desktops, and if possible multiple ones, as one router can connect up to 5 of them.

  3. #183
    Join Date
    Aug 2011
    Beans
    1

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    I solved it by disable firewall in my router....

    my step :

    - first follow this first thread post
    - disable firewall in my router
    - configure port forwarding in my router
    - tried and succeed, then enable back firewall in my router... then all set.

  4. #184
    Join Date
    Jul 2012
    Beans
    20

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    I wrote this article describing my own setup:

    http://www.linuxist.com.au/index.php...e-home-server/

  5. #185
    Join Date
    Feb 2008
    Beans
    722

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by The Linuxist View Post
    I wrote this article describing my own setup:

    http://www.linuxist.com.au/index.php...e-home-server/
    Thank you. I wish you'd publish one on how to set up Home Server with a static IP.

  6. #186
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Quote Originally Posted by The Linuxist View Post
    I wrote this article describing my own setup:

    http://www.linuxist.com.au/index.php...e-home-server/
    Since you are talking about energy savings in your article, I wonder whether you also have a solution to have the server automatically go into hibernation after a determined time of inactivity. (For example, in the case where somebody forgets to turn it off after using it; this would be especially interesting if also children are allowed to connect to the server.)

  7. #187
    Join Date
    Apr 2006
    Beans
    Hidden!

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Just an observation....

    Set up here is trying to wake a computer on the same lan as I am.

    I installed wakeonlan

    and neither
    wakeonlan xx:xx:xx:xx:xx:xx
    or
    wakeonlan -i xxx.xxx.xxx.255 xx:xx:xx:xx:xx:xx

    works... however i discovered etherwake in the repos and that works where wakeonlan seems to fail

    sudo etherwake xx:xx:xx:xx:xx:xx.

  8. #188
    Join Date
    Dec 2009
    Beans
    102

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    Hi guys,
    I know this is an old thread but I'd really appreciate if someone with more experience/knowledge could eyeball my problem and suggest any tips if they think of them.

    I set up WOL as per the instructions, forwarded port 9 to my machine and WOL worked from the internet using a magic packet sending site which needs IP & MAC addresses only. Yay! (implicit & now explicit: BIOS supports WOL & it's turned on)
    Then I tried it a day later and it doesn't work. I've not changed anything.

    Info / terminal printouts:
    "ethtool eth0" gives:
    Cannot get wake-on-lan settings: Operation not permitted
    Current message level: 0x000000ff (255)
    drv probe link timer ifdown ifup rx_err tx_err
    Cannot get link status: Operation not permitted

    "sudo ethtool eth0" gives
    Supports Wake-on: pg
    Wake-on: g
    Current message level: 0x000000ff (255)
    drv probe link timer ifdown ifup rx_err tx_err
    Link detected: yes

    wakeonlanconfig done correctly, defaults set up as per instructions, chmod done as per instructions.
    /etc/init.d/wakeonlanconfig produced no output, as desired.

    When the machine's powered off, the NIC LEDs are on (green) and intermittently flash (yellow/orange). Sending magic packets makes the orange LED flash more regularly, tested until satisfied by sending loads and loads, compared to the flash regularity of sending none. Therefore I feel reasonably sure the machine's getting the packets.

    Any ideas for a step-by-step debugging procedure for me to find out what's not working? I've installed wireshark but either I don't know how to set up a WOL filter, or it should be picking up WOL inputs and isn't.

    I looked at the advice here: https://help.ubuntu.com/community/WakeOnLan and added the 'auto eth0' bit in etc/network/interfaces, however it didn't make WOL work, AND it meant I can't surf the net. So I undid that. It also mentioned network-manager may be interfering, but why would I be able to use WOL successfully already if that were the case? I'm reluctant to remove something as important-sounding as network manager in case it loses me other things, as is so often the case when following instructions!

    "Remove -i option from halt" - have read about this but not done anything. It worked before by shutting down normally, via menu, so again i'm reluctant to change unless there's a good logical reason.

    I've looked into other people having the problem of it working once and not again, but that seems to be related to saving scripts to ensure ethtool is run before each shutdown. Since I'm manually running it while trying to make this work, evidently this isn't a (currently) relevant problem, however. For reference: http://askubuntu.com/questions/19089...booting-ubuntu

    Thanks in advance
    dez

    more thoughts: if the community wiki says I should set wakeonlanconfig to run via /etc/network/interfaces, should I do that instead of this thread's instructions?
    Also: I'm not 100% sure, but I don't *think* that this line was coming up in "sudo ethtool eth0" when I first started this process:
    "Current message level: 0x000000ff (255)
    drv probe link timer ifdown ifup rx_err tx_err"
    Last edited by dez93_2000; January 27th, 2013 at 10:26 PM. Reason: typo & more info

  9. #189
    Join Date
    Jun 2008
    Location
    India
    Beans
    33
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    In Windows, there is GUI based software called wake on lan.

    Is there any such software for Ubuntu.
    It will be easier to use it than many other text or command based software.

    TY.

  10. #190
    Join Date
    Apr 2014
    Beans
    1

    Re: HOWTO: Set your system up for Wake On LAN (WOL)

    I am having trouble getting wake on lan to work and I can't for the life of me figure out what isn't working. I'm running xubuntu 12.04 LTS and I know the NIC supports wol because i've used the same computer for it with both windows xp and xubuntu 9. If i run sudo ethtool eth0 it says:

    supports wake-on: pg
    wake-on: g

    but if i suspend the system, wake on lan wont work for me.

    I'm using sudo /usr/sbin/pm-suspend to suspend the system. with pm-utils.

    Any thoughts? They'd be most appreciated. Thanks

Page 19 of 19 FirstFirst ... 9171819

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •