Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: ePSXe 1.9.0 is not starting up on Linux Lite

  1. #1
    Join Date
    Aug 2014
    Location
    Glasgow, Scotland
    Beans
    37

    Unhappy ePSXe 1.9.0 is not starting up on Linux Lite

    I'm having a problem with running ePSXe on Linux Lite (which is a Xubuntu derivative/distro), and it isn't working at all, when I click on the executable, nothing happens. I've looked it up the problem online and this seems to be a common issue with Xubuntu. I haven't found a solution, however. I asked about this issue in a thread in the "Other OS/distros" forum, and they said to post a thread here.

    So has anyone here got it working on Xubuntu? How can I get it working?
    Last edited by cobradabest; August 14th, 2014 at 06:40 PM.

  2. #2
    Join Date
    Sep 2013
    Beans
    136

    Re: ePSXe 1.9.0 is not starting up on Linux Lite/Xubuntu

    try opening a terminal in the folder you have epsxe in and type ./epsxe (or whatever your epsxe is called) and post what the terminal produces in error messages.

    As a hint for the future, its always good to try running problematic programs from the terminal as it will give you more specified errors that can be sorted to get your program running

  3. #3
    Join Date
    Aug 2014
    Location
    Glasgow, Scotland
    Beans
    37

    Re: ePSXe 1.9.0 is not starting up on Linux Lite/Xubuntu

    I'm getting this error:

    Code:
    ./epsxe: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

  4. #4
    Join Date
    Sep 2013
    Beans
    136

    Re: ePSXe 1.9.0 is not starting up on Linux Lite/Xubuntu

    If you are running 64bit OS try installing the 32bit lib

    sudo apt-get install libgtk2.0-0:i386

    if it doesnt run after installing the above package, you may also need :

    sudo apt-get install libsdl-image1.2:i386

    sudo apt-get install libsdl-ttf2.0-0:i386
    Last edited by adec2; August 14th, 2014 at 12:57 AM.

  5. #5
    Join Date
    Aug 2014
    Location
    Glasgow, Scotland
    Beans
    37

    Re: ePSXe 1.9.0 is not starting up on Linux Lite/Xubuntu

    Okay, it's starting up, though only through command line, and games are also starting up. However, When I attempt to edit the Video, Sound or Netplay options, I get the error:
    Code:
    plugins/libbz2.dll: invalid ELF header
    on the command line and then it closes...
    Last edited by cobradabest; August 14th, 2014 at 09:26 AM.

  6. #6
    Join Date
    Sep 2013
    Beans
    136

    Re: ePSXe 1.9.0 is not starting up on Linux Lite/Xubuntu

    Hmm, thats a new one. I would be tempted to install libbz2-dev as i have just had a look around and i have it installed and epsxe runs fine. Clutching at straws here cobra
    You could always edit the video config files manually in the cfg directory and epsxe itrself has a hidden cfg file (.epsxerc) in the same directory as the epsxe binary, you will have to press ctrl+h to unhide it
    Last edited by adec2; August 14th, 2014 at 10:11 AM.

  7. #7
    Join Date
    Aug 2014
    Location
    Glasgow, Scotland
    Beans
    37

    Re: ePSXe 1.9.0 is not starting up on Linux Lite/Xubuntu

    I've done that, but I'm afraid it didn't help...

  8. #8
    Join Date
    Sep 2013
    Beans
    136

    Re: ePSXe 1.9.0 is not starting up on Linux Lite/Xubuntu

    Then other than post your problem in the epsxe forums and if you get a fix write it here, then all i can say is edit your cfg files manually before running.

    Edit I have found a possible solution from the epsxe website about dependencies

    http://ngemu.com/threads/epsxe-confi...u-linux.93374/

    sudo su
    apt-get install lib32ncurses5
    apt-get install lib32z1
    apt-get install libx11-6:i386
    apt-get install ia32-libs-gtk

    especially the lib32z1 library
    Last edited by adec2; August 14th, 2014 at 11:40 AM.

  9. #9
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: ePSXe 1.9.0 is not starting up on Linux Lite

    Thread moved to Other Operating Systems and Projects.

    And thread title amended. Linux Lite != Xubuntu. Linux Lite is a 3rd party unofficial derivative of Xubuntu.
    Ubuntu 16.04 Desktop Guide - Ubuntu 14.04 Desktop Guide - Forum Guide to BBCode - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  10. #10
    Join Date
    Aug 2014
    Location
    Glasgow, Scotland
    Beans
    37

    Re: ePSXe 1.9.0 is not starting up on Linux Lite/Xubuntu

    Quote Originally Posted by adec2 View Post
    Then other than post your problem in the epsxe forums and if you get a fix write it here, then all i can say is edit your cfg files manually before running.

    Edit I have found a possible solution from the epsxe website about dependencies

    http://ngemu.com/threads/epsxe-confi...u-linux.93374/

    sudo su
    apt-get install lib32ncurses5
    apt-get install lib32z1
    apt-get install libx11-6:i386
    apt-get install ia32-libs-gtk

    especially the lib32z1 library
    That hasn't worked either. I'll ask around on the ePSXe forums, thanks for all of your help anyway.

    By the way, when I said ePSXe only starts up on command line, will it turns out the launcher I made for the executable was what didn't work, none of the launchers I've made for programs I made work. Is there a way to get launchers working on an Xfce desktop? It's a lot harder than I first thought, it seems there's more to it then clicking "Create Launcher"...

    EDIT: Oh wait! it turns out the problem with my ePSXe was that I was using windows plugins, I didn't think there was a difference! I downloaded and use Linux plugins, and it all works now, thanks so much for your help!
    Last edited by cobradabest; August 14th, 2014 at 03:31 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •