Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37

Thread: Team Fortress 2 , horrible FPS

  1. #31
    Join Date
    Feb 2009
    Location
    Slovenija
    Beans
    Hidden!
    Distro
    Kubuntu 14.10 Utopic Unicorn

    Re: Team Fortress 2 , horrible FPS

    I found out that the 2D tearing/flickering usually happens if the memory clocks are set too low in desktop mode. Running:
    Code:
     aticonfig --adapter=0 --od-getclocks
    will show you the current clocks.


    It might be smart if you Alt+Tab out of your TF2 and run this command. The clocks should be at peak, if they aren't, this might be the cause of lag.

    If you wan't to know what else aticonfig can do, you can run:

    Code:
    aticonfig --help
    Youtube gaming channel dedicated to game bugs, glitches and tricks

  2. #32
    Join Date
    Jul 2014
    Beans
    89

    Re: Team Fortress 2 , horrible FPS

    i already tried that before making xorg.cong, but i can't remove xorg.conf,

    but also my firefox tears like hell, and when i scroll down, my video on right side lags LIKE HELL ! when i scroll

  3. #33
    Join Date
    Jul 2014
    Beans
    89

    Re: Team Fortress 2 , horrible FPS

    thanks i will try, also my python compilying is taking long and apps are slow(slow startup), whats wrong with my pc ! all happeneds after installing new graphics card , also windows got slow, the (super + w) takes a little long to load, it didn't used to

    edit: heres result , clocks are ok, i will try with tf2 !

    Adapter 0 - AMD Radeon R7 200 Series
    Core (MHz) Memory (MHz)
    Current Clocks : 1020 1125
    Current Peak : 1020 1125
    Configurable Peak Range : [300-1300] [150-1300]
    GPU load : 31%

    31% is high for desktop but before that i got 8%

    in middle of doing nothing my gpu usage goes really high sometimes !!!! like 78% while viewing stuff on sublime, it never laged on IGPU!

    my gpu is 40% when playing tf2, and its weird that clock is always max no matter what !

    i got update drivers and restarted, i still get tearing, but freq is max at tf2, and perforamnce is same, even maybe worst, i remember updae drivers had a lo better performance !!!

    oh god this is horrible, it even lags worst, maybe i should reinstall ubuntu,i wish i took an backup((((((( i dont want to download these agin, a week of staying awake till 3am

    atleast i have to forget about playing tf2 on linux, can you help me fix sublime and tearing in firefox and lags problem? i dont remember anything like this on my old 7750 before it died !

    edit: i used live cd and it doens't have tearing, dont have any apps to try on it but firefox doesn't even have slightest tearing !!! windows move smoothly
    Last edited by kamhagh; August 9th, 2014 at 04:28 PM.

  4. #34
    Join Date
    Feb 2009
    Location
    Slovenija
    Beans
    Hidden!
    Distro
    Kubuntu 14.10 Utopic Unicorn

    Re: Team Fortress 2 , horrible FPS

    31% GPU load on desktop is way too high in idle. Also, 40% GPU load when playing TF2 indicates that the Graphics card isn't even working at the highest potential. At this resolution and MSAA level, the usage should be close to 100%. Did you plug in the 1x6pin power connector properly? What power supply do you have?

    Can you also run the command top and see if some program is overusing your CPU?
    Youtube gaming channel dedicated to game bugs, glitches and tricks

  5. #35
    Join Date
    Jul 2014
    Beans
    89

    Re: Team Fortress 2 , horrible FPS

    hmm on windows tf2 uses 30%-40% i guess, multicore is on,

    tomb raider uses 99% gpu on windows so its not the problem ! its a GP650B-OC and im sure i connected power collectedly

    EDIT: im on windows, i was wrong, it uses 80+% gpu!!!!
    Last edited by kamhagh; August 9th, 2014 at 07:40 PM.

  6. #36
    Join Date
    Jul 2014
    Beans
    89

    Re: Team Fortress 2 , horrible FPS

    i found out something, my load is exactly the same with linux with VSync on, and the weird thing is the fps keeps jumping from 120 to 60 for less than a second and than staying 60, maybe the 2 VSyncs one is off and other one isn't so it's interrupting each other thats why i tear too ! because i get 30-40% usage with VSync on!

    im kinda sure there's some other VSync enabled somewhere else!

    do you have any idea?!

    when it works on windows(near 100%) it means everything is fine, its a setting or driver prob in linux!

    EDIT:

    Dont know why results were diffrent but now it gives me 99% with no VSync available(while playing) and 50%with VSync enabled(it was 40% max on windwos i guess ) i get 0% at idle, !!! so everythings fine, and fps no longer jumps to 60fps and go back near 100 , with VSync sometimes my fps gets 28-30

    but anyway with or without VSync my game still get lag spikes, its so horrible, my game goes like slowmotion or.... do you have any idea what else it might be?

    and sublime scrolling feels like 1fps, i dont remember any scrolling problem befroe i get new gpu or even maybe when i had 7750!
    Last edited by kamhagh; August 10th, 2014 at 01:45 PM.

  7. #37
    Join Date
    Jul 2014
    Beans
    89

    Re: Team Fortress 2 , horrible FPS

    i was wrong i get 0% on desktop !!! and i was wrong again, its 99-80% gpu usage with tf2,

    no program is overusing my cpu according to top, most cpu using program was compiz!

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •