Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Screen tearing on Bonobo Extreme 7

  1. #1
    Join Date
    Oct 2013
    Beans
    17

    Screen tearing on Bonobo Extreme 7

    Hello, I'm running a Bonobo Extreme 7 with nvidia driver 331. About 2/3s of the games that I have tried playing suffer from screen tearing. I believe the games that have an option for vertical sync don't have the problem, but not all games have that option. I've tried completely reformatting my computer and the problem persists. Is there some way to force vertical sync, or some other solution?

  2. #2
    Join Date
    Dec 2009
    Beans
    11
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Screen tearing on Bonobo Extreme 7

    What version of Ubuntu are you running? And what Desktop Environment?

    Also, an older tutorial, but have you checked out this link for options on disabling compositing and certain features in NVIDIA settings?
    http://www.omgubuntu.co.uk/2010/01/how-to-fix-video-tearing-in-videos-nvidia-ubuntu
    Last edited by billdozor; July 21st, 2014 at 03:00 AM. Reason: Added link to Ubuntu video tearing fixes for NVIDIA

  3. #3
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,563
    Distro
    Ubuntu

    Re: Screen tearing on Bonobo Extreme 7

    In addition to the above, do you have the system76-driver-nvidia pacakge installed? If you still have the original Ubuntu installation from when the system was new, it should be preinstalled.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  4. #4
    Join Date
    Oct 2013
    Beans
    17

    Re: Screen tearing on Bonobo Extreme 7

    It is 14.04 and Unity. Billdozer's guide didn't work unfortunately. None of those options to adjust the refresh rate exist in the places that the guide says any more, so I was lost without being able to try the guide at all.

    Yes, I do have the System76 driver installed. 14.04.8.

  5. #5
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,563
    Distro
    Ubuntu

    Re: Screen tearing on Bonobo Extreme 7

    In addition to the package, there is also the system76-driver-nvidia package that includes the Nvidia Proprietary Driver. That may have a large effect on screen tearing, as the proprietary driver is much better optimized for the hardware.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  6. #6
    Join Date
    Oct 2013
    Beans
    17

    Re: Screen tearing on Bonobo Extreme 7

    Hi Isantop, yes, I have that installed and updated to the latest version already, according to apt-get.

  7. #7
    Join Date
    May 2014
    Beans
    7

    Re: Screen tearing on Bonobo Extreme 7

    I've suffered the same kind of problem under Ubuntu 14.04 and Ubuntu GNOME 14.04 so it doesn't look like it's limited to Unity. I've tried a number of solutions but eventually decided to simply play the games in windowed mode. In that mode, the screen tearing doesn't seem to exist. Let me know if you've seen an improvement even though this "solution" might be less than ideal.

  8. #8
    Join Date
    Oct 2013
    Beans
    17

    Re: Screen tearing on Bonobo Extreme 7

    Silverslimer, yep, I can confirm that the problem does not happen in windowed mode. But there was to be a better solution.

  9. #9
    Join Date
    Dec 2009
    Beans
    11
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Screen tearing on Bonobo Extreme 7

    I know that in the KDE and XFCE environments, full screen video tears can be fixed by disabling "Compositing".
    This is something that can be turned off with a check box in the settings.

    Turn off compositing
    KDE:
    • Settings > System Settings > Desktop Effects > Advanced > Suspend desktop effects for fullscreen windows.
      • This is how I fixed screen tearing while using Debian 7 with KDE and NVidia proprietary drivers.


    XFCE:

    • Settings > Personal section > Window Manager Tweaks > Compositor > Uncheck "Enable display compositing"
      • 08/06/14: I just tested this with my desktop system and it resolves Steam games full screen tearing. (Xubuntu 14.04 64-bit, NVidia 331.38 driver for GeForce GTX285 card)


    Although, from what I understand with Ubuntu Unity, compositing is pretty integrated because of the 3d desktop environment. (no 2d fallback anymore)

    Other things you could try is in the NVidia Settings utility:


    • Enable "sync to vblank"
      • X Screen 0 > OpenGL Settings > Check "Sync to VBlank"


    1. Set GPU Power Levels to run at Max instead of auto


    • GPU 0 > PowerMizer > PowerMizer Settings > Preferred Mode: Prefer Maximum Performance

  10. #10
    Join Date
    Oct 2013
    Beans
    17

    Re: Screen tearing on Bonobo Extreme 7

    Thanks Billdozor.. I definitely don't want to give up Unity to resolve this.. I tried your other two suggestions. Sync to VBlank was already checked.. and Prefer Maximum Performance seems to have had no effect.

    Any other ideas?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •