Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Laptop brightness control

  1. #1
    Join Date
    May 2014
    Beans
    21

    Laptop brightness control

    ***Solved by editing grub, see post 7***

    Under both Debian and Windows I get 10 levels of brightness, under 14.04 I get 7. I'm fortunate to have two of the same machine. The difference between them is the lower end. It doesn't seem to go down as low when side by side with the other laptop running Windows 7.


    It's a Core i3 370M processor with Ironlake graphics, not sure if it's graphics or power management though.
    Last edited by MrMe01; July 16th, 2014 at 01:23 AM.

  2. #2
    Join Date
    May 2014
    Beans
    1,167

    Re: Laptop brightness control

    It might just be different kernel versions between debian and ubuntu especially if both machines have the same BIOS version

  3. #3
    Join Date
    May 2014
    Beans
    21

    Re: Laptop brightness control

    What can I do about it? I like using Ubuntu over Debian, but as someone who's regularly running to the low end of the battery, that low screen brightness is somewhat needed.

  4. #4
    Join Date
    May 2014
    Beans
    1,167

    Re: Laptop brightness control

    You can check kernel versions using
    Code:
    uname -r
    Ubuntu 14.04 is likely using 3.13.0-? I have no idea what your debian would have but a simple code in terminal should lower your brightness depending on some files
    Code:
    for interface in /sys/class/backlight/*; do echo $interface; cat $interface/brightness; cat $interface/max_brightness; done
    Isn't there a slider in system settings or power management that allows more settings?
    Last edited by jeremy31; July 15th, 2014 at 05:44 PM.

  5. #5
    Join Date
    May 2014
    Beans
    21

    Re: Laptop brightness control

    Here's the output of that command, brightness fully up
    /sys/class/backlight/acpi_video0
    10
    10
    /sys/class/backlight/intel_backlight
    4598
    4882

    Fully down,
    /sys/class/backlight/acpi_video0
    0
    10
    /sys/class/backlight/intel_backlight
    1349
    4882

    Not sure what how to interpret that though. I don't have Debian installed so I can't tell you what the same command would say.

    Kernel version is 3.13.0-30-generic
    Last edited by MrMe01; July 15th, 2014 at 07:51 PM.

  6. #6
    Join Date
    May 2014
    Beans
    21

    Re: Laptop brightness control

    Okay, after repeating the command at different brightness levels, this is happening.
    Using the */10 from the above comment.

    Actual screen brightness doesn't change between 6 and 10. On 5 it changes. I'm not sure if 10 is the highest brightness the backlight will go, but I do know that 0 isn't the lowest.

  7. #7
    Join Date
    May 2014
    Beans
    1,167

    Re: Laptop brightness control

    I wonder if editing grub to make it switch to the intel_backlight might help
    Code:
    sudo gedit /etc/default/grub
    and make the line that usually looks like this
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    be this instead
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=1"
    Code:
    sudo update-grub
    If that doesn't work, you may need to add a file
    Code:
    sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf
    And enter this
    Code:
    Section "Device"       
            Identifier  "card0"
            Driver      "intel"
            Option      "Backlight"  "intel_backlight"
            BusID       "PCI:0:2:0"
    
    EndSection
    and reboot
    Last edited by jeremy31; July 16th, 2014 at 12:18 AM.

  8. #8
    Join Date
    May 2014
    Beans
    21

    Re: Laptop brightness control

    I updated grub and that worked. The file '20-intel.conf' doesn't exist on my machine. Not in that folder anyway.

    Thank you for your help

    EDIT, I have off as an option! That's awesome!
    Last edited by MrMe01; July 16th, 2014 at 01:25 AM.

  9. #9
    Join Date
    May 2014
    Location
    Edmonton
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Laptop brightness control

    FTR I just tried:

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=1"
    and I still have 7 brightness levels instead of 10 when rebooting.

    Intel Centrino Core 2 Duo T5250 2 Ghz, GME965 Express Chipset w/GPU (like the 3500) running i915 Linux driver. Toshiba ACPI. ECHO 4 in startup applications used to have reasonable brightness on boot up but xrandr for the WVGA output to external TV kind of ruined that.

  10. #10
    Join Date
    May 2014
    Beans
    1,167

    Re: Laptop brightness control

    You could try adding
    Code:
    acpi_osi=linux
    to the Grub CMDLINE and see if it changes on a reboot. The number of brightness levels is usually reported to the OS from BIOS during startup after BIOS inquires what OS, Linux ignores the OS request by default

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •