Page 35 of 38 FirstFirst ... 253334353637 ... LastLast
Results 341 to 350 of 376

Thread: HOWTO: Setup easy web development environment (XAMPP)

  1. #341
    Join Date
    Oct 2008
    Location
    Brisbane, Australia
    Beans
    135

    Re: HOWTO: Setup easy web development environment (XAMPP)

    syed.rakib.al.hasan, you really don't need XAMPP on Ubuntu these days. It was great when apache, mysql and php needed lots of configuration and fiddling to get working but that has not been the case, at least since 8.04.

    I develop using Joomla all the time and I've just installed apache2, mysql etc. straight from the repositories as per the instructions on the Ubuntu help guides (or elsewhere on this thread). It works out of the box and you can have as many joomla sites as you like in subfolders of your web root (either by copying the files, creating the database and user and editing the configuration.php appropriately or by doing the standard joomla installation).

  2. #342
    Join Date
    Apr 2010
    Location
    Pittsburgh Suburbs
    Beans
    77
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Setup easy web development environment (XAMPP)

    syed.rakib.al.hasan, I did use XAMPP, because it was so easy to install, and before I saw PaulWhipp's forum post. I've finally got Joomla working on it - after considerable effort (and much help from forums). Here's what worked for me.

    I had to modify the php.ini file, and it's best to do that to begin with. You can find it in /opt/lampp/etc. I changed the line
    Code:
    error_reporting = E_ALL | E_STRICT
    to
    Code:
    error_reporting = E_ALL & ~E_STRICT
    I also changed the line
    Code:
    display_errors = On
    to
    Code:
    display_errors = Off
    (You have to call your editor from the command line using sudo to modify this file.)

    Next, with the Joomla web install I ran into some serious errors, so I used the manual install. You can find a very good set of instructions for that at http://help.joomla.org/content/view/1944/302/. Be sure to install it WITHOUT filling in the $ftp_ variables in the configuration.php file (except set $ftp_enable = '0'). I tried using the ftp layer, and ran into innumerable problems. It works without it.

    Once you complete the installation and have logged in as admin, choose Help > System Info > Directory Permissions. All the directories will probably show their status in red as Unwritable. At command level using sudo, you will need to change the owner of each of those directories to nobody. E.g.,
    Code:
    sudo chown -v nobody directoryname
    making sure you're located in the proper containing directory when you issue the command. After changing them, reload the current page in your browser, and they should now all show the status Writable in green. In the same way, change the owner of the file configuration.php to nobody. It's located in the directory in which you installed Joomla.

    Hope that works for you.

  3. #343
    Join Date
    Nov 2009
    Location
    Poland
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Setup easy web development environment (XAMPP)

    does anybody know, how to make it psosible to create database? i've just installed xampp on my 10.4
    but when i want to login as root in phpmyadmin i get
    Code:
     #1045 - Access denied for user 'root'@'localhost' (using password: YES)
    i've set up password in config.inc.php file
    and if i log in with pma i can't create database, it says i have no privilege

    any help please?

    UPDATE

    ok after struggling with this damn problem i've managed to get privileges to create mysql database
    here's what i did

    after failures with changing config files and so on i've just reinstalled xampp
    just tar xzvf xampp* -C /opt
    above replaced all previous files with default ones

    after this i've started xamp for first time with lampp start

    now what worked out
    BEFORE using any "lampp security" script and BEFORE changing any passwords i've opened localhost, and clicked phpmyadmin
    by default you can login with root without any password, just open phpmyadmin login page, make sure user is root and click GO without any password
    then i went to privileges tab, i've added EVERYTHING to pma user

    closed all webpages that had anything to do with xampp including phpmyadmin panel
    now started xampp secruity script, wrote passwords
    logged in as pma with my previously set password to phpmyadmin
    privileges tab
    and CREATED NEW user with privileges as pma
    it can be done by clicking edit icon for account pma, scrolling down the page and using create new user option and just leave old one

    now finally after i log in with new user i can create mysql databases...

    what a hell...
    Last edited by suzenon; August 15th, 2010 at 02:55 PM. Reason: solved

  4. #344
    Join Date
    Aug 2009
    Location
    /
    Beans
    39
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Setup easy web development environment (XAMPP)

    okay.. all this is really good.. especially the first time i used it..

    BUT, i cant make it work now.. the only way i have made it work is by running nautilus..

    i have tried this "sudo ln -s ~/public_html /opt/lampp/htdocs/$USER" but the link that it creates is broken..

    Can some one help me on this?

    Thanks in advance.

    PS: Once i make the link and i try to see the page ive made on firefox, i get an "Access Forbiden" warning..

    what is that?
    Last edited by LinLou; October 8th, 2010 at 04:25 PM.

  5. #345
    Join Date
    Aug 2009
    Location
    /
    Beans
    39
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Setup easy web development environment (XAMPP)

    Quote Originally Posted by LinLou View Post
    okay.. all this is really good.. especially the first time i used it..

    BUT, i cant make it work now.. the only way i have made it work is by running nautilus..

    i have tried this "sudo ln -s ~/public_html /opt/lampp/htdocs/$USER" but the link that it creates is broken..

    Can some one help me on this?

    Thanks in advance.

    PS: Once i make the link and i try to see the page ive made on firefox, i get an "Access Forbiden" warning..

    what is that?

    Ok my fault..

    If you guys want to link any file, where your html or php files are located, you have to do it like this..

    " ln -s /home/$USER/foldername/ /opt/lampp/htdocs/$USER "

    it worked prefect for me..

    + you do not have to create a new file.. you simply use the one you already have..

  6. #346
    Join Date
    Aug 2008
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOWTO: Setup easy web development environment (XAMPP)

    If anyone keeps having trouble, maybe this tutorial could help you further.

    It worked for me, with the following version code:

    Code:
    tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt
    Good luck!

  7. #347
    Join Date
    Oct 2008
    Location
    Brisbane, Australia
    Beans
    135

    Re: HOWTO: Setup easy web development environment (XAMPP)

    And remember that xampp is really pretty redundant considering how easily you can now install the stack directly to make a 'real' server (see earlier posts in this thread).

  8. #348
    Join Date
    May 2008
    Beans
    8

    Re: HOWTO: Setup easy web development environment (XAMPP)

    Quote Originally Posted by petervk View Post
    So far this post has just under 200 views, So great. If you read this and use it could you leave a reply saying if it was useful/useless? I'd like to keep improving this how-to, so feedback would be good.

    Plus, replies bump it up the list.
    Hello,
    I am just a newbie and I will make a newbie question: to start, how do I make sure i am in the right directory? (this is what you wrote at the veru beginning).
    This because I downloaded xampp and entered terminal but the system said it couldn't find any such file in the directory.

    Thank you

    ps

    sorry for my english

  9. #349
    Join Date
    Mar 2009
    Beans
    23

    Re: HOWTO: Setup easy web development environment (XAMPP)

    hey, thanks for your tutorial but this is not working for me.

    Starting XAMPP for Linux 1.5.3a...
    XAMPP: Starting Apache with SSL (and PHP5)...
    XAMPP: Starting MySQL...
    /opt/lampp/bin/mysql.server: 84: source: not found
    XAMPP: Another FTP daemon is already running.
    XAMPP for Linux started.
    motz@motz-Aspire-5735:~$ /opt/lampp/bin/mysql.server: 334: log_success_msg: not found
    cya

  10. #350
    Join Date
    Dec 2009
    Location
    UK
    Beans
    127
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: Setup easy web development environment (XAMPP)

    Hi there,

    I followed your instructions using Xampp 1.7.3a on two of my laptops.

    On one of my laptops, I cannot access the folder (where I keep ALL my html, php files) from Firefox address bar i.e. http://localhost/USER

    I've already uninstalled and reinstalled everything but it still doesn't work.
    It keeps saying
    Access forbidden! You don't have permission to access the requested object. It is either read-protected or not readable by the server.
    If you think this is a server error, please contact the webmaster.
    It's even more frustrating that on the other laptop, it works straight away after creating the shortcut.

    So, any idea on how to get around this???

    Thank you.

    Regards,
    GS

Page 35 of 38 FirstFirst ... 253334353637 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •