Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: problem playing wmv file under 14.04

  1. #1
    Join Date
    Jul 2014
    Beans
    5

    problem playing wmv file under 14.04

    I recently upgraded to 14.04 64bit from 11.04 64bit, found that I have issues playing some wmv files, which I had no problem under 11.04,or under Windows
    In 14.04, I have installed
    codec related: ffmpeg, libav-tools, gstreamer0.10-ffmpeg, gstreamer0.10-nice,gstreamer0.10-plugins-bad,gstreamer0.10-plugins-base,gstreamer0.10-plugins-good,gstreamer0.10-plugins-ugly,gstreamer0.10-libav, ubuntu-restricted extra, and maybe some more

    players: vlc,mplayer,smplayer,totem, xbmc

    Symtoms: all of smplayers, totem, mplayer, vlc's GUI crashed right away; cvlc crashed, failed to load the file; mplayer players when using command line, however, it crashed when the mouse click elsewhere. when using ffplay / avplay to play those wmv files in command line, everything work, also, xbmc could play them.

    Question: Is there anyway that I could fix so that vlc,mplayer etc could play those wmv file?

    Here is the result from avconv
    Code:
    $ avconv -i TEST.wmv
    ffmpeg version 2.2.git-7e8fdf0 Copyright (c) 2000-2014 the FFmpeg developers
      built on Jun 26 2014 14:30:02 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
      configuration: --extra-libs=-ldl --prefix=/opt/ffmpeg --enable-avresample --disable-debug --enable-nonfree --enable-gpl --enable-version3 --enable-x11grab --enable-libpulse --enable-libx264 --enable-libfdk-aac --enable-libvorbis --enable-libmp3lame --enable-libopus --enable-libvpx --enable-libspeex --enable-libass --enable-avisynth --enable-libsoxr
      libavutil      52. 90.101 / 52. 90.101
      libavcodec     55. 68.100 / 55. 68.100
      libavformat    55. 44.100 / 55. 44.100
      libavdevice    55. 13.101 / 55. 13.101
      libavfilter     4.  9.100 /  4.  9.100
      libavresample   1.  3.  0 /  1.  3.  0
      libswscale      2.  6.100 /  2.  6.100
      libswresample   0. 19.100 /  0. 19.100
      libpostproc    52.  3.100 / 52.  3.100
    Guessed Channel Layout for  Input Stream #0.1 : stereo
    Input #0, asf, from 'TEST.wmv':
      Metadata:
        encoder         : Lavf55.40.100
      Duration: 01:59:55.80, start: 0.000000, bitrate: 1347 kb/s
        Stream #0:0: Video: wmv2 (WMV2 / 0x32564D57), yuv420p, 800x450, SAR 1:1 DAR 16:9, 24 fps, 24 tbr, 1k tbn, 1k tbc
        Stream #0:1: Audio: wmav2 (a[1][0][0] / 0x0161), 44100 Hz, 2 channels, fltp, 48 kb/s
    Here is the reuslt from VLC
    Code:
    $ vlc -vvvVLC media player 2.1.5 Rincewind (revision 2.1.5+ppa1)
    [0x16d9058] main libvlc debug: VLC media player - 2.1.5 Rincewind
    [0x16d9058] main libvlc debug: Copyright © 1996-2014 the VideoLAN team
    [0x16d9058] main libvlc debug: revision 2.1.5+ppa1
    [0x16d9058] main libvlc debug: configured with ./configure  '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--localstatedir=/var' '--libdir=${prefix}/lib/x86_64-linux-gnu' '--libexecdir=${prefix}/lib/x86_64-linux-gnu' '--disable-dependency-tracking' '--build=x86_64-linux-gnu' 'CPPFLAGS=-D_FORTIFY_SOURCE=2' 'LDFLAGS=-Wl,-Bsymbolic-functions -Wl,-z,relro' '--config-cache' '--disable-maintainer-mode' '--disable-silent-rules' '--disable-update-check' '--enable-fast-install' '--prefix=/usr' '--docdir=/usr/share/doc/vlc-nox' '--libdir=/usr/lib' '--sysconfdir=/etc' '--with-binary-version=' '--enable-a52' '--enable-aa' '--enable-bluray' '--enable-bonjour' '--enable-caca' '--enable-chromaprint' '--enable-dbus' '--enable-dca' '--enable-dirac' '--enable-directfb' '--enable-dvbpsi' '--enable-dvdnav' '--enable-faad' '--enable-fdkaac' '--enable-flac' '--enable-fluidsynth' '--enable-freetype' '--enable-fribidi' '--enable-gnutls' '--enable-jack' '--enable-kate' '--enable-libass' '--enable-libfreerdp' '--enable-libmpeg2' '--enable-libxml2' '--enable-lirc' '--enable-live555' '--enable-mad' '--enable-mkv' '--enable-mod' '--enable-mpc' '--enable-mtp' '--enable-mux_ogg' '--enable-ncurses' '--enable-notify' '--enable-ogg' '--enable-opus' '--enable-oss' '--enable-pulse' '--enable-qt' '--enable-realrtsp' '--enable-samplerate' '--enable-schroedinger' '--enable-sdl' '--enable-sftp' '--enable-shout' '--enable-skins2' '--enable-smbclient' '--enable-speex' '--enable-svg' '--enable-taglib' '--enable-theora' '--enable-twolame' '--enable-upnp' '--enable-vcd' '--enable-vcdx' '--enable-vorbis' '--enable-x264' '--enable-zvbi' '--with-kde-solid=/usr/share/kde4/apps/solid/actions/' '--disable-decklink' '--disable-dxva2' '--disable-gnomevfs' '--disable-goom' '--disable-libvnc' '--disable-opencv' '--disable-projectm' '--disable-quicksync' '--disable-sndio' '--disable-telx' '--disable-vsxu' '--disable-wasapi' '--enable-alsa' '--enable-atmo' '--enable-dc1394' '--enable-dv1394' '--enable-linsys' '--enable-omxil' '--enable-udev' '--enable-libva' '--enable-v4l2' '--enable-crystalhd' '--enable-mmx' '--enable-sse' '--disable-neon' '--disable-altivec' 'CFLAGS=-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' 'CXXFLAGS=-g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security' 'build_alias=x86_64-linux-gnu'
    [0x16d9058] main libvlc debug: searching plug-in modules
    [0x16d9058] main libvlc debug: loading plugins cache file /usr/lib/vlc/plugins/plugins.dat
    [0x16d9058] main libvlc debug: recursively browsing `/usr/lib/vlc/plugins'
    [0x16d9058] main libvlc debug: saving plugins cache /usr/lib/vlc/plugins/plugins.dat
    [0x16d9058] main libvlc debug: plug-ins loaded: 427 modules
    [0x16d9058] main libvlc debug: opening config file (/home/myhome/.config/vlc/vlcrc)
    [0x16d9058] main libvlc debug: translation test: code is "C"
    [0x16d9058] main libvlc debug: CPU has capabilities MMX MMXEXT SSE SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 FPU 
    [0x1982258] main input debug: Creating an input for 'Media Library'
    [0x1982258] main input debug: Input is a meta file: disabling unneeded options
    [0x1982258] main input debug: using timeshift granularity of 50 MiB, in path '/tmp'
    [0x1982258] main input debug: `file/xspf-open:///home/myhome/.local/share/vlc/ml.xspf' gives access `file' demux `xspf-open' path `/home/myhome/.local/share/vlc/ml.xspf'
    [0x1982258] main input debug: creating demux: access='file' demux='xspf-open' location='/home/myhome/.local/share/vlc/ml.xspf' file='/home/myhome/.local/share/vlc/ml.xspf'
    [0x1922d68] main demux debug: looking for access_demux module matching "file": 20 candidates
    [0x1922d68] main demux debug: no access_demux modules matched
    [0x1982258] main input debug: creating access 'file' location='/home/myhome/.local/share/vlc/ml.xspf', path='/home/myhome/.local/share/vlc/ml.xspf'
    [0x1922188] main access debug: looking for access module matching "file": 25 candidates
    [0x1922188] filesystem access debug: opening file `/home/myhome/.local/share/vlc/ml.xspf'
    [0x1922188] main access debug: using access module "filesystem"
    [0x1a6d298] main stream debug: Using stream method for AStream*
    [0x1a6d298] main stream debug: starting pre-buffering
    [0x1a6d298] main stream debug: received first data after 0 ms
    [0x1a6d298] main stream debug: pre-buffering done 296 bytes in 0s - 10706 KiB/s
    [0x197ace8] main stream debug: looking for stream_filter module matching "any": 9 candidates
    [0x197ace8] main stream debug: no stream_filter modules matched
    [0x197ace8] main stream debug: looking for stream_filter module matching "record": 9 candidates
    [0x197ace8] main stream debug: using stream_filter module "record"
    [0x1982258] main input debug: creating demux: access='file' demux='xspf-open' location='/home/myhome/.local/share/vlc/ml.xspf' file='/home/myhome/.local/share/vlc/ml.xspf'
    [0x1924878] main demux debug: looking for demux module matching "xspf-open": 63 candidates
    [0x1924878] playlist demux debug: using XSPF playlist reader
    [0x1924878] main demux debug: using demux module "playlist"
    [0x19125d8] main demux meta debug: looking for meta reader module matching "any": 2 candidates
    [0x19125d8] lua demux meta debug: Trying Lua scripts in /home/myhome/.local/share/vlc/lua/meta/reader
    [0x19125d8] lua demux meta debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/reader
    [0x19125d8] lua demux meta debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/reader/filename.luac
    [0x19125d8] lua demux meta debug: Trying Lua scripts in /usr/share/vlc/lua/meta/reader
    [0x19125d8] main demux meta debug: no meta reader modules matched
    [0x1982258] main input debug: `file/xspf-open:///home/myhome/.local/share/vlc/ml.xspf' successfully opened
    [0x17acbc8] main xml reader debug: looking for xml reader module matching "any": 1 candidates
    [0x17acbc8] main xml reader debug: using xml reader module "xml"
    [0x1924878] playlist demux debug: parsed 0 tracks successfully
    [0x1982258] main input debug: EOF reached
    [0x1924878] main demux debug: removing module "playlist"
    [0x197ace8] main stream debug: removing module "record"
    [0x1922188] main access debug: removing module "filesystem"
    [0x1a60c78] main playlist debug: creating audio output
    [0x17af928] main audio output debug: looking for audio output module matching "any": 6 candidates
    [0x17af928] pulse audio output debug: using library version 4.0.0
    [0x17af928] pulse audio output debug:  (compiled with version 4.0.0, protocol 28)
    [0x17af928] pulse audio output debug: connected locally to unix:/run/user/1000/pulse/native as client #137
    [0x17af928] pulse audio output debug: using protocol 28, server protocol 28
    [0x17af928] main audio output debug: using audio output module "pulse"
    [0x1a60c78] main playlist debug: keeping audio output
    [0x197db48] main interface debug: looking for interface module matching "hotkeys,none": 19 candidates
    [0x197db48] main interface debug: using interface module "hotkeys"
    [0x197cff8] main interface debug: looking for interface module matching "globalhotkeys,none": 19 candidates
    [0x17af928] pulse audio output debug: adding sink 0: alsa_output.pci-0000_00_1b.0.analog-stereo (Built-in Audio Analog Stereo)
    [0x197cff8] main interface debug: using interface module "globalhotkeys"
    [0x17af6d8] main interface debug: looking for interface module matching "dbus,none": 19 candidates
    [0x17af6d8] dbus interface debug: listening on dbus as: org.mpris.MediaPlayer2.vlc.inmyhomece22402
    [0x17af6d8] main interface debug: using interface module "dbus"
    [0x16d9058] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [0x17afd18] main interface debug: looking for interface module matching "any": 19 candidates
    [0x7fa078093898] main generic debug: looking for extension module matching "any": 1 candidates
    [0x7fa078093898] lua generic debug: Opening Lua Extension module
    [0x7fa078093898] lua generic debug: Trying Lua scripts in /home/myhome/.local/share/vlc/lua/extensions
    [0x7fa078093898] lua generic debug: Trying Lua scripts in /usr/lib/vlc/lua/extensions
    [0x7fa078093898] lua generic debug: Trying Lua playlist script /usr/lib/vlc/lua/extensions/VLSub.luac
    [0x7fa078093898] lua generic debug: Scanning Lua script /usr/lib/vlc/lua/extensions/VLSub.luac
    [0x7fa078093898] lua generic debug: Script /usr/lib/vlc/lua/extensions/VLSub.luac has the following capability flags: 0x5
    [0x7fa078093898] lua generic debug: Trying Lua scripts in /usr/share/vlc/lua/extensions
    [0x7fa078093898] main generic debug: using extension module "lua"
    "sni-qt/22402" WARN  11:53:06.766 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE 
    [0x17afd18] main interface debug: using interface module "qt4"
    [0x1a60c78] main playlist debug: adding item `TEST.wmv' ( file:///media/disk2/TEST.wmv )
    [0x17afd18] qt4 interface debug: Adding a new MRL to recent ones: file:///media/disk2/TEST.wmv
    [0x1a60c78] main playlist debug: processing request item: TEST.wmv, node: null, skip: 0
    [0x1a60c78] main playlist debug: rebuilding array of current - root Playlist
    [0x1a60c78] main playlist debug: rebuild done - 1 items, index 0
    [0x1a60c78] main playlist debug: starting playback of the new playlist item
    [0x1a60c78] main playlist debug: resyncing on TEST.wmv
    [0x1a60c78] main playlist debug: TEST.wmv is at 0
    [0x1a60c78] main playlist debug: creating new input thread
    [0x7fa0740009b8] main input debug: Creating an input for 'TEST.wmv'
    [0x7fa0740009b8] main input debug: using timeshift granularity of 50 MiB, in path '/tmp'
    [0x7fa0740009b8] main input debug: `file:///media/disk2/TEST.wmv' gives access `file' demux `' path `/media/disk2/TEST.wmv'
    [0x7fa0740009b8] main input debug: creating demux: access='file' demux='' location='/media/disk2/TEST.wmv' file='/media/disk2/TEST.wmv'
    [0x7fa070000958] main input debug: Creating an input for 'TEST.wmv'
    [0x7fa06c000e78] main demux debug: looking for access_demux module matching "file": 20 candidates
    [0x7fa06c000e78] main demux debug: no access_demux modules matched
    [0x7fa0740009b8] main input debug: creating access 'file' location='/media/disk2/TEST.wmv', path='/media/disk2/TEST.wmv'
    [0x7fa06c0010c8] main access debug: looking for access module matching "file": 25 candidates
    [0x7fa06c0010c8] filesystem access debug: opening file `/media/disk2/TEST.wmv'
    [0x7fa06c0010c8] main access debug: using access module "filesystem"
    [0x7fa06c001218] main stream debug: Using stream method for AStream*
    [0x7fa06c001218] main stream debug: starting pre-buffering
    [0x7fa06c001218] main stream debug: received first data after 0 ms
    [0x7fa06c001218] main stream debug: pre-buffering done 1024 bytes in 0s - 76923 KiB/s
    [0x7fa06cc01518] main stream debug: looking for stream_filter module matching "any": 9 candidates
    [0x7fa06cc01518] main stream debug: no stream_filter modules matched
    [0x7fa06cc01518] main stream debug: looking for stream_filter module matching "record": 9 candidates
    [0x7fa06cc01518] main stream debug: using stream_filter module "record"
    [0x7fa0740009b8] main input debug: creating demux: access='file' demux='' location='/media/disk2/TEST.wmv' file='/media/disk2/TEST.wmv'
    [0x7fa06cc01768] main demux debug: looking for demux module matching "asf": 63 candidates
    [0x7fa06cc01518] asf stream debug: + 'Unknown'
    [0x7fa06cc01518] asf stream debug: |   + 'Header'
    [0x7fa06cc01518] asf stream debug: |   |   + 'File Properties'
    [0x7fa06cc01518] asf stream debug: |   |   + 'Header Extension'
    [0x7fa06cc01518] asf stream debug: |   |   |   + 'Metadata'
    [0x7fa06cc01518] asf stream debug: |   |   + 'Extended content description'
    [0x7fa06cc01518] asf stream debug: |   |   + 'Stream Properties'
    [0x7fa06cc01518] asf stream debug: |   |   + 'Stream Properties'
    [0x7fa06cc01518] asf stream debug: |   |   + 'Codec List'
    [0x7fa06cc01518] asf stream debug: |   + 'Data'
    [0x7fa06cc01518] asf stream debug: |   + 'Simple Index'
    [0x7fa06cc01768] asf demux debug: found 2 streams
    [0x7fa06cc01768] asf demux debug: added new video stream(ID:1)
    [0x7fa0740009b8] main input debug: selecting program id=0
    [0x7fa06cc01768] asf demux debug: added new audio stream(codec:0x161,ID:2)
    [0x7fa06cc01768] main demux debug: using demux module "asf"
    [0x7fa0740009b8] main input debug: looking for a subtitle file in /media/disk2/
    [0x7fa06cc144e8] main decoder debug: looking for decoder module matching "any": 39 candidates
    [0x17afd18] qt4 interface debug: IM: Setting an input
    [0x7fa06cc144e8] omxil decoder debug: fmt in:WMV2, out:     
    [0x7fa06cc144e8] omxil decoder debug: found 0 matching components for role video_decoder.wmv2
    [0x7fa06cc144e8] omxil decoder warning: couldn't find an omx component for codec WMV2
    [0x1a60c78] main playlist debug: meta ok for (null), need to fetch art
    [0x7fa070c18268] main demux meta debug: looking for meta fetcher module matching "any": 1 candidates
    [0x7fa06cc144e8] avcodec decoder debug: trying to use direct rendering
    [0x7fa06cc144e8] avcodec decoder debug: allowing 4 thread(s) for decoding
    [0x7fa06cc144e8] avcodec decoder debug: avcodec codec (Windows Media Video 8) started
    [0x7fa06cc144e8] main decoder debug: using decoder module "avcodec"
    [0x7fa06cc89a48] main decoder debug: looking for decoder module matching "any": 39 candidates
    [0x7fa06cc89a48] avcodec decoder debug: avcodec codec (Windows Media Audio 2) started
    [0x7fa06cc89a48] main decoder debug: using decoder module "avcodec"
    [0x7fa06ccb2b68] main demux meta debug: looking for meta reader module matching "any": 2 candidates
    [0x7fa070c18268] lua demux meta debug: Trying Lua scripts in /home/myhome/.local/share/vlc/lua/meta/fetcher
    [0x7fa070c18268] lua demux meta debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/fetcher
    [0x7fa070c18268] lua demux meta debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/fetcher/tvrage.luac
    [0x7fa06ccb2b68] lua demux meta debug: Trying Lua scripts in /home/myhome/.local/share/vlc/lua/meta/reader
    [0x7fa06ccb2b68] lua demux meta debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/reader
    [0x7fa06ccb2b68] lua demux meta debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/reader/filename.luac
    [0x7fa070c18268] main demux meta debug: using meta fetcher module "lua"
    [0x7fa070c18268] main demux meta debug: removing module "lua"
    [0x1a60c78] main playlist debug: searching art for TEST.wmv
    [0x7fa070000aa8] main art finder debug: looking for art finder module matching "any": 2 candidates
    [0x7fa06ccb2b68] lua demux meta debug: Trying Lua scripts in /usr/share/vlc/lua/meta/reader
    [0x7fa06ccb2b68] main demux meta debug: no meta reader modules matched
    [0x7fa0740009b8] main input debug: `file:///media/disk2/TEST.wmv' successfully opened
    [0x7fa0740009b8] main input debug: Buffering 0%
    [0x7fa0740009b8] main input debug: Buffering 15%
    [0x7fa0740009b8] main input debug: Buffering 15%
    [0x7fa0740009b8] main input debug: Buffering 29%
    [0x7fa0740009b8] main input debug: Buffering 30%
    [0x7fa0740009b8] main input debug: Buffering 43%
    [0x7fa0740009b8] main input debug: Buffering 46%
    [0x7fa0740009b8] main input debug: Buffering 56%
    [0x7fa0740009b8] main input debug: Buffering 61%
    [0x7fa0740009b8] main input debug: Buffering 71%
    [0x7fa0740009b8] main input debug: Buffering 61%
    [0x7fa06cc89a48] avcodec decoder warning: Physical channel configuration not set : guessing
    [0x1a60c78] main playlist debug: reusing audio output
    [0x17af928] pulse audio output debug: using stereo channel map
    [0x7fa0740009b8] main input debug: Stream buffering done (324 ms in 0 ms)
    [0x7fa070000aa8] lua art finder debug: Trying Lua scripts in /home/myhome/.local/share/vlc/lua/meta/art
    [0x7fa054001d48] main spu text debug: looking for text renderer module matching "any": 2 candidates
    [0x7fa070000aa8] lua art finder debug: Trying Lua scripts in /usr/lib/vlc/lua/meta/art
    [0x7fa070000aa8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/00_musicbrainz.luac
    [0x7fa054001d48] freetype spu text debug: Building font databases.
    [0x7fa054001d48] freetype spu text debug: Took 0 microseconds
    Fontconfig warning: FcPattern object size does not accept value "0"
    Fontconfig warning: FcPattern object size does not accept value "0"
    [0x17af928] pulse audio output debug: changed buffer metrics: maxlength=4194304, tlength=42336, prebuf=0, minreq=14112
    [0x17af928] pulse audio output debug: connected to sink alsa_output.pci-0000_00_1b.0.analog-stereo
    [0x17af928] main audio output debug: output 'f32l' 44100 Hz Stereo frame=1 samples/8 bytes
    [0x7fa05c004a18] main volume debug: looking for audio volume module matching "any": 2 candidates
    [0x17af928] pulse audio output debug: base volume: 65536
    [0x17af928] pulse audio output debug: changing sink 0: alsa_output.pci-0000_00_1b.0.analog-stereo (Built-in Audio Analog Stereo)
    [0x7fa054001d48] freetype spu text debug: Using Serif Bold as font from file /usr/share/fonts/truetype/dejavu/DejaVuSans.ttf
    [0x7fa05c004a18] main volume debug: using audio volume module "float_mixer"
    [0x17af928] main audio output debug: input 'f32l' 44100 Hz Stereo frame=1 samples/8 bytes
    [0x7fa05c006b78] main audio filter debug: looking for audio filter module matching "scaletempo": 14 candidates
    [0x7fa05c006b78] scaletempo audio filter debug: format: 44100 rate, 2 nch, 4 bps, fl32
    [0x7fa05c006b78] scaletempo audio filter debug: params: 30 stride, 0.200 overlap, 14 search
    [0x7fa05c006b78] scaletempo audio filter debug: 1.000 scale, 1323.000 stride_in, 1323 stride_out, 1059 myhomeding, 264 overlap, 617 search, 2204 queue, fl32 mode
    [0x7fa05c006b78] main audio filter debug: using audio filter module "scaletempo"
    [0x17af928] main audio output debug: conversion: 'f32l'->'f32l' 44100 Hz->44100 Hz Stereo->Stereo
    [0x17af928] main audio output debug: conversion pipeline complete
    [0x17af928] main audio output debug: conversion: 'f32l'->'f32l' 44100 Hz->44100 Hz Stereo->Stereo
    [0x17af928] main audio output debug: conversion pipeline complete
    [0x7fa05c00dd48] main audio resampler debug: looking for audio resampler module matching "any": 3 candidates
    [0x7fa070000aa8] lua art finder debug: Trying Lua playlist script /usr/lib/vlc/lua/meta/art/01_googleimage.luac
    [0x7fa05c00dd48] main audio resampler debug: using audio resampler module "samplerate"
    Segmentation fault (core dumped)

    Result from mplayer command line
    Code:
    $ mplayer TEST.wmv MPlayer SVN-r37220 (C) 2000-2012 MPlayer Team
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    
    Playing TEST.wmv.
    libavformat version 55.37.102 (internal)
    ASF file format detected.
    [asfheader] Video stream found, -vid 1
    [asfheader] Audio stream found, -aid 2
    VIDEO:  [WMV2]  800x450  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)
    Load subtitles in /media/disk1/
    ==========================================================================
    Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
    libavcodec version 55.60.103 (internal)
    Selected video codec: [ffwmv2] vfm: ffmpeg (FFmpeg WMV2/WMV8)
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 44100 Hz, 2 ch, floatle, 48.0 kbit/1.70% (ratio: 6000->352800)
    Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
    ==========================================================================
    [AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
    AO: [alsa] 44100Hz 2ch floatle (4 bytes per sample)
    Starting playback...
    Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
    VO: [x11] 800x450 => 800x450 Planar YV12 
    [swscaler @ 0x7fc8c02c15c0]bicubic scaler, from yuv420p to bgra using MMXEXT
    [swscaler @ 0x7fc8c02c15c0]using unscaled yuv420p -> bgra special converter
    A:   3.1 V:   3.2 A-V: -0.043 ct: -0.004   2/  2 ??% ??% ??,?% 0 0 
    [VD_FFMPEG] DRI failure.
    A:   5.4 V:   5.4 A-V:  0.000 ct: -0.045  54/ 54  4%  4%  0.5% 0 0 
    
    
    
    
    MPlayer interrupted by signal 11 in module: key_events
    - MPlayer crashed by bad usage of CPU/FPU/RAM.
      Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
      disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
    - MPlayer crashed. This shouldn't happen.
      It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
      gcc version. If you think it's MPlayer's fault, please read
      DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
      won't help unless you provide this information when reporting a possible bug.
    Last edited by darkhalo2; July 4th, 2014 at 09:43 PM.

  2. #2
    Join Date
    Aug 2013
    Beans
    1,975

    Re: problem playing wmv file under 14.04

    A sample?

  3. #3
    Join Date
    Jul 2014
    Beans
    5

    Re: problem playing wmv file under 14.04

    Quote Originally Posted by monkeybrain20122 View Post
    A sample?
    most test files I used was too big, but here is one of the samples that I have problem playing as well, found it on another thread
    https://archive.org/download/WorkToF...v/test_wmv.wmv

  4. #4
    Join Date
    Aug 2013
    Beans
    1,975

    Re: problem playing wmv file under 14.04

    No problem playing with vlc and mpv, but not with smplayer. The difference is that I compiled mpv and vlc myself against ffmpeg while mplayer is stock install from Ubuntu's repo which is built against libav. So maybe libav for some reasons cannot play these files.

    Totem works as well but I might have upgraded it with some ppa.
    Last edited by monkeybrain20122; July 4th, 2014 at 11:01 PM.

  5. #5
    Join Date
    Jul 2014
    Beans
    5

    Re: problem playing wmv file under 14.04

    I installed all of them from various repo.
    btw, did you compile vlc from source using the preferred method "sudo apt-get build-dep vlc" or using the "contrib" method? and how did your compile it against ffmpeg, did you compile ffmpeg as well?

  6. #6
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: problem playing wmv file under 14.04

    It works for me to play that video clip with mplayer2 in my production system (12.04.4 LTS 32-bits).

    Code:
    Selected video codec: [ffwmv3] vfm: ffmpeg (FFmpeg WMV3/WMV9)
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 44100 Hz, 2 ch, s16le, 64.0 kbit/4.54% (ratio: 8005->176400)
    Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
    Long ago I might have added something extra beyond ubuntu-restricted-extras (I don't remember), but I suggest that you

    1. Try with

    Code:
    sudo apt-get install ubuntu-restricted-extras
    2. If you are running a 64-bit system, try a 32-bit system (without installing into an internal drive, but installing ubuntu-restricted-extras into this live system).

    Try Ubuntu (Kubuntu, Lubuntu, Xubuntu, ...) before installing it

    Edit: Or compile your own video player as monkeybrain
    Last edited by sudodus; July 4th, 2014 at 11:13 PM.

  7. #7
    Join Date
    Jul 2014
    Beans
    5

    Re: problem playing wmv file under 14.04

    Quote Originally Posted by sudodus View Post
    It works for me to play that video clip with mplayer2 in my production system (12.04.4 LTS 32-bits).

    Code:
    Selected video codec: [ffwmv3] vfm: ffmpeg (FFmpeg WMV3/WMV9)
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 44100 Hz, 2 ch, s16le, 64.0 kbit/4.54% (ratio: 8005->176400)
    Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
    Long ago I might have added something extra beyond ubuntu-restricted-extras (I don't remember), but I suggest that you

    1. Try with

    Code:
    sudo apt-get install ubuntu-restricted-extras
    2. If you are running a 64-bit system, try a 32-bit system (without installing into an internal drive, but installing ubuntu-restricted-extras into this live system).

    Try Ubuntu (Kubuntu, Lubuntu, Xubuntu, ...) before installing it

    Edit: Or compile your own video player as monkeybrain
    already installed ubuntu-restricted-extras, and yes, I'm using 64 bit, will have to wait later to try using 32bit in my VM.

    hmm, I found out more,I could actually play those video using smplayer without crashing, the problem is that before, I was using vdpau as output driver, and after I switched to xv as output dirver , it played, and even after I switched back to vdpau , smplayer no problem playing, other players still don't work.


    ps: mplayer was removed, and replaced with mplayer2
    Last edited by darkhalo2; July 4th, 2014 at 11:27 PM.

  8. #8
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: problem playing wmv file under 14.04

    Good that you have found a way to play wmv video clips

  9. #9
    Join Date
    Aug 2013
    Beans
    1,975

    Re: problem playing wmv file under 14.04

    Quote Originally Posted by darkhalo2 View Post
    I installed all of them from various repo.
    btw, did you compile vlc from source using the preferred method "sudo apt-get build-dep vlc" or using the "contrib" method? and how did your compile it against ffmpeg, did you compile ffmpeg as well?
    I installed ffmpeg and all the -dev files from
    https://launchpad.net/~samrog131/+archive/ppa


    apt-get build-dep will not work as it will install the libav-dev files from the repo, which you don't want if you build against ffmpeg rather than avconv. So I installed a list of dependencies following andrew.46's list as baseline
    http://ubuntuforums.org/showthread.php?t=2141949

    Then install the -dev files for x264, libfdk-aac etc from repo. andrew.46 compiles these for vlc-git but the repo versions are up to date enough for vlc stable release
    You can add others by looking at outputs of ./configure

    Then

    Download vlc release tarball, extract, cd to it and run
    Code:
    export CPPFLAGS="-I/opt/ffmpeg/include"
    export LDFLAGS="-L/opt/ffmpeg/lib"
    export PKG_CONFIG_PATH="/opt/ffmeg/lib/pkgconfig"
    ./configure --prefix=/usr
    make -j4
    sudo checkinstall
    Adjust make -j4 to make -jx where x is the number of threads use.

    You can also compile ffmpeg like in andrew.46's guide, but I am lazy.
    Last edited by monkeybrain20122; July 4th, 2014 at 11:42 PM.

  10. #10
    Join Date
    Jul 2014
    Beans
    5

    Re: problem playing wmv file under 14.04

    Quote Originally Posted by monkeybrain20122 View Post
    I installed ffmpeg with
    https://launchpad.net/~samrog131/+archive/ppa
    and also all the -dev files

    apt-get build-dep will not work as it will install the libav-dev files, which you don't want if you build against ffmpeg. So I installed a list of dependencies following andrew.46's list as baseline
    http://ubuntuforums.org/showthread.php?t=2141949

    Then install the -dev files for x264, libfdk-aac etc from repo. andrew.46 compiles these for vlc-git but the repo versions are up to date enough for vlc stable release
    You can add others by looking at outputs of ./configure

    Then

    Download vlc release tarball, extract, cd to it and run
    Code:
    export CPPFLAGS="-I/opt/ffmpeg/include"
    export LDFLAGS="-L/opt/ffmpeg/lib"
    export PKG_CONFIG_PATH="/opt/ffmeg/lib/pkgconfig"
    ./configure --prefix=/usr
    make -j4
    sudo checkinstall
    Adjust make -j4 to make -jx where x is the number of threads use.

    You can also compile ffmpeg like in andrew.46's guide, but I am lazy.
    thanks, I'll give it a try. I built vlc using the "apt-get build-dep" method, no wonder it didn't work.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •