Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Broadcom wifi in laptop keeps dropping out

  1. #11
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,920
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broadcom wifi in laptop keeps dropping out

    Quick post before retiring to bed for the night - Please change the encryption type in the router to pure WPA2 with AES (CCMP). Currently it is using WPA/WPA2 mixed mode which can increase the problem if not the problem itself. Reboot the router after saving the change.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  2. #12
    Join Date
    Jun 2005
    Location
    England
    Beans
    2,695
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broadcom wifi in laptop keeps dropping out

    That made no difference it still sadly keeps dropping out

  3. #13
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,920
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broadcom wifi in laptop keeps dropping out

    Can we see a fresh report with the changes applied please?

    PS:
    I may not be able to help further on this due to lack of time. If anyone watching the thread has any ideas, please jump in!

    PPS:
    If you remove the hyphen (-) from the AP name (SSID) in the router, let's say replace it with underscore (_), does the script that I suggested earlier work? Just trying to sort out its bug.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  4. #14
    Join Date
    Jun 2005
    Location
    England
    Beans
    2,695
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broadcom wifi in laptop keeps dropping out

    I cannot change the ssid as it's not my router i'm using right now i'm afraid.

    Here's a fresh script output: http://pastebin.com/ZN2cWd6t

    Wireless still drops out a lot.

  5. #15
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,920
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broadcom wifi in laptop keeps dropping out

    The current AP which the report shows in use is again using WPA/WPA2 mixed mode with TKIP. Like I said before, it adds to the problem if not a problem itself. Unless you have some Jurassic-age device that can't support WPA2 and really needs WPA(1), it is highly recommended to use WPA2-PSK with AES (CCMP), regardless of whether it seems to help or not.

    Additionally, try explicitly defining your country code for RegDomain settings. That is, adding the country code to /etc/default/crda file. A one liner for doing that -
    Code:
    sudo sed -i '/^REG.*=$/ s/.*/&GB/' /etc/default/crda
    ..assuming you are in England (country code 'GB'). If not, change the country code accordingly, refer to this table : http://en.wikipedia.org/wiki/ISO_316...Decoding_table

    The change will be effective after a reboot.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  6. #16
    Join Date
    Jun 2005
    Location
    England
    Beans
    2,695
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broadcom wifi in laptop keeps dropping out

    Using that command so far seems to have fixed it without changing the router settings, any idea why that might have fixed it setting the country code? :S

  7. #17
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,920
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broadcom wifi in laptop keeps dropping out

    Quote Originally Posted by ELD View Post
    Using that command so far seems to have fixed it without changing the router settings, any idea why that might have fixed it setting the country code? :S
    That command tells the system to use wifi frequency settings compatible to those allowed in Britain. The Regulatory Domain settings for 'GB' are -
    Code:
    country GB:
    	(2402.000 - 2482.000 @ 40.000), (N/A, 20.00)
    	(5170.000 - 5250.000 @ 40.000), (N/A, 20.00)
    	(5250.000 - 5330.000 @ 40.000), (N/A, 20.00), DFS
    	(5490.000 - 5710.000 @ 40.000), (N/A, 27.00), DFS
    ..while the earlier (defaulted to '00') settings were -
    Code:
    country 00:
    	(2402.000 - 2472.000 @ 40.000), (3.00, 20.00)
    	(2457.000 - 2482.000 @ 20.000), (3.00, 20.00), PASSIVE-SCAN, NO-IBSS
    	(2474.000 - 2494.000 @ 20.000), (3.00, 20.00), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    	(5170.000 - 5250.000 @ 40.000), (3.00, 20.00), PASSIVE-SCAN, NO-IBSS
    	(5735.000 - 5835.000 @ 40.000), (3.00, 20.00), PASSIVE-SCAN, NO-IBSS
    ..so I can only guess that maybe your router is using a frequency setting that keeps falling out of the ranges/limitations enforced by the defaulted (00) settings. Fixing the regdomain setting to 'GB' matched it with the router's frequency range.

    I suggest you test the connection for a couple of days, and if it proves to be stable, please mark the thread as [SOLVED].
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •