Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Wired Network Not Working

  1. #11
    Join Date
    Mar 2010
    Location
    Metro-ATL
    Beans
    Hidden!
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: Wired Network Not Working

    The ethtool commands are forcing (locking) your 1000base-t NIC to be a 100base-t NIC. This slows down everything by a factor of 10x on your network - if that is acceptable to you, great. It may even be best, if the switch/router aren't GigE too then this is 100% fine. All the options for ethtool are explained in the man page. man ethtool BTW, manpages exist for almost every command on Linux/UNIX systems. Nothing is hidden or secret here.

  2. #12
    Join Date
    Jun 2014
    Beans
    10

    Re: Wired Network Not Working

    Thefu thanks ill have a read of those now. I don't understand why it would be beneficial for things to run slower is this to save bandwidth? Im totally guessing. Hopefully I should understand after reading all those things.

    Ran this code again thinking maybe it got cancelled out when I rebooted
    sudo ethtool -s eth0 speed 100 duplex full autoneg offAfter running it computer connected to my ethernet, I was pretty happy until I tested it and when I try access webpages on the internet its just continuously loading. My wifi is doing the same thing now. Had to swap computers, Hoping after reading up on the code ill understand though.

  3. #13
    Join Date
    Jun 2014
    Beans
    10

    Re: Wired Network Not Working

    My bad, thought I could copy and paste boxes.

    Code:
    sudo ethtool -s eth0 speed 100 duplex full autoneg off
    

  4. #14
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,601
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wired Network Not Working

    Quote Originally Posted by corey14 View Post
    I don't understand why it would be beneficial for things to run slower is this to save bandwidth?
    It's not about 'benefit', it's about 'compatibility'. Some router/switch firmware are buggy, sometimes the drivers are buggy, sometimes the cable is problematic.... all in a way that they simply fail to facilitate a working link at Gigabit speeds. In such cases, usually the driver or the router/switch automatically falls back to a lower speed that is easily achievable. If they don't for some reason, the driver allows us to use tools like 'ethtool' to do that manually so that at least we can get a working connection. So it is just a compromise when things refuse to work in their most optimal levels.

    Quote Originally Posted by corey14 View Post
    Ran this code again thinking maybe it got cancelled out when I rebooted
    Code:
    sudo ethtool -s eth0 speed 100 duplex full autoneg off
    After running it computer connected to my ethernet, I was pretty happy until I tested it and when I try access webpages on the internet its just continuously loading. My wifi is doing the same thing now. Had to swap computers, Hoping after reading up on the code ill understand though.
    I have an exam tomorrow, and am also overloaded with some urgent office work. Hope someone else would be able to help you out with sufficient information. To help us help you, please provide us the outputs of (with "link=yes" status) -
    Code:
    ifconfig -a
    route -n
    nm-tool
    cat /etc/network/interfaces
    sudo ethtool eth0
    dmesg | egrep -i 'jme|eth|dhclient'
    ..some more information may be needed later.

    PS:
    Yes, the 'ethtool -s...' command is temporary and its effect is lost on reboot. We can make it permanent if is proved to be helping and necessary.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #15
    Join Date
    Jun 2014
    Beans
    10

    Re: Wired Network Not Working

    Cheers for explaining that im eager to learn as much as possible, got really busy today didn't have a chance to read up about much at all, don't stress about me ill continue trying to work this out, id definately appreciate your help when you have time again if I havent Goodluck with your exam.

    ifconfig -a

    Code:
    ifconfig -a 
    eth0      Link encap:Ethernet  HWaddr bc:ae:c5:5f:2f:d4   
              inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0 
              inet6 addr: fe80::beae:c5ff:fe5f:2fd4/64 Scope:Link 
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1 
              RX packets:205 errors:0 dropped:5 overruns:0 frame:0 
              TX packets:57 errors:0 dropped:0 overruns:0 carrier:0 
              collisions:0 txqueuelen:1000  
              RX bytes:13670 (13.6 KB)  TX bytes:8654 (8.6 KB) 
              Interrupt:45  
     
    lo        Link encap:Local Loopback   
              inet addr:127.0.0.1  Mask:255.0.0.0 
              inet6 addr: ::1/128 Scope:Host 
              UP LOOPBACK RUNNING  MTU:65536  Metric:1 
              RX packets:237 errors:0 dropped:0 overruns:0 frame:0 
              TX packets:237 errors:0 dropped:0 overruns:0 carrier:0 
              collisions:0 txqueuelen:0  
              RX bytes:17485 (17.4 KB)  TX bytes:17485 (17.4 KB) 
     
    wlan0     Link encap:Ethernet  HWaddr 48:5d:60:e2:36:e5   
              inet addr:192.168.0.5  Bcast:192.168.0.255  Mask:255.255.255.0 
              inet6 addr: fe80::4a5d:60ff:fee2:36e5/64 Scope:Link 
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1 
              RX packets:959 errors:0 dropped:0 overruns:0 frame:0 
              TX packets:81 errors:0 dropped:0 overruns:0 carrier:0 
              collisions:0 txqueuelen:1000  
              RX bytes:128656 (128.6 KB)  TX bytes:12949 (12.9 KB)
    route -n
    Code:
     
    route -n 
    Kernel IP routing table 
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface 
    0.0.0.0         198.142.131.29  0.0.0.0         UG    0      0        0 eth0 
    192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0 
    192.168.0.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0 
    198.142.131.29  0.0.0.0         255.255.255.255 UH    0      0        0 eth0
    nm-tool
    Code:
     nm-tool 
     
    NetworkManager Tool 
     
    State: connected (global) 
     
    - Device: wlan0  [ISSWA] ------------------------------------------------------- 
      Type:              802.11 WiFi 
      Driver:            ath9k 
      State:             connected 
      Default:           no 
      HW Address:        48:5D:60:E2:36:E5 
     
      Capabilities: 
        Speed:           1 Mb/s 
     
      Wireless Properties 
        WEP Encryption:  yes 
        WPA Encryption:  yes 
        WPA2 Encryption: yes 
     
      Wireless Access Points (* = current AP) 
        BUILTONWIFI:     Infra, 00:1D:AA:2B:E2:D8, Freq 2462 MHz, Rate 54 Mb/s, Strength 10 WPA WPA2 
        *ISSWA:          Infra, F0:82:61:AE:7D:BF, Freq 2412 MHz, Rate 54 Mb/s, Strength 63 WPA WPA2 
        auto_net:        Infra, 00:04:ED:D4:55:29, Freq 2412 MHz, Rate 54 Mb/s, Strength 17 WPA2 
     
      IPv4 Settings: 
        Address:         192.168.0.5 
        Prefix:          24 (255.255.255.0) 
        Gateway:         192.168.0.1 
     
        DNS:             192.168.0.1 
     
     
    - Device: eth0  [Ethernet connection 1] ---------------------------------------- 
      Type:              Wired 
      Driver:            jme 
      State:             connected 
      Default:           yes 
      HW Address:        BC:AE:C5:5F:2F:D4 
     
      Capabilities: 
        Carrier Detect:  yes 
        Speed:           100 Mb/s 
     
      Wired Properties 
        Carrier:         on 
     
      IPv4 Settings: 
        Address:         192.168.0.1 
        Prefix:          24 (255.255.255.0) 
        Gateway:         198.142.131.29

    cat /etc/network/interfaces

    Code:
    cat /etc/network/interfaces 
    # interfaces(5) file used by ifup(8) and ifdown(8) 
    auto lo 
    iface lo inet loopback

    sudo ethtool eth0

    Code:
    sudo ethtool eth0
    Settings for eth0: 
        Supported ports: [ TP MII ] 
        Supported link modes:   10baseT/Half 10baseT/Full  
                                100baseT/Half 100baseT/Full  
                                1000baseT/Half 1000baseT/Full  
        Supported pause frame use: No 
        Supports auto-negotiation: Yes 
        Advertised link modes:  Not reported 
        Advertised pause frame use: No 
        Advertised auto-negotiation: No 
        Speed: 100Mb/s 
        Duplex: Full 
        Port: MII 
        PHYAD: 1 
        Transceiver: internal 
        Auto-negotiation: off 
        Supports Wake-on: pg 
        Wake-on: g 
        Current message level: 0x000020c6 (8390) 
                       probe link rx_err tx_err hw 
        Link detected: yes
    dmesg | egrep -i 'jme|eth|dhclient
    Code:
    dmesg | egrep -i 'jme|eth|dhclient 
    >
    I left the last code for over 10 mins when I ran it thinking it might just take awhile nothing happened, tried a second time same thing?

  6. #16
    Join Date
    Mar 2010
    Location
    Metro-ATL
    Beans
    Hidden!
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: Wired Network Not Working

    So it broke after a reboot?
    Did you apply the ethtool command again - the one with all the options to slow the connection down?
    If you add that 1 line to your /etc/rc.local file, it will happen at every reboot. If your router or switch are 10/100 and not gigE, I'd stop there and call this solved.

    If you want to go further, swap the cable for a known-good CAT5e cable.
    Try a different port on the device (switch/router).
    Read up on the other options that ethtool and the driver used support - that reading should lead to different options that might make it work with your specific switch/router - or at least known incompatibilities.

    If it doesn't, I'd start suspecting a failed gate inside the network chip. 1 small failure that can be worked around is a warning that something else will fail. Time to look for mitigation strategies, like getting a replacement NIC.

    Does this make sense? BTW, I don't have school pressures (haven't in years), just life gets in the way sometimes.

  7. #17
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,601
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wired Network Not Working

    Quote Originally Posted by corey14 View Post
    dmesg | egrep -i 'jme|eth|dhclient
    Code:
    dmesg | egrep -i 'jme|eth|dhclient <---- closing quote (') missing
    >
    I left the last code for over 10 mins when I ran it thinking it might just take awhile nothing happened, tried a second time same thing?
    Because you didn't type the closing single quote mark in the command, leaving the terminal thinking that you are going to type more, then close it with closing quote mark.

    The outputs look solid, did you have a working connection? If not, I'd blame that weird gateway.
    Why do you have a gateway that is different than your network subnet? Is that intentional or a mistake?
    Is the IP automatically acquired from dhcp or is manually configured in Network Manager?

    Quote Originally Posted by TheFu View Post
    BTW, I don't have school pressures (haven't in years)
    However it goes, at least the exam made me feel younger
    Last edited by varunendra; June 6th, 2014 at 02:06 PM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  8. #18
    Join Date
    Jun 2014
    Beans
    10

    Re: Wired Network Not Working

    Sorry its taken me so long to reply guys, got way to busy to work on this over the weekend.

    Quote Originally Posted by TheFu View Post
    So it broke after a reboot?
    Did you apply the ethtool command again - the one with all the options to slow the connection down?
    If you add that 1 line to your /etc/rc.local file, it will happen at every reboot. If your router or switch are 10/100 and not gigE, I'd stop there and call this solved.

    If you want to go further, swap the cable for a known-good CAT5e cable.
    Try a different port on the device (switch/router).
    Read up on the other options that ethtool and the driver used support - that reading should lead to different options that might make it work with your specific switch/router - or at least known incompatibilities.

    If it doesn't, I'd start suspecting a failed gate inside the network chip. 1 small failure that can be worked around is a warning that something else will fail. Time to look for mitigation strategies, like getting a replacement NIC.

    Does this make sense? BTW, I don't have school pressures (haven't in years), just life gets in the way sometimes.
    Yeh after I apply the command again ethernet connects, just never loads anything. Ill have a read now, actually got time for once aha. Yeh that makes sense.

    Quote Originally Posted by varunendra View Post
    The outputs look solid, did you have a working connection? If not, I'd blame that weird gateway.
    Why do you have a gateway that is different than your network subnet? Is that intentional or a mistake?
    Is the IP automatically acquired from dhcp or is manually configured in Network Manager?
    IP address should be automatically aquired, I made some changes based on what id read in other posts before I made my post, I thought id reversed all changes but I might have missed something. It says ethernet is connected but I cant load anything, doesnt time out though which I thought would normally happen if I had no connection. Ill have a look see if I can fix that gateway thing but any tips would be helpful

    Also here is the output of that command corrected.

    egrep -i 'jme|eth|dhclient'

    Code:
    dmesg | egrep -i 'jme|eth|dhclient' 
    [    1.481209] jme: JMicron JMC2XX ethernet driver version 1.0.8 
    [    1.481267] jme 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control 
    [    1.531594] jme 0000:02:00.0 eth0: JMC250 Gigabit Ethernet chiprev:23 pcirev:3 macaddr:bc:ae:c5:5f:2f:d4 
    [   12.384374] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready 
    [   14.165838] type=1400 audit(1402048951.391:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=355 comm="apparmor_parser" 
    [   14.165888] type=1400 audit(1402048951.391:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=355 comm="apparmor_parser" 
    [   14.168072] type=1400 audit(1402048951.395:6): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=355 comm="apparmor_parser" 
    [   14.173275] type=1400 audit(1402048951.399:7): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=355 comm="apparmor_parser" 
    [   15.543365] Bluetooth: BNEP (Ethernet Emulation) ver 1.3 
    [   16.645747] ACPI Error: Method parse/execution failed [\OWLS] (Node ffff88007bf73aa0), AE_NOT_EXIST (20131115/psparse-536) 
    [   16.645771] ACPI Error: Method parse/execution failed [\AMW0.DEVS] (Node ffff88007bf455c8), AE_NOT_EXIST (20131115/psparse-536) 
    [   16.645797] ACPI Error: Method parse/execution failed [\AMW0.WMBC] (Node ffff88007bf45348), AE_NOT_EXIST (20131115/psparse-536) 
    [   19.752849] jme 0000:02:00.0: irq 45 for MSI/MSI-X 
    [   19.752979] jme 0000:02:00.0 eth0: Link is down 
    [   19.776661] jme 0000:02:00.0 eth0: Link is down 
    [   19.776762] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready 
    [   19.778730] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready 
    [   20.762923] type=1400 audit(1402048957.987:14): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/sbin/dhclient" pid=796 comm="apparmor_parser" 
    [   20.762977] type=1400 audit(1402048957.987:16): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=796 comm="apparmor_parser" 
    [232457.959817] jme 0000:02:00.0 eth0: Link is up at Forced: 100 Mbps, Full-Duplex, MDI 
    [232457.961000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

  9. #19
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,601
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wired Network Not Working

    Please let us know if you're still stuck with it. You can set the gateway in the Network Manager settings (nm-applet menu > "Edit Connections..." > edit your connection > "IPv4 Settings" > method "Manual" > fill in the desired settings > Save > Close), or, if using automatic settings, must fix it in the router or whichever device/computer is answering the DHCP requests on the network. For a detailed help, please explain your network in detail.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •