Amongst a bunch of updates I just got - avahi-utils/-daemon and lightdm were nestling furtively amongst them.

That went well ...

Errors were encountered while processing:
avahi-daemon
libnss-mdns:amd64 you can forget that - unless you go wandering around in recovery mode without thinking
lightdm
avahi-utils