Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39

Thread: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

  1. #11
    Join Date
    Nov 2013
    Beans
    10

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    Also great to here of the other devices users have managed to successfully mount following the guide

  2. #12
    Join Date
    Nov 2007
    Beans
    45
    Distro
    Kubuntu 7.10 Gutsy Gibbon

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    Kubuntu 14.04 people who had MTP working on a previous release may find that all they need to do is edit /etc/fuse.conf and uncomment #user_allow_other
    to
    user_allow_other

    Aparently upgrading replaces /etc/fuse.conf...

  3. #13
    Join Date
    Aug 2014
    Beans
    1

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    Quote Originally Posted by jdarby1983 View Post
    Also great to here of the other devices users have managed to successfully mount following the guide
    Thank you for the guide, @jdarby1983. Confirming that this worked for a Sony Z1 Compact [D5503]. The device id is reported as 01a7.

    The device's internal memory and SD card contents are accessible through Nemo on my system as an attached device, in addition to gMTP and Banshee.

  4. #14
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    9,005
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    Quote Originally Posted by ewr2san View Post
    Kubuntu 14.04 people who had MTP working on a previous release may find that all they need to do is edit /etc/fuse.conf and uncomment #user_allow_other
    Thanks! That seems to have fixed my problems.
    If you ask for help, please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  5. #15
    Join Date
    Aug 2014
    Beans
    1

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    Works great for me.

    I'm a new ubuntu user, and this was so helpful.

    Test on ubuntu 14.04 LTS
    Smartphone: Motorola Razr D1

    Thank you !

  6. #16
    Join Date
    Aug 2014
    Beans
    1

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    Thanks for the tutorial, but i cant connect my Samsung Galaxy S4 phone to Ubuntu 14.04 LTE. I have followed your instructions and changed the id of the device and then rebooted from terminal.

    # Samsung Galaxy S4ATTR{idVendor}=="04e8", ATTR{idProduct}=="6860", SYMLINK+="libmtp-%k", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"


    But still cant connect

    Thanks in Advance,


    Peivand

  7. #17
    Join Date
    Mar 2013
    Beans
    2

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    I've tried to configure my android phone, and it has worked momentarily, but then, I've activated the debug mode and mtp has stopped working.
    I've executed lsusb, and I've saw that the idProduct has changed (but not the idVendor). Then, I've tried to reconfigure my android phone with the new idProduct, but it hasn't worked...
    Any idea?

    PD: Sorry for my bad english... (I'm spanish...)

  8. #18
    Join Date
    May 2011
    Beans
    4

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    I had installed Ubuntu 14.04.1 LTS, by doing only Step 3, 4 & 6 is already good enough to hook up my Xperia Z1 Compact, I can access both internal storage as well as SDCard of the phone.

    For Step 3, I think you need to do 2 times. 1 time with USB Debugging Off and 1 time with USB Debugging ON in order to get the 2 different Product ID, then you need to add these 2 ID in Step 4 as 2 seperate lines

    For Step 5, I think this is not related to MTP. Unless you want to use "adb" and "fastboot" with the phone, you may skip this step.

  9. #19
    Join Date
    May 2011
    Beans
    4

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    Quote Originally Posted by serra19 View Post
    I've tried to configure my android phone, and it has worked momentarily, but then, I've activated the debug mode and mtp has stopped working.
    I've executed lsusb, and I've saw that the idProduct has changed (but not the idVendor). Then, I've tried to reconfigure my android phone with the new idProduct, but it hasn't worked...
    Any idea?

    PD: Sorry for my bad english... (I'm spanish...)
    For Step 3, I think you need to do 2 times. 1 time with USB Debugging Off and 1 time with USB Debugging ON in order to get the 2 different Product ID, then you need to add these 2 ID in Step 4 as 2 seperate lines (one Product ID per line).

  10. #20
    Join Date
    Mar 2013
    Beans
    2

    Re: [How-To] Connect an Android device using MTP in Ubuntu 14.04 LTS

    I've tried that, but it doesn't work with USB debugging on...

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •