Results 1 to 8 of 8

Thread: Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

  1. #1
    Join Date
    Aug 2014
    Beans
    2

    Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

    To cut to the chase, my URL is: http://paste.ubuntu.com/8111994/

    I have:
    - disabled Intel Smart Connect and Rapid Start
    - disabled secure boot (I've tried it enabled and disabled)
    - disabled fast startup

    I created a Live USB based on the instructions given here: http://www.everydaylinuxuser.com/201...e-windows.html
    And I've generally followed these two tutorials/posts:
    1. http://askubuntu.com/questions/22183...uefi-supported
    2. http://www.everydaylinuxuser.com/201...e-windows.html

    Help would be greatly appreciated!

  2. #2
    Join Date
    May 2005
    Location
    Staffordshire UK
    Beans
    308
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

    OK. You are trying to install 64 bit Ubuntu and not 32 bit?
    1. There is absolutely no need to disable Intel Smart connect and Rapid Start, or secure boot or fast startup.
    2. Yiou need to create the unallocated space for Ubuntu IN WINDOWS - do NOT use GParted to do this.
    3. You need to install Grub on the EFI partition. To find out what partition that is, when booted from the lice CD/USB, use the Disks utility.

    That worked OK for me.

  3. #3
    Join Date
    Aug 2014
    Beans
    18
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

    I had to disable secure boot and fast startup because of the new UEFI thing. I followed the instructions I found in everydaylinuxuser, but my Ubuntu installer didn't recognize my pre-installed Windows, so I had to follow the steps I found in here before being able to continue with manual partitioning: http://www.linuxbsdos.com/2013/02/26...br-partitions/

    I think it is easier to partition my disk in Ubuntu installer, but it's jut my opinion.

  4. #4
    Join Date
    May 2005
    Location
    Staffordshire UK
    Beans
    308
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

    No, if you use 64 bit 14.04 Ubuntu then you do NOT have to disable UEFI. Trust me.
    Secondly, if you use Gparted to create the space to install Ubuntu you run a great danger of borking your Windows 8 install.
    Thirdly the Ubuntu installer has a bug re pre-installed Windows 8.
    You need to choose the "Other" option on the install screen.
    Last edited by Gordonbp531; August 22nd, 2014 at 01:17 PM.

  5. #5
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    9,623
    Distro
    Ubuntu Development Release

    Re: Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

    That Boot Repair report is out of date. It gives the state of the system before Boot Repair carried out any repairs. Please run Boot repair again. At least to generate a report that describes the situation at present and not what the situation was. For example, the report states that Grub is not installed in the MBR of either sda or sdb but Boot Repair should have re-installed the Grub of sda7 into the MBR of sda. So, there should be changes that are not in the report that you have linked to.

    Also running Boot Repair more than once might fix things. Furthermore, it helps us to imagine what is happening on your machine if you describe what you see when the machine loads. Would I be right in assuming that you can no longer load Windows? You do say that Windows is loading. This is information that Boot Repair does not provide. Not knowing the accurate state of your machine I might give you inaccurate advice.
    Last edited by grahammechanical; August 22nd, 2014 at 01:33 PM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  6. #6
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

    It does show ubuntu folder in the efi partition.

    But HP has modified its UEFI to only boot Windows.
    Most find copying grubx64.efi to /efi/Boot and replacing bootx64.efi and booting hard drive then works.
    Backup efi partition before making any changes.

    The Intel SRT often adds complexity. I have been suggesting turning that off as it is seen as RAID and grub did not install correctly. But now grub still installs. One user said it worked without issue.

    Not sure why you have so many hard drive entries. Ubuntu should boot first but with HP it will not.
    BootOrder: 0000,3004,3000,3002,3003,3005,3006,3007,3008,2001,2002 ,2003
    Boot0001* USB Hard Drive (UEFI) - SanDisk
    Boot0004* Windows Boot Manager
    Boot2001* USB Drive (UEFI)
    Boot3000* Internal Hard Disk or Solid State Disk
    Boot3002* Internal Hard Disk or Solid State Disk
    Boot3003* Internal Hard Disk or Solid State Disk
    Boot3004* Internal Hard Disk or Solid State Disk
    Boot3005* Internal Hard Disk or Solid State Disk
    Boot3006* Internal Hard Disk or Solid State Disk
    Boot3007* Internal Hard Disk or Solid State Disk
    Boot3008* Internal Hard Disk or Solid State Disk
    Boot0000* ubuntu.

    It seems hp firmware do not allow you to boot anything other than windows. Hence no ubuntu option in the UEFI. To work around it
    http://ubuntuforums.org/showthread.php?t=2227889
    1) press esc key while booting to access start up menu 2) press F9 for boot devices menu.
    [SOLVED] Trying to install Ubuntu as dual boot on Windows 8.1 desktop HP500
    http://ubuntuforums.org/showthread.php?t=2218154

    HP Manually renamed files to make it work.
    http://ubuntuforums.org/showthread.php?t=2131886

    a1: Rename /efi/boot/bootx64.efi, copy shim or grub into /efi/boot and name it bootx64.efi Then boot harddrive entry in UEFI menu.

    sudo mount -t vfat /dev/sda2 /mnt
    sudo cp /mnt/EFI/ubuntu/grubx64.efi /mnt/EFI/Boot/bootx64.efi

    Vendors violated UEFI specs - http://hwe.ubuntu.com/docs/ubuntu-bi...quirements.pdf
    Firmware should not enforce any boot policy other than the mechanism specified in Section 3 of the
    UEFI 2.3.1 specification [UEFI 2.3.1]. Specifically, firmware should not modify boot behaviour de-
    pending on the Description field of the EFI_LOAD_OPTION descriptor.
    For more info on UEFI boot install & repair - Updated Oct 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.







  7. #7
    Join Date
    Aug 2014
    Beans
    2

    Re: Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

    That is odd, I reported the webpage that was given to me after running boot repair.

    Either way, I did the boot repair again and here is the new link: http://paste.ubuntu.com/8134379/

    Thanks!

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Trouble Installing Ubuntu 14.04 with Windows 8 (Pre-install)

    You show Intel SRT which caches Windows fast boot into the 32GB SSD. But it looks like you have 8GB of RAM so it only is using 8 of the 32GB.
    Several users have just created a 16GB / (root) partition on SSD to make all of Ubuntu fast not just the fast boot. You might be able to fit all of Windows in 32GB, but they only use part to make booting fast.

    Lots of detail, screenshots and essential info.14.04 Something Else example
    http://www.dedoimedo.com/computers/u...all-guide.html

    Any install with Something Else which is required with external drives or any second drive or any install with separate /home
    Also shows combo box with location of grub2 boot loader
    https://help.ubuntu.com/community/Grub2/Installing
    Does not hightlight changing boot loader to sdb, if external drive, but shows other install screenshots:
    http://askubuntu.com/questions/31278...in-a-dual-boot
    http://askubuntu.com/questions/27437...p-boot-optiond
    Install 14.04 Something Else explanation and screenshots (note boot load to VM, most may install to MBR of drive sda, or sdb)
    http://www.tecmint.com/ubuntu-14-04-installation-guide/

    Older instructions (including mine) may say to remove RAID to get grub to install. Some have posted that with 14.04 grub will install correctly without removing RAID. Not sure if just turning off fast boot or fast boot and Intel SRT while installing or not.

    But you have an HP, so you can only boot Windows without a work around.
    For more info on UEFI boot install & repair - Updated Oct 2015:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.







Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •