Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: ffmpeg Problem

  1. #1
    Join Date
    Oct 2008
    Location
    UK
    Beans
    1,162
    Distro
    Ubuntu 13.04 Raring Ringtail

    ffmpeg Problem

    I'm running 14.04 and wanted to install ffmpeg so I followed this guide - http://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu. Everything appeared to go ok until I got to the Conclusion section and tried to launch ffmpeg. I entered the suggested terminal command and got the following:

    dad@dadubuntu:~$ cd ~/bin && ./ffmpeg -i ~/input.mp4 ~/videos/output.mkv
    ffmpeg version 2.2.git Copyright (c) 2000-2014 the FFmpeg developers
    built on May 24 2014 12:36:38 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
    configuration: --prefix=/home/dad/ffmpeg_build --extra-cflags=-I/home/dad/ffmpeg_build/include --extra-ldflags=-L/home/dad/ffmpeg_build/lib --bindir=/home/dad/bin --extra-libs=-ldl --enable-gpl --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree --enable-x11grab
    libavutil 52. 86.100 / 52. 86.100
    libavcodec 55. 63.100 / 55. 63.100
    libavformat 55. 40.100 / 55. 40.100
    libavdevice 55. 13.101 / 55. 13.101
    libavfilter 4. 5.100 / 4. 5.100
    libswscale 2. 6.100 / 2. 6.100
    libswresample 0. 19.100 / 0. 19.100
    libpostproc 52. 3.100 / 52. 3.100
    /home/dad/input.mp4: No such file or directory
    dad@dadubuntu:~/bin$



    I have tried just entering ffmpeg but I get:

    dad@dadubuntu:~$ ffmpeg
    ffmpeg: command not found


    I am looking to convert a dvd to mp4 and a lot of advice from ubuntu users is to use ffmpeg - I've tried mencoder and arista but 14.04 does not appear to like them. Having gone through http://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu I would like to try ffmpeg but I'm at yet another block. Thanks.

  2. #2
    Join Date
    Aug 2012
    Beans
    Hidden!

    Re: ffmpeg Problem

    Try the command
    Code:
    which ffmpeg
    to see where the ffmpeg binary is located.
    Check that the location given for ffmpeg is in your user path
    Code:
    echo $PATH
    this should give an idea to what is happening.

    Edit: just noted in the link instructions the binary should be in your home "bin" folder.
    Code:
    --bindir="$HOME/bin"
    config option used.

    If the guide created the home bin folder because of that configuration option, bash would not have known where the binary was until after the next log out / in, to set the ~/home/bin folder in your path. This would explain the error of ffmpeg not being found.
    Last edited by coldcritter64; May 24th, 2014 at 02:46 PM.

  3. #3
    Join Date
    Apr 2012
    Beans
    5,611

    Re: ffmpeg Problem

    It's locating and executing the ffmpeg program (in your ~/bin directory) just fine - what it's not finding is the specified ~/input.mp4 file - do you have such a file in your home directory?

  4. #4
    Join Date
    Aug 2012
    Beans
    Hidden!

    Re: ffmpeg Problem

    Quote Originally Posted by steeldriver View Post
    It's locating and executing the ffmpeg program (in your ~/bin directory) just fine - what it's not finding is the specified ~/input.mp4 file - do you have such a file in your home directory?
    Note when he runs the ffmpeg command and gets a not found error
    dad@dadubuntu:~$ ffmpeg
    ffmpeg: command not found
    You are right about the file as well of course. But note the start of the command where the OP is cd'ing into ~/bin. So the ffmpeg binary will be found on the first command given, the OP is in the home directory when trying to run ffmpeg the second time, edit: following the guide will need a logout to set the bin folder in the path if it is being created by following the guide.
    cd ~/bin...
    Last edited by coldcritter64; May 24th, 2014 at 03:26 PM. Reason: added "directory"

  5. #5
    Join Date
    Apr 2012
    Beans
    5,611

    Re: ffmpeg Problem

    The OP will get 'ffmpeg: command not found' when running it without an explicit path, unless/until $HOME/bin is added to their path

    By default, $HOME/bin is added to PATH on login by the .profile file if it exists - i.e. if the OP only just created a ~/bin 9as part of the ffmpeg install process) it won't appear in their path until next login

  6. #6
    Join Date
    Oct 2008
    Location
    UK
    Beans
    1,162
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: ffmpeg Problem

    Thank you for your replies. I'm still not sure whether ffmpeg is installed or not - I think it is. I tried to install a gui called sinthgunt via the software centre and it says Dependency is not satisfiable: ffmpeg. The output of the various commands is:

    dad@dadubuntu:~$ which ffmpeg
    /home/dad/bin/ffmpeg
    dad@dadubuntu:~$ echo $PATH
    /home/dad/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
    dad@dadubuntu:~$ --bindir="$HOME/bin"
    bash: --bindir=/home/dad/bin: No such file or directory
    dad@dadubuntu:~$ ffmpeg
    ffmpeg version 2.2.git Copyright (c) 2000-2014 the FFmpeg developers
    built on May 24 2014 12:36:38 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
    configuration: --prefix=/home/dad/ffmpeg_build --extra-cflags=-I/home/dad/ffmpeg_build/include --extra-ldflags=-L/home/dad/ffmpeg_build/lib --bindir=/home/dad/bin --extra-libs=-ldl --enable-gpl --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree --enable-x11grab
    libavutil 52. 86.100 / 52. 86.100
    libavcodec 55. 63.100 / 55. 63.100
    libavformat 55. 40.100 / 55. 40.100
    libavdevice 55. 13.101 / 55. 13.101
    libavfilter 4. 5.100 / 4. 5.100
    libswscale 2. 6.100 / 2. 6.100
    libswresample 0. 19.100 / 0. 19.100
    libpostproc 52. 3.100 / 52. 3.100
    Hyper fast Audio and Video encoder
    usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

    Use -h to get full help or, even better, run 'man ffmpeg'


    note: I do not have that file in /home. Can I just create it as an empty text file - I assumed it would have been created as part of all those install instructions.

  7. #7
    Join Date
    Aug 2012
    Beans
    Hidden!

    Re: ffmpeg Problem

    edit: Yes you have ffmpeg installed in your home bin folder, it is now in your path as it works from the home folder from those results

    note: I do not have that file in /home. Can I just create it as an empty text file - I assumed it would have been created as part of all those install instructions.
    That "file" as such is an example format; you replace the path and filename to an actual video file of yours you want converted, same with output mkv file ... where you are saving it to, an example of usage for you to alter as needed.
    Last edited by coldcritter64; May 24th, 2014 at 04:20 PM.

  8. #8
    Join Date
    Sep 2006
    Beans
    3,532

    Re: ffmpeg Problem

    Why ~/bin?
    The guide installs ffmpeg to ~/bin because:

    • it avoids conflicts with repository packages
    • it is non-destructive and avoids messing with the system (useful for users with no sudo privileges, like some server users)
    • it avoids the complexity of the package management system
    • removal is simple


    Adding ~/bin to your PATH
    The Persistent Environment Variables section of the guide has the following instructions:
    Code:
    echo "MANPATH_MAP $HOME/bin $HOME/ffmpeg_build/share/man" >> ~/.manpath
    . ~/.profile
    The first line allows you to use "man ffmpeg" to get the associated man pages for your new ffmpeg. The second line sources ~/.profile which should immediately add ~/bin to your PATH, meaning that when you run "ffmpeg" in the terminal it will use ~/bin/ffmpeg (instead of the old, fake, crappy repository version for Ubuntu releases older than 14.04). However, now that I wrote that I now notice that in post #6 that ~/bin is now in your PATH, so it looks like you already did this.

    Sinthgunt, even if it did recognize it, may not work with your new ffmpeg. FFmpeg development is very active, and these GUIs tend to age quickly. You can try using ffmpeg directly. If you have any questions you can ask them here.

  9. #9
    Join Date
    Feb 2008
    Beans
    4,300
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: ffmpeg Problem

    I'm puzzled why you didn't just install ffmpeg from the repositories, using software manager, Synaptic or apt-get install.

  10. #10
    Join Date
    Aug 2013
    Beans
    2,135

    Re: ffmpeg Problem

    Quote Originally Posted by gordintoronto View Post
    I'm puzzled why you didn't just install ffmpeg from the repositories, using software manager, Synaptic or apt-get install.
    Because 1) the version in the repository is not real ffmpeg. It is a fork called avconv. If you install from the repository and type ffmpeg in the terminal it will say something like 'ffmpeg is deprecated.. " 2) There is no more ffmpeg package in the repository in 14.04 (that being the case may be the concern about conflicting with system 'ffmpeg' no longer applies?)

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •