Results 1 to 9 of 9

Thread: Can't change my English keyboard layout after Lubuntu 14.04 install

  1. #1
    Join Date
    Feb 2010
    Location
    Devon, UK
    Beans
    89
    Distro
    Lubuntu 14.04 Trusty Tahr

    Question Can't change my English keyboard layout after Lubuntu 14.04 install

    Since a new Lutuntu install, I can't get back to whatever my English keyboard layout was before. I wanted to type something using the Unicode Hex code, but when I release Shift/Ctrl although the u remains underscored, the hex keys are not activated. So when I type u2665, ( it's a little heart symbol ) all I get is u"^^% even before I release the other keys. My shift key is obviously working, and ctrl also works for shortcuts. So what's going on? Is there some way to change layouts via the terminal?
    Last edited by cheapodonuts; May 7th, 2014 at 08:19 PM.
    Permanent noob

    Just give me the donuts!!

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    6,788
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't change my English keyboard layout after Lubuntu 14.04 install

    cheapodonuts; Hi !


    See if these help at all.
    Maybe take a look at :
    Code:
    cat /etc/default/keyboard
    and change the default language ?
    In my case the default:
    XKBLAYOUT="us"
    is for the United States 'us'.

    Also one might play about with 'setxkbmap'.
    For example:
    Code:
    setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ar
    It's for Arabic, English- US switching using both Alt+Shift .
    Another:
    Code:
    setxkbmap -option grp:ctrl_shift_toggle "us,il"
    I used Ctrl_Shift and not Alt_Shift, because the latter was set too, and switched keyboard layouts not to interfere .

    Off hand I do not know what the code is for the United Kingdom English ( en ??).
    Once you find what works for you one can make it permanent by editing:
    Copy the command at the end of your /home/user/.bashrc file. The file is hidden by default.
    Code:
    # .bashrc
    
    # Source global definitions
    if [ -f /etc/bashrc ]; then
        . /etc/bashrc
    fi
    
    # User specific aliases and functions
    
    setxkbmap -layout "jp,ch(fr)" -option "grp:alt_shift_toggle"
    as an example.
    Log-out/in for the change to take effect.

    maybe yes
    maybe not so yes
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  3. #3
    Join Date
    Feb 2010
    Location
    Devon, UK
    Beans
    89
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't change my English keyboard layout after Lubuntu 14.04 install

    Well!!! I have it working, but now I don't know if your suggestion has made a difference. I tried the first one, and found that now u underscores with ctrl/shift but I still see the "^^% appearing instead of 2665, but then it all vanishes when I release crl/shift and the typing cursor returns to the start.
    BUT, and it's a big butt , I just tried inputting the numerical elements with the number pad and it worked!! ♥!! And that's with NumLock turned off!! Another big but is that I have re-acquired the ¬ symbol, whatever it is, which was missing till now. (I've been using it on Youtube comments! ;¬) )

    So, thanx for your input Bashing my friend, even though I may not have been as bright as I could have been before the event. My problem is basically solved.

    Have a bunch of donuts!!

    Permanent noob

    Just give me the donuts!!

  4. #4
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    6,788
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't change my English keyboard layout after Lubuntu 14.04 install

    cheapodonuts; Hey,

    Donuts are GooD.

    Keyboards can be peculiar people when talking to the operating system. Sometimes again there is no telling what the operating system will relate back to the monitor.
    Maybe these will help:
    http://forums.bodhilinux.com/index.p...board-layouts/
    http://crunchbanglinux.org/wiki/xev-...om_keybindings

    One might play with the tool 'xev'; to see raw xevents as you press keys.
    terminal command:
    Code:
    xev
    and maybe get an idea of what is not going on.

    And to see the tty default settings:
    Code:
    stty -a
    just about the time I think I know
    I get reminded how
    little I do know
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  5. #5
    Join Date
    Feb 2010
    Location
    Devon, UK
    Beans
    89
    Distro
    Lubuntu 14.04 Trusty Tahr

    Wink Re: Can't change my English keyboard layout after Lubuntu 14.04 install

    Quote Originally Posted by Bashing-om View Post
    cheapodonuts; Hey,

    Donuts are GooD.

    Keyboards can be peculiar people when talking to the operating system.

    just about the time I think I know
    I get reminded how
    little I do know
    Peculiar people? Have you seen my avatar? That's an actual photo of me!! In a suit and tie!!! With a hat! So if my keboard is finally doing what I need, it can be as peculiar as it likes!
    But I'm ok with being a permanent noob. It means I can concentrate on my next donut.
    Permanent noob

    Just give me the donuts!!

  6. #6
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    6,788
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't change my English keyboard layout after Lubuntu 14.04 install

    cheapodonuts; Hey,

    No pictures of me, scares too many folks ! -> long haired, bearded Arkansa(w) ridge runner that I am.

    Anyway, if the situation is now at a satisfactory condition;
    Please mark this thread solved; aides others seeking the solution, helps keep the forum clean and precludes others miss-directing efforts to aid.

    And hey hey, learning this operating system continues a main focus in my life.

    it is
    all a process of learning
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  7. #7
    Join Date
    Feb 2010
    Location
    Devon, UK
    Beans
    89
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't change my English keyboard layout after Lubuntu 14.04 install

    Oh yes, yup yup, solved it in a basic way. Keyboard reset to default.
    Permanent noob

    Just give me the donuts!!

  8. #8
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    6,788
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't change my English keyboard layout after Lubuntu 14.04 install

    cheapodonuts; Humm,

    Why did I not think of that ? maybe a lack of donuts !

    cognitive powers have to come from somewhere
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  9. #9
    Join Date
    Feb 2010
    Location
    Devon, UK
    Beans
    89
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't change my English keyboard layout after Lubuntu 14.04 install

    Cognitive Powers? Can I get that on a disk?
    Permanent noob

    Just give me the donuts!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •