Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Problems with accented vowels

  1. #1
    Join Date
    Mar 2007
    Beans
    41

    Problems with accented vowels

    Hello,

    Last year I installed on my wife's laptop a 2013 version of lubuntu.
    Under configuration first language was Spanish and then English.
    I added a top bar with some icons, one of them was the used language.
    It always displayed "US" despite the real lang was "ES" or "SP" (I don't know if this icon should be used to change the language like other OS, no option but set a country flag, font size...)
    She recently upgrade to 14.04 and the keyword worked sometimes. I fixed that changing kb input method from iBus to None.
    At this time she is able to write Spanish chars like á ó and ñ BUT in Chromium Gmail.
    Strangely the ñ or Ñ work fine but the accent key seems not, no way to write accented vowels.
    Gmail has a menu with some Spanish options aside the configuration wheel.
    I tried changing to other options but it is the same thing.

    Thanks for any help

  2. #2
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Problems with accented vowels

    If you right click on the icon, it brings up the Keyboard Layout Handler Settings. You can choose your keyboard variant there.

    In Chromium, I have to ibus exit to be able to write characters.
    https://bugs.launchpad.net/ubuntu/+s...r/+bug/1307648
    Attached Images Attached Images
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  3. #3
    Join Date
    Mar 2007
    Beans
    41

    Re: Problems with accented vowels

    Thanks bapoumba for your reply
    IMG_1955.jpg
    Both languages are installed, first Spanish, second and last English

    $ ibus exit
    "Cannot connect to ibus"

    Remember I had to switch keyb input from iBus to None to get it work

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Problems with accented vowels

    My first button says "Add" which I believe is yours saying "Anadir". The Spanish keyboard layout is within the S letter range, and not the E, do not ask me why
    You can click on the little arrow to have more options.
    Attached Images Attached Images
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  5. #5
    Join Date
    Mar 2007
    Beans
    41

    Re: Problems with accented vowels

    Yes, Añadir means Add but all this this section of the window was greyed, unable to make changes until... next snapshot.
    Anyway "es" language is already displayed in my previous attachment while "US" is displayed in the top bar.
    Now I've unchecked 'Keep system distribution' and the left side is enabled, so I added "en-us".
    Now "ES" is displayed in top bar.
    But the problem still remains.
    This is strange, on some programs accented vowels are displayed (accent key works) and in others they do not.
    I remember when I installed the previous OS last year (clean install) setup guides me to set the correct keyboard setting.
    Is it possible that this setting was change during recent upgrade? If so, how can I correct this?
    In this snapshot I see Keyboard model pc105. I don't know if it would be useful to change that.
    IMG_1955.jpg

  6. #6
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Problems with accented vowels

    Quote Originally Posted by marciano#1 View Post
    This is strange, on some programs accented vowels are displayed (accent key works) and in others they do not.
    Now that can be the font you are using.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  7. #7
    Join Date
    Mar 2007
    Beans
    41

    Re: Problems with accented vowels

    Common fonts are used like Sans-serif, Verdana all without problems with accented vowels.
    I insist, can this be a keyb config issue?
    Merci

  8. #8
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Problems with accented vowels

    Yes, that can be. All I can find around (because I've already used all I had to go through to set up my own French keyboard that was stuck on a US layout) are older threads that invoke lxkeymap. It's not installed by default here, and not sure how it could fuss around with other config files. I'll have a deeper look.

    I tried changing my own French layout for one with no dead keys and see what it would do, but my session froze and I had to reboot, nothing would allow me back either on a working desktop or to log back in again.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  9. #9
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Problems with accented vowels

    I have been looking around and crashed my session several times trying out things

    Here are some links that may help you, although all I did to set up the compose key failed and completely froze my desktop. Had to reboot from one of the virtual terminals as restarting LightDM brought me to a very funny desktop with funny and unusable panel.

    http://rlog.rgtti.com/2014/05/01/how...yout-in-linux/
    http://ubuntuforums.org/showthread.php?t=2207779 < this one crashed me
    https://help.ubuntu.com/community/ComposeKey < this one too

    I used to use the compose key, had not set it yet, and wanted to have it back anyway.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  10. #10
    Join Date
    Mar 2007
    Beans
    41

    Re: Problems with accented vowels

    Thanks for your time, I appreciate this.

    The file to be edited does not exist in my system http://rlog.rgtti.com/2014/05/01/how...yout-in-linux/

    I was thinking about the problem happens in some apps. LibreOffice display well accented vowles.

    So I installed Firefox (problems with Java here, I'll have to dig on it) and voilà! Facebook and gmail accept all Spanish chars.

    The problem is with Chromium and this lubuntu upgrade 14.04.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •