Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Openbox session issues in Lubuntu 14.04

  1. #1
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,347
    Distro
    Lubuntu 14.04 Trusty Tahr

    Openbox session issues in Lubuntu 14.04

    I was quite happy logging into "Openbox" instead of Lubuntu when on 13.10. But now, in 14.04, I finding something odd.

    Although everything works "normally", my ~/.xsession-errors picks up quite a few errors. If I run the default Lubuntu session, the only entry I see is:
    Script for ibus started at run_im.
    and ~/.xsession-errors.old has
    Script for ibus started at run_im.
    init: lxsession main process (3519) terminated with status 1
    init: Disconnected from notified D-Bus bus
    In an Openbox session most programs I run seem to be adding entries to ~/.xsession-errors even though the programs seem to function just fine.

    Can some kind soul with Lubuntu 14.04 please run an Openbox session for a while and see if ~/.xsession-errors gets more entries relative to the Lubuntu session?
    de gustibus et coloribus non est disputandum -- Wiktionary

  2. #2
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Openbox session issues in Lubuntu 14.04

    @vasa : I'll look into it tonight. I have no pure openbox session here as far as I can tell, will set up one. I've wanted to try that out in a while.
    To note, I have to exit ibus in lubuntu 14.04 for Chromium to work.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  3. #3
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,347
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Openbox session issues in Lubuntu 14.04

    Quote Originally Posted by bapoumba View Post
    @vasa : I'll look into it tonight. I have no pure openbox session here as far as I can tell, will set up one. I've wanted to try that out in a while.
    To note, I have to exit ibus in lubuntu 14.04 for Chromium to work.
    Thank you I'll look forward to your findings.

    Yes, turning off ibus is needed to enter text in Chromium:
    https://lists.ubuntu.com/archives/lu...il/007293.html
    and
    https://bugs.launchpad.net/ubuntu/+s...r/+bug/1307648

    But Chrome 34 doesn't have the problem.
    de gustibus et coloribus non est disputandum -- Wiktionary

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Openbox session issues in Lubuntu 14.04

    http://ubuntuforums.org/showthread.php?t=2173126
    I had bookmarked this thread. Any other link that I may need ?
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  5. #5
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Openbox session issues in Lubuntu 14.04

    Sorry to bump, I could not resist and had a look. I can indeed choose the openbox session when I log in. Will need further investigations as I am stuck with a querty keyboard when I'm using azerty here. Will try the language settings from the LightDM screen, but I do want my system in English with a French keyboard. Need to go to work for now
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  6. #6
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,347
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Openbox session issues in Lubuntu 14.04

    Quote Originally Posted by bapoumba View Post
    http://ubuntuforums.org/showthread.php?t=2173126
    I had bookmarked this thread. Any other link that I may need ?
    That thread has other links scattered about and also points to stinkeye's help in sorting out Openbox's right-click menu.
    de gustibus et coloribus non est disputandum -- Wiktionary

  7. #7
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,347
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Openbox session issues in Lubuntu 14.04

    Quote Originally Posted by vasa1 View Post
    ...
    In an Openbox session most programs I run seem to be adding entries to ~/.xsession-errors even though the programs seem to function just fine.

    Can some kind soul with Lubuntu 14.04 please run an Openbox session for a while and see if ~/.xsession-errors gets more entries relative to the Lubuntu session?
    Many of the errors/warnings/messages have this format:
    Code:
    (program_name:PID): GLib-CRITICAL **: Source ID nnn was not found when attempting to remove it
    and this seems to be some sort of upstream GNOME issue: https://bugs.launchpad.net/ubuntu/+s...r/+bug/1264368

    I don't know why these aren't seen in a Lubuntu session if they are of a general nature.
    de gustibus et coloribus non est disputandum -- Wiktionary

  8. #8
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Openbox session issues in Lubuntu 14.04

    Logged in from openbox. Not easy with the wrong keyboard setting, in particular for the password
    My current file :
    Code:
    cat .xsession-errors
    Script for ibus started at run_im.
    Unable to create /home/bapoumba/.dbus/session-bus
    Script for ibus started at run_im.
    nm-applet-Message: using fallback from indicator to GtkStatusIcon
    QGtkStyle was unable to detect the current GTK+ theme.
    
    (x-terminal-emulator:1646): Gtk-WARNING **: Unknown property: GtkTable.valign
    
    (x-terminal-emulator:1646): Gtk-WARNING **: Unknown property: GtkTable.valign
    
    (x-terminal-emulator:1646): Gtk-WARNING **: Unknown property: GtkTable.valign
    
    (process:1666): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
    I suppose the nm-applet error comes from me auto-starting it in lubuntu.

    Edit : I could sort out the keyboard layout "detail", ouf
    Last edited by bapoumba; May 5th, 2014 at 05:23 PM.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  9. #9
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    6,347
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Openbox session issues in Lubuntu 14.04

    Code:
    (process:1666): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
    is known to come from Firefox.

    Did you get any error associated with PCManFM?
    I get
    Code:
    ** (pcmanfm:6198): WARNING **: modules directory is not accessible
    only in the Openbox session.
    de gustibus et coloribus non est disputandum -- Wiktionary

  10. #10
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu 14.10 Utopic Unicorn

    Re: Openbox session issues in Lubuntu 14.04

    Quote Originally Posted by vasa1 View Post
    Code:
    (process:1666): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
    is known to come from Firefox.

    Did you get any error associated with PCManFM?
    I get
    Code:
    ** (pcmanfm:6198): WARNING **: modules directory is not accessible
    only in the Openbox session.
    Yes, still logged in the Openbox session :
    Code:
    ** (pcmanfm:3347): WARNING **: modules directory is not accessible
    I'm using it from the lxpanel.

    Edit :
    http://sourceforge.net/p/pcmanfm/bugs/831/
    Looks there is a fix from 4 days ago.
    And here of course http://ubuntuforums.org/showthread.php?t=2217698
    Last edited by bapoumba; May 5th, 2014 at 06:07 PM.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •