Results 1 to 6 of 6

Thread: nouveau VDPAU support in Trusty

  1. #1
    Join Date
    Nov 2006
    Beans
    24

    nouveau VDPAU support in Trusty

    I have GeForce 8300 and as far as I can read this page:

    http://nouveau.freedesktop.org/wiki/VideoAcceleration/

    some VDPAU decoding acceleration should be supported by the nouveau drivers for my card.

    I have been testing and I haven't been able to make it work. Is there something that needs to be done on Trusty to enable those features?

  2. #2
    Join Date
    May 2012
    Beans
    64

    Re: nouveau VDPAU support in Trusty

    Install the restricted drivers. Its worth it.

    I have an old nvidia geforce gt610. with the right restricted drivers i get vpdau showing up in nvidia settings and i assume its being used in xbmc as the vdpau setting is enabled and not causing issues.

    unless your card is not supported yet i wouldnt think the open source driver would for that level of hardware acceleration.

    opensource driver is always behind the propriety driver. If your card is supported, id install the propriety driver

  3. #3
    Join Date
    Jun 2007
    Beans
    11,620

    Re: nouveau VDPAU support in Trusty

    You have to extract the blob's firmware (it worked for me on an 8400GS): http://nouveau.freedesktop.org/wiki/VideoAcceleration/

    Just copy/paste the commands because you need to use version 325.15 for that extraction script to work.

  4. #4
    Join Date
    Jan 2005
    Beans
    137
    Distro
    Ubuntu Karmic Koala (testing)

    Re: nouveau VDPAU support in Trusty

    I am also having issues getting VDPAU to work using the nouveau driver. I have a laptop with a GF119M chipset, which falls under the VP5 category according to the nouveau page. After installing libvdpau1, mesa-vdpau-drivers and nouveau-firmware packages vdpauinfo recognized the card, but does not show any decoder capabilities.

    After searching I found that there is a bug in the mesa driver for this particular class of cards: https://bugs.freedesktop.org/show_bug.cgi?id=77102, so I downloaded the source for the mesa vdpau driver and applied the patch. After rebuilding initramfs and rebooting I can confirm there are no error messages in the kernel log about loading the device firmware, though no decoder capabilities show up still.

    I'm at a loss now, I have no idea why it would not report any decoder capabilities.

  5. #5
    Join Date
    Jun 2007
    Beans
    11,620

    Re: nouveau VDPAU support in Trusty

    Quote Originally Posted by martijntje View Post
    nouveau-firmware package
    That's not the only firmware you need. Follow the directions in my previous post.

  6. #6
    Join Date
    Jan 2005
    Beans
    137
    Distro
    Ubuntu Karmic Koala (testing)

    Re: nouveau VDPAU support in Trusty

    Aha! Silly me assumed that the nouveau-firmware package would install the necessary firmware. Extracting and copying the firmware files from the nvidia driver does work and vdpauinfo reports the necessary decoder capabilities now.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •