Results 1 to 6 of 6

Thread: Python 2.7.4 to python 2.7.5

  1. #1
    Join Date
    May 2014
    Beans
    0

    Python 2.7.4 to python 2.7.5

    I've been struggling for about 24 hours to resolve this issue.

    I've noticed doing extensive research on google most answers equate to "Why do you need 2.7.5?" which is kind of insulting.

    For specific reasons I believe this is absolutely what I need.

    I am trying to set up altcointip, and after using 2.6 2.7.4 and 3.0 sources for python I have seen the only difference I have is they built the software using 2.7.5 and it is giving nonsensical errors that don't really describe the error. It is a hefty application so all I want to know how is to safely upgrade. I am apparently lost at this point and requiring help.

    I basically need a step by step guide on how to safely upgrade to 2.7.5.

    My error simple comes down to

    ERROR:cointipbot:CointipBot::main(): traceback: Traceback (most recent call last):
    File "cointipbot.py", line 556, in main
    self.check_inbox()
    File "cointipbot.py", line 232, in check_inbox
    action = ctb_action.eval_comment(m, self)
    File "ctb/ctb_action.py", line 1071, in eval_comment
    rg = re.compile(r.regex, re.IGNORECASE|re.DOTALL)
    File "/usr/lib/python2.7/re.py", line 190, in compile
    return _compile(pattern, flags)
    File "/usr/lib/python2.7/re.py", line 238, in _compile
    raise TypeError, "first argument must be string or compiled pattern"
    TypeError: first argument must be string or compiled pattern


    Now if you are to help or give an answer let's assume I know nothing. Exact files, exact lines, and exact steps without anything missing I need. This needs to be fixed ASAP and after roughly 30 hours of reconfiguring, making edits and additional stuff I am at a road block.

  2. #2
    Join Date
    May 2014
    Beans
    0

    Re: Python 2.7.4 to python 2.7.5

    Also if it matters I am using virtualbox and ubuntu 13.04.

  3. #3
    Join Date
    May 2014
    Beans
    0

    Re: Python 2.7.4 to python 2.7.5

    Also upon second thought maybe it's not 2.7.5. I just tried everything and I am not completely incompetent. I just... Hit a roadblock. Sometimes the serice worked on 2.7.3 but crashed at specific actions, 2.7.4 doesn't run it at all, and when it comes to looking it up, they built it on 2.7.5. So this leads me to believe there is some function, call or anything that relies on stuff in 2.7.5.

  4. #4
    Join Date
    May 2014
    Beans
    0

    Re: Python 2.7.4 to python 2.7.5

    Bounty: 10,000,000 flappycoins.

    I am willing to add a competent individual to skype or other service who can directly even change or make the correct additions I need.

    http://www.reddit.com/r/flappycoin/c...m_some_love_d/

    I was fairly sure it was working, and on 2.7.3 it worked more then any other version. At this point though... I just need it working. Sorry for asking for this type of help, we will pay you for your services and help. I can even allow SSH services temporarily to fix specific files or adjust whats needed. Even if it "Just works" for the meantime until we can personally fix it.

    I myself am working on development for a new wallet version and organizing and after not sleeping for 50-60 hours beginning to think it's either me, something i'm missing or a simple edit.
    Last edited by cizuzj; May 2nd, 2014 at 10:16 AM.

  5. #5
    Join Date
    May 2014
    Beans
    0

    TipBot Python 2.7.4 to 2.7.5 or additional help. Paid for services.

    I've been struggling for about 24 hours to resolve this issue.

    I've noticed doing extensive research on google most answers equate to "Why do you need 2.7.5?" which is kind of insulting.

    For specific reasons I believe this is absolutely what I need.

    I am trying to set up altcointip, and after using 2.6 2.7.4 and 3.0 sources for python I have seen the only difference I have is they built the software using 2.7.5 and it is giving nonsensical errors that don't really describe the error. It is a hefty application so all I want to know how is to safely upgrade. I am apparently lost at this point and requiring help.

    I basically need a step by step guide on how to safely upgrade to 2.7.5.

    My error simple comes down to

    ERROR:cointipbot:CointipBot::main(): traceback: Traceback (most recent call last):
    File "cointipbot.py", line 556, in main
    self.check_inbox()
    File "cointipbot.py", line 232, in check_inbox
    action = ctb_action.eval_comment(m, self)
    File "ctb/ctb_action.py", line 1071, in eval_comment
    rg = re.compile(r.regex, re.IGNORECASE|re.DOTALL)
    File "/usr/lib/python2.7/re.py", line 190, in compile
    return _compile(pattern, flags)
    File "/usr/lib/python2.7/re.py", line 238, in _compile
    raise TypeError, "first argument must be string or compiled pattern"
    TypeError: first argument must be string or compiled pattern


    Now if you are to help or give an answer let's assume I know nothing. Exact files, exact lines, and exact steps without anything missing I need. This needs to be fixed ASAP and after roughly 30 hours of reconfiguring, making edits and additional stuff I am at a road block.

    Bounty: 10,000,000 flappycoins.

    I am willing to add a competent individual to skype or other service who can directly even change or make the correct additions I need.

    http://www.reddit.com/r/flappycoin/c...m_some_love_d/

    I was fairly sure it was working, and on 2.7.3 it worked more then any other version. At this point though... I just need it working. Sorry for asking for this type of help, we will pay you for your services and help. I can even allow SSH services temporarily to fix specific files or adjust whats needed. Even if it "Just works" for the meantime until we can personally fix it.

    I myself am working on development for a new wallet version and organizing and after not sleeping for 50-60 hours beginning to think it's either me, something i'm missing or a simple edit.

  6. #6
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Python 2.7.4 to python 2.7.5

    Threads merged and moved to the Market.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •