Results 1 to 6 of 6

Thread: do-release-upgrade gives a warning

  1. #1
    Join Date
    Apr 2014
    Beans
    6

    do-release-upgrade gives a warning

    So the upgrade to 14.04 is finally done. It crashed, it hung, the kernel went in limbo, dpkg became corrupted. But in the end, I'm the one who fixed it all. Great.

    One last (hopefully) thing:

    Code:
    $ do-release-upgrade
    Checking for a new Ubuntu release
    Ignoring unknown parameter "announce version"
    No new release found
    Why do I get that warning/error? I'm not getting it on my other servers...
    Should I be worried about this warning? I guess I should, since I'm not getting it on other servers, but for now I'm noticing any other weird behaviour just yet...

  2. #2
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: do-release-upgrade gives a warning

    Make sure you are on trusty and all up to date:
    Code:
    cat /etc/apt/sources.list
    sudo apt-get update
    sudo apt-get upgrade
    In that case, if you are on trusty up to date, unless you force the upgrade to the development version 14.10, there is no new release.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  3. #3
    Join Date
    Apr 2014
    Beans
    6

    Re: do-release-upgrade gives a warning

    I can't find any lines in sources.list with anything other than trusty.

    I just noticed, `apt-get update` also produces this warning:
    Code:
    $ sudo apt-get update
    0% [Working]Ignoring unknown parameter "announce version"
    Ignoring unknown parameter "announce version"
    Ign http://us.archive.ubuntu.com trusty InRelease
    Ign http://security.ubuntu.com trusty-security InRelease
    ...
    What could it mean?

    /edit
    Ooh, even ssh'ing to another server gives this warning:
    Code:
    $ ssh andromeda
    Ignoring unknown parameter "announce version"
    martijn@andromeda's password:
    Is there some sort of generic system component that's being called and produces (or is capable of producing) this warning?
    Last edited by m3rtijn; May 1st, 2014 at 09:36 AM.

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: do-release-upgrade gives a warning

    All I can find with this error is related to samba :
    https://answers.launchpad.net/ubuntu...uestion/177652
    The solution was to purge samba (including conf files) and reinstall.

    There are other unanswered threads here on the forums.

    Please have a look at this page : https://www.samba.org/~ab/output/htm...mb.conf.5.html
    and search for announce version. Does it ring a bell ? Not sure if the info is still relevant. Looking here https://www.samba.org/~ab/output/ says 2008. There is also this one http://www.ast.cam.ac.uk/~rgm/cirsi/...nnounceversion

    Going here https://www.samba.org/samba/docs/man...mb.conf.5.html from the main samba.org page does not show the same wording.

    Just look for samba announce version in a search engine and see if you find anything helpful.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  5. #5
    Join Date
    Apr 2014
    Beans
    6

    Re: do-release-upgrade gives a warning

    Wow, that's it!

    There was an entry in /etc/samba/smb.conf:
    Code:
    announce version = 6.0
    I don't remember having added that, or I may have plucked it from an example config. In anycase, I removed this line, restarted smbd and nmbd, and the warnings are gone.

    One thing though: why does this warning pop up when executing a command that has absolutely nothing to do with samba? Isn't that strange to say the least?

  6. #6
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: do-release-upgrade gives a warning

    Quote Originally Posted by m3rtijn View Post
    Wow, that's it!

    There was an entry in /etc/samba/smb.conf:
    Code:
    announce version = 6.0
    I don't remember having added that, or I may have plucked it from an example config. In anycase, I removed this line, restarted smbd and nmbd, and the warnings are gone.

    One thing though: why does this warning pop up when executing a command that has absolutely nothing to do with samba? Isn't that strange to say the least?
    Glad to see you got it fixed! Please mark your thread as solved (under Thread Tools), thanks.

    To answer you question, I have no idea, I'm not that familiar with samba and how it interacts with the system, and in particular if it talks to the package managers.
    http://ubuntuforums.org/showthread.p...3#post11184373
    http://oreilly.com/openbook/samba/book/appc_01.html
    https://www.samba.org/samba/docs/usi...-CHP-7-TABLE-4

    May be it was announcing itself in a way the package manager was unable to complete the upgrade due to some conflicts with version numbers ?
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •