Results 1 to 8 of 8

Thread: 14.04 fresh install with wireless button disabled > no wireless now

  1. #1
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    14.04 fresh install with wireless button disabled > no wireless now

    Hello all, I need help

    That was stupid, I know, I fresh installed 14.04 to rearrange my partitions. In the process, I somehow disabled the bluetooth/wireless button (it is a small slider on the laptop front, I must have moved it unintentionally). Now I cannot get my wireless to work. To note, on a previous 14.04 install, it used to work without any intervention from my part (other than the wireless password of course). I've tried to fiddle around and changed my /etc/network/interfaces to what it used to be in ancient times when I had to do it manually, and sudo ifup wlan0 gives
    Code:
    bapoumba@SonyBlue:~$ sudo ifup wlan0 
    ifup: interface wlan0 already configured
    But :
    Code:
    bapoumba@SonyBlue:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr <snip> 
              inet addr:192.168.1.22  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::213:a9ff:fea5:6782/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2784 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2616 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:1610861 (1.6 MB)  TX bytes:375477 (375.4 KB)
              Interrupt:16 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:528 errors:0 dropped:0 overruns:0 frame:0
              TX packets:528 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:41376 (41.3 KB)  TX bytes:41376 (41.3 KB)
    I'm not that network savvy, so attached is the wireless script output. My router is within the reported access points so it sees it. I'm sure I'm not very far from having it working, but I'm kinda stuck for now..

    Thanks much !
    Attached Files Attached Files
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,650
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 14.04 fresh install with wireless button disabled > no wireless now

    Hi bapoumba, according to the information from the script the switch is not off and it is not softblocked either.

    This file:
    Code:
    /etc/network/interfaces
    should only have:
    Code:
    auto lo
    iface lo inet loopback
    if you are using network manager.

    What is the network name you are trying to connect too?
    Please try:
    Code:
    sudo modprobe -rv iwl3945
    sudo modprobe iwl3945 disable_hw_scan=1
    if it connects we will need to make this change permanent so please do not reboot.
    Thanks

  3. #3
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: 14.04 fresh install with wireless button disabled > no wireless now

    Hello Wild Man, and thanks

    After some more reading around, I had reverted back to the previous /etc/network/interface and rebooted. With the other one, booting up would take a long time with messages related to waiting for network access (or similar wording), so I figured it was not working that way.
    Code:
    bapoumba@SonyBlue:~$ cat /etc/network/interfaces
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback
    So to answer your suggestions :

    Code:
    bapoumba@SonyBlue:~$ sudo modprobe -rv iwl3945
    rmmod iwl3945
    rmmod iwlegacy
    rmmod mac80211
    rmmod cfg80211
    bapoumba@SonyBlue:~$ sudo modprobe iwl3945 disable_hw_scan=1
    bapoumba@SonyBlue:~$
    It does not connect.
    From some other reading, I had a look in the bios and there is nothing for wireless there.

    Ethernet works OK, but is not comfortable with a regular size ethernet cable.

    I also had a look here, which looks empty:
    Code:
    cat /proc/net/wireless 
    Inter-| sta-|   Quality        |   Discarded packets               | Missed | WE
     face | tus | link level noise |  nwid  crypt   frag  retry   misc | beacon | 22
    Code:
    sudo iwconfig wlan0 essid "My Router"
    Which gives no error but does not connect either.

    If I manually enter wlan0 in the panel applet and try to configure it from there, it says the interface does not exist.

    Thanks again!

    Edit : the router is <bip>.
    Last edited by bapoumba; May 13th, 2014 at 05:40 PM.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  4. #4
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,650
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 14.04 fresh install with wireless button disabled > no wireless now

    Did you do a fresh install of 14.04? Lubuntu 14.04 has a bug where nm-applet does not show up in the panel does your? You may look here.
    http://askubuntu.com/questions/45159.../451599#451599
    I would use the commands just as written:
    Code:
    sudo modprobe -rv iwl3945
    sudo modprobe iwl3945 disable_hw_scan=1
    if you remove all those modules one at a time you would have to add them back one at a time to make it work.

    In your router change your channel to 1 or 11 you should have less interference and wpa2 is the best encryption with (CCMP) (AES) not TKIP.

    You should set IPV6 to ignore in network manager.

    I recommend removing all networks and rebooting and letting network manager find your network.

    Your device is scanning so it is just a matter of getting it to connect.
    Thanks

  5. #5
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: 14.04 fresh install with wireless button disabled > no wireless now

    It worked after a reboot, logging out and back in was not enough.

    What I did was remove and add back the iwl3945 module as suggested and add the nm-applet in the panel.

    Yes, this is a fresh install. My previous 14.04 was an upgrade from 13.10, that was itself upgraded from 13.04. 13.04 was a fresh install. So the previous 14.04 must have been working from previous installs. I could choose the router from the list and enter the passphrase.
    I have not changed the IPV6 setting, yet, it is set to auto and working.

    I have changed the router to channel 11 and WPA2 (AES). I had set it to TKIP because one of the kids has a 3DS that could not connect to wifi unless it was set up that way. He's not using it much anymore, so I'll see if and when he complains ^^
    To note, I set up my router to filter on MAC addresses and easy pairing (their wording, that's a button you can press to have any device auto connect during 1 minute) disabled.

    Infinite thanks, Wild Man, all my best
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  6. #6
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,650
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 14.04 fresh install with wireless button disabled > no wireless now

    Your very welcome! glad it is working.

  7. #7
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: 14.04 fresh install with wireless button disabled > no wireless now

    Looks like the nm-applet bug got fixed for Utopic : https://bugs.launchpad.net/ubuntu/+s...n/+bug/1308348, comment #50.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  8. #8
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: 14.04 fresh install with wireless button disabled > no wireless now

    Update : installing lxsession0.4.9.2 from the trusty-proposed repositories fixes the issue. nm-applet does show in the panel after I removed it from Prefs > Default Applications for LXSession > Autostart tab after a reboot.

    Procedure to enable the trusty-proposed repos : https://wiki.ubuntu.com/Testing/EnableProposed
    Create /etc/apt/preferences and include :
    Code:
    Package: *
    Pin: release a=trusty-proposed
    Pin-Priority: 400
    Code:
    sudo apt-get update
    bapoumba@SonyBlue:/etc/apt$ sudo apt-get install lxsession/trusty-proposed
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Selected version '0.4.9.2+git20140410-0ubuntu1.1' (Ubuntu:14.04/trusty-proposed [i386]) for 'lxsession'
    Suggested packages:
      lxde-common
    The following packages will be upgraded:
      lxsession
    1 to upgrade, 0 to newly install, 0 to remove and 5 not to upgrade.
    Need to get 86,9 kB of archives.
    After this operation, 6 144 B of additional disk space will be used.
    Get:1 http://archive.ubuntu.com/ubuntu/ trusty-proposed/universe lxsession i386 0.4.9.2+git20140410-0ubuntu1.1 [86,9 kB]
    Fetched 86,9 kB in 0s (258 kB/s)     
    (Reading database ... 189780 files and directories currently installed.)
    Preparing to unpack .../lxsession_0.4.9.2+git20140410-0ubuntu1.1_i386.deb ...
    update-alternatives: using /usr/bin/openbox-session to provide /usr/bin/x-session-manager (x-session-manager) in auto mode
    Unpacking lxsession (0.4.9.2+git20140410-0ubuntu1.1) over (0.4.9.2+git20140410-0ubuntu1) ...
    Setting up lxsession (0.4.9.2+git20140410-0ubuntu1.1) ...
    update-alternatives: renaming x-session-manager.1.gz slave link from /usr/share/man/man1/x-session-manager.1.gz to /usr/share/man/man1/lxsession-manager.1.gz
    update-alternatives: using /usr/bin/lxsession to provide /usr/bin/x-session-manager (x-session-manager) in auto mode
    update-alternatives: warning: skip creation of /usr/share/man/man1/lxsession-manager.1.gz because associated file /usr/share/man/man1/lxsession.1.gz (of link group x-session-manager) doesn't exist
    Code:
    apt-cache policy lxsession
    lxsession:
      Installed: 0.4.9.2+git20140410-0ubuntu1.1
      Candidate: 0.4.9.2+git20140410-0ubuntu1.1
      Version table:
     *** 0.4.9.2+git20140410-0ubuntu1.1 0
            400 http://archive.ubuntu.com/ubuntu/ trusty-proposed/universe i386 Packages
            100 /var/lib/dpkg/status
         0.4.9.2+git20140410-0ubuntu1 0
            500 http://archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •