Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Keyboard layout for Lubuntu 14.04

  1. #1
    Join Date
    Sep 2013
    Beans
    23

    Keyboard layout for Lubuntu 14.04

    I have been running Lubuntu 12.04 for a couple of years on an old IBM ThinkCentre S50. With the LTS release of 14.04, I have upgraded it, hoping that it will give me several more years of life.

    First problem I have is the keyboard layout. I am using a Swiss keyboard and previously with 12.04 it was set for the Swiss French layout with no problems. When I booted into 14.04 the first time, I got the US keyboard layout. I changed it via the Keyboard Layout Handler panel application, but the list of layouts does not include the French (Swiss) layout! At the moment I am using German (Swiss) because that one is the closest I can get to the layout I want. The Swiss French and Swiss German layouts are different even though the same keyboard is used. Is there a reason Swiss French is not included in Lubuntu?

    I also tried installing Lxkeymap which does list Swiss French, but when I click on Apply, it does not change the layout. I still get German characters.

    Can anyone help out there?

  2. #2
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Keyboard layout for Lubuntu 14.04

    I just have one keyboard type and cannot test. Would something here work ? http://ubuntuforums.org/showthread.php?t=1455877
    I've checked my own /etc/default/keyboard, and that looks about right for the French keyboard I use here.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  3. #3
    Join Date
    Sep 2013
    Beans
    23

    Re: Keyboard layout for Lubuntu 14.04

    Thanks for your quick reply. I looked at /etc/default/keyboard and it appears to be correct.

    Code:
    XKBMODEL="pc105"
    XKBLAYOUT="ch"
    XKBVARIANT="fr"
    XKBOPTIONS=""
    CH is Switzerland and FR is the French variant. I also ran the setxkbmap command.

    Code:
    setxkbmap -layout "ch(fr)"
    But I am still locked to the Swiss German keyboard. Is this a bug in LXDE? Something seems to be overwriting the layout (possibly the Keyboard Layout Handler since it does not have CH(FR) in the list).

    EDIT (recent update): I just found under Preferences -> Keyboard Input Method which leads to IBus Preferences dialog box. Under the Advanced tab, there is a checkbox Use system keyboard layout. I checked this, but it still has no effect. Also under Preferences -> Input Method, I get the following message.

    Code:
    Current configuration for the input method:
     * Active configuration: ibus (normally missing)
     * Automatic configuration: ibus (normally ibus or fcitx or uim)
     * Number of valid choices: 2 (normally 1)
    The configuration set by im-config is activated by re-starting X.
    Explicit selection is not required to enable the automatic configuration, if the active one is default/auto/cjkv/missing.
      Available input methods: ibus xim
    Unless you really need them all, please make sure to install only one input method tool.
    Could someone explain to me what this message means?
    Last edited by srope01; April 25th, 2014 at 07:55 AM.

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Keyboard layout for Lubuntu 14.04

    I'll have to look around, but I have the exact same message.

    One stupid idea, would you happen to have another ch keyboard to test ?

    Edit, is an additional reading. In addition, is your locale set to fr_ch ? You can check running locale in a terminal.
    http://forums.linuxmint.com/viewtopic.php?f=175&t=62681

    I'd also try this : http://ubuntuforums.org/showthread.p...3#post10844633
    Back up the current file before editing, just in case, log out and log back in to be effective.
    Last edited by bapoumba; April 25th, 2014 at 08:51 AM.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  5. #5
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Keyboard layout for Lubuntu 14.04

    Quote Originally Posted by srope01 View Post
    I changed it via the Keyboard Layout Handler panel application, but the list of layouts does not include the French (Swiss) layout! At the moment I am using German (Swiss) because that one is the closest I can get to the layout I want.
    Quote Originally Posted by srope01 View Post
    ...possibly the Keyboard Layout Handler since it does not have CH(FR) in the list
    Look harder, it does - right under the one you've found, which happens to be the main layout for Swiss keyboards, "ch".

    Quote Originally Posted by srope01 View Post
    I also tried installing Lxkeymap which does list Swiss French, but when I click on Apply, it does not change the layout. I still get German characters.
    Hmm, that works here too.

    Regards.

  6. #6
    Join Date
    Sep 2013
    Beans
    23

    Re: Keyboard layout for Lubuntu 14.04

    Quote Originally Posted by bapoumba View Post
    One stupid idea, would you happen to have another ch keyboard to test ?
    Yes, I do. Using a more modern Swiss keyboard there is unfortunately no difference.

    Quote Originally Posted by bapoumba View Post
    Edit, is an additional reading. In addition, is your locale set to fr_ch ? You can check running locale in a terminal.
    http://forums.linuxmint.com/viewtopic.php?f=175&t=62681
    I ran locale and it is set to en_GB. But this is what I expect because I am using Swiss computers and keyboards, but my main language is English.


    Quote Originally Posted by bapoumba View Post
    I'd also try this : http://ubuntuforums.org/showthread.p...3#post10844633
    Back up the current file before editing, just in case, log out and log back in to be effective.
    I tried this (XKBLAYOUT="us,ua,ru") which is effectively trying to change the keyboard layout to a US keyboard and setting a toggle. This also has no effect. I still have the Swiss German layout. It seems to me that any change to /etc/default/keyboard is ineffective because all those parameters are being overwritten by something else. It seems that Keyboard Layout Handler has the final master control. But unfortunately, that does not have the Swiss French layout as an option. (see reply below) Is there a way to suppress the Keyboard Layout Handler and force LXDE to just use the X11 file /etc/default/keyboard?

    Quote Originally Posted by Krytarik View Post
    Look harder, it does - right under the one you've found, which happens to be the main layout for Swiss keyboards, "ch".
    But take a look at what it says under Description. This is the German variant of the ch keyboard which gives German umlaut characters instead of French accented characters. I would like the French variant of the ch keyboard. It should have been listed under Layout - ch, Description - French (Switzerland). As a side note, the French keyboard layout (Layout - fr, Description - French) is completely different from the Swiss one.

  7. #7
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Keyboard layout for Lubuntu 14.04

    Quote Originally Posted by srope01 View Post
    But take a look at what it says under Description. This is the German variant of the ch keyboard which gives German umlaut characters instead of French accented characters. I would like the French variant of the ch keyboard. It should have been listed under Layout - ch, Description - French (Switzerland).
    Well, I said "under", not the exact one - hit the arrow symbol in front of it to reveal all the variants of "ch", incl. the "ch(fr)" one.

  8. #8
    Join Date
    Sep 2013
    Beans
    23

    Re: Keyboard layout for Lubuntu 14.04

    Ah yes, thank you. Not obvious because they ordered the flags by languages. The list should have been ordered by country name. As a francophone, I would contest that the French variant would be hidden behind ch-German. But in any case, case solved. Thanks again.

  9. #9
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Keyboard layout for Lubuntu 14.04

    Thanks Krytarik, and thanks srope01 for marking your thread as solved
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |

  10. #10
    Join Date
    Jan 2009
    Location
    Milton Keynes, England
    Beans
    90
    Distro
    Lubuntu 15.04 Vivid Vervet

    Re: Keyboard layout for Lubuntu 14.04

    Hi, changed my /etc/default/keyboard to:

    Code:
    # If you change any of the following variables and X is configured to
    # use this file, then the changes will become visible to X only if udev
    # is restarted.  You may need to reboot the system.
    
    # The following variables describe your keyboard and can have the same
    # values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
    # in /etc/X11/xorg.conf.
    
    XKBMODEL="pc105"
    XKBLAYOUT="gb,us"
    XKBVARIANT=","
    XKBOPTIONS="grp:ctrl_shift_toggle,grp_led:scroll"
    
    # If you don't want to use the XKB layout on the console, you can
    # specify an alternative keymap.  Make sure it will be accessible
    # before /usr is mounted.
    I wanted a UK keyboard but still got an American one on boot up
    Belief is the death of intelligence. As soon as one believes a doctrine of any sort, or assumes certitude, one stops thinking about that aspect of existence." - Robert Anton Wilson
    *Psilocybin is the one drug you have to justify not taking!*

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •