Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Open VPN cannot run ./build-ca

  1. #1
    Join Date
    May 2007
    Beans
    11
    Distro
    Ubuntu 7.04 Feisty Fawn

    Open VPN cannot run ./build-ca

    When I try to run I get the following error:
    Code:
    error on line 198 of /etc/openvpn/easy-rsa/openssl-1.0.0.cnf
    140224783447712:error:0E065068:configuration file routines:STR_COPY:variable has no value:conf_def.c:618:line 198
    line 198 of openssl-1.0.0.cnf reads:
    Code:
    subjectAltName=$ENV::KEY_ALTNAMES

  2. #2
    Join Date
    May 2007
    Beans
    11
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Open VPN cannot run ./build-ca

    I'm a idiot. I just added the following line to the vars file. working correctly now.

    export KEY_ALTNAMES="something"

  3. #3
    Join Date
    May 2014
    Beans
    1

    Re: Open VPN cannot run ./build-ca

    you may call yourself an idiot, but your comment certinaly helped me. Thank you.

  4. #4
    Join Date
    Sep 2013
    Location
    Morgantown,WV
    Beans
    19
    Distro
    Ubuntu

    Re: Open VPN cannot run ./build-ca

    I have the same problem and tried adding exportKEY_ALTNAMES="something" to my VARS file but I am still getting the same error?

  5. #5
    Join Date
    May 2011
    Beans
    1

    Re: Open VPN cannot run ./build-ca

    Quote Originally Posted by Jacob_Tennant View Post
    I have the same problem and tried adding exportKEY_ALTNAMES="something" to my VARS file but I am still getting the same error?

    yep it works. THANKS OP!

    make sure there is a space between export and key in your VARS... unlike your post.

    then rerun:

    source vars
    ./clean-all
    ./build-ca

  6. #6
    Join Date
    Aug 2009
    Beans
    4

    Thumbs up Re: Open VPN cannot run ./build-ca

    This is the first time I have logged in since probably about 2009. I had to login because your post helped me out so much. I have been searching forever for this answer!! And for that I thank you.

  7. #7
    Join Date
    Jun 2014
    Beans
    21

    Re: Open VPN cannot run ./build-ca

    Ditto above comment.

  8. #8
    Join Date
    Sep 2014
    Beans
    1

    Re: Open VPN cannot run ./build-ca

    Quote Originally Posted by dcorwin822 View Post
    I'm a idiot. I just added the following line to the vars file. working correctly now.

    export KEY_ALTNAMES="something"
    Has nobody asked why a clean install of openVPN is broken out of the box? That doesn't seem right.

  9. #9
    Join Date
    Aug 2009
    Location
    Makati City, Philippines
    Beans
    1,831
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Open VPN cannot run ./build-ca

    Quote Originally Posted by darren-hobbs-l View Post
    Has nobody asked why a clean install of openVPN is broken out of the box? That doesn't seem right.
    Haha...now that you pointed it out a fresh install is indeed broken, at least on my experience. I expected things to be configured after the installation that I did not even question the fact that the config is broken on first trial of generating certificates.
    I mean, it doesn't even ship with a default working config.
    You know what solved my problems? GOOGLE Searches!
    The best Ubuntu derivative: Linux Mint
    Relax. Head to the Community Cafe
    The Philippine Team

  10. #10
    Join Date
    Oct 2014
    Beans
    1

    Re: Open VPN cannot run ./build-ca

    On https://help.ubuntu.com/14.04/serverguide/openvpn.html the steps should also be updated to include setting that variable. This thread helped me!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •