Page 1 of 5 123 ... LastLast
Results 1 to 10 of 45

Thread: 14.04: Audacity does not work with FFMpeg anymore

  1. #1
    Join Date
    Aug 2013
    Beans
    25

    14.04: Audacity does not work with FFMpeg anymore

    With 14.04 we have another major problem: Audacity does not import multimedia files other than MP3. It seems it's because Ubuntu package is not compiled with FFMpeg.

    More about the issue:

    http://discourse.ubuntu.com/t/audaci...ssible/1379/15

    http://forum.audacityteam.org/viewto...p?f=48&t=78491

    Dear Canonical, now you are messing with productivity. My company depends on Audacity. Now we are on 12.04 which crashes and freezes way to often and we can't upgrade because we can't process audio files?!?!

  2. #2
    Join Date
    Dec 2006
    Beans
    6,926

    Re: 14.04: Audacity does not work with FFMpeg anymore

    Hmmm.... changelog for audacity:

    Code:
    audacity (2.0.5-1ubuntu3) trusty; urgency=low
    
      * Disable libav support... Ubuntu now ships libav 9.
    
     -- Dmitrijs Ledkovs <xnox@ubuntu.com>  Sun, 10 Nov 2013 20:30:26 +0000
    It would be interesting to see which version of FFmpeg / Libav audacity is happy with, a rebuild should be possible using a locally installed lesser version than Trusty's version...
    Last edited by andrew.46; April 22nd, 2014 at 07:44 AM.
    You think that's air you're breathing now?

  3. #3
    Join Date
    Jun 2007
    Beans
    11,027

    Re: 14.04: Audacity does not work with FFMpeg anymore


  4. #4
    Join Date
    Jun 2007
    Beans
    11,027

    Re: 14.04: Audacity does not work with FFMpeg anymore

    Quote Originally Posted by robi-hipnos View Post
    Dear Canonical, now you are messing with productivity.
    This site/forum is for user to user support. If you want to gripe at "Canonical" or its devs, please find somewhere else to do it.

  5. #5
    Join Date
    Aug 2013
    Beans
    25

    Re: 14.04: Audacity does not work with FFMpeg anymore

    Thanks for bug report. I was trying to find anything usable about this and I see this was reported almost 2 years ago.

    Sorry for the rant, but it was in case somebody from Canonical actually read it

  6. #6
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    5,739
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: 14.04: Audacity does not work with FFMpeg anymore

    Affects only three people!

    Least those of us who can't do more is to click on "Affects me as well"
    de gustibus et coloribus non est disputandum -- Wiktionary

  7. #7
    Join Date
    Mar 2009
    Beans
    294

    Re: 14.04: Audacity does not work with FFMpeg anymore

    Hey robi-hipnos,

    I think this might fix your issue:
    http://www.webupd8.org/2014/04/10-th...ng-ubuntu.html

    Scroll down to "3. Fixes" and look into the first point about H.264 support in Firefox.

  8. #8
    Join Date
    Aug 2013
    Beans
    25

    Re: 14.04: Audacity does not work with FFMpeg anymore

    The Bright Side:
    I have tried that too. The problem is that, audacity package is compiled with ffmpeg support disabled, so it won't work. Will check with audacity daily if it has ffmpeg still enabled.

    Update: Audacity daily does not help
    Last edited by robi-hipnos; April 22nd, 2014 at 02:38 PM.

  9. #9
    Join Date
    Jun 2007
    Beans
    11,027

    Re: 14.04: Audacity does not work with FFMpeg anymore

    You'll have to rebuild Audacity yourself with a local copy of ffmpeg. I'm sure there's a good ffmpeg PPA to grab it from (maybe ask mc4man what ffmpeg he uses for his mpv PPA).

    As for the problem itself, I wouldn't hold my breath that it will get fixed. The Audacity devs don't seem highly concerned with modifying their code for libav and the Debian maintainers don't seem enthusiastic about providing their own patch. Finger-pointing...

  10. #10
    Join Date
    Aug 2013
    Beans
    1,988

    Re: 14.04: Audacity does not work with FFMpeg anymore

    Quote Originally Posted by Temüjin View Post
    You'll have to rebuild Audacity yourself with a local copy of ffmpeg. I'm sure there's a good ffmpeg PPA to grab it from (maybe ask mc4man what ffmpeg he uses for his mpv PPA).
    .
    You need an old ffmpeg for audacity, ppas tend to provide new, more up to date versions. I remember reading in their forums that 0.5 - 0.8 should work, but I can't find the thread now, forgot to bookmark it.

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •