Results 1 to 9 of 9

Thread: message:desktop manager is not active

  1. #1
    Join Date
    Dec 2007
    Location
    green bay, wi
    Beans
    2,189
    Distro
    Lubuntu 14.04 Trusty Tahr

    Lightbulb message:desktop manager is not active

    running 14.04 when i log into any session except lubuntu (eg. gnome,ubuntu,xubuntu) i get the message:desktop manger is not active. any ideas how to correct. tks
    quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

  2. #2
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: message:desktop manager is not active

    No real idea, sorry. All I could find related to 14.04 was this : https://bugs.launchpad.net/variety/+bug/1301651
    Has it always been that way or is this recent ? May be you need to broaden the search to other release and see if you find anything related to events that you might have been doing.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  3. #3
    Join Date
    Dec 2007
    Location
    green bay, wi
    Beans
    2,189
    Distro
    Lubuntu 14.04 Trusty Tahr

    Lightbulb Re: message:desktop manager is not active

    bap tks. i always google first but sometimes i miss. if i google now get link to this thread displayed in search results. will keep on looking.
    quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: message:desktop manager is not active

    You're welcome, although I understand this is not of much help.
    Looked again, found this one which is close to the previous one : https://bugs.launchpad.net/variety/+bug/1296560
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests by PM, thanks |

  5. #5
    Join Date
    May 2009
    Beans
    2

    Re: message:desktop manager is not active

    This just happened to me, hence my finding this thread. Running 14.04 LTS in a Gnome desktop.
    The cause in my case was using the Ubuntu Software Center and noticing a new tweak program called "Desktop Preferences" to "Change desktop wallpapers and behavior of desktop manager". Clicked "install" and went to a different window. While in the other window the "Desktop Manager" error started popping up. It turned out "Desktop Preferences was actually the pcmanfm file manager... Rather mis-labelled thinks I. Uninstalled it and the Desktop Manager error went away.....

  6. #6
    Join Date
    Apr 2014
    Beans
    1

    Re: message:desktop manager is not active

    Problem:
    I login with "Lubuntu" option (during Lubuntu's initial password authentication --> choosing "Lubuntu" in upper right corner's drop down menu). System logs in and:
    "Desktop manager not active!" error message @ startup - was bothering me as well,
    ....so I played with a config file that was mentioned somwhere earlier this thread and that fixed an issue on my Lubuntu14

    Fix:
    "Desktop manager not active!" error message @ startup - DISAPEARED, once I updated my file located at:

    ~/.config/lxsession/Lubuntu/desktop.conf
    (..and restarted the machine afterwords to verify the fix)

    Fix - Suggestions:
    Your desktop.conf file for lxsession should look very similar to mine. Try editing it with vi or something (Only verify first 15 lines or so. Chances are your issue is somwhere within: [window_manager* OR file_manager* OR desktop_manager* ] parameters of desktop.conf. At least it was for me, because i did not modify any other parameters )
    This way you'll get to keep "pcmanfm". (Lubuntu's native file manager), but you'll lose "Desktop Setting" functionality while right-clicking on you desktop (right-click on DESKTOP --> System --> Desktop Setting (I believe that my nVidia driver took controll of that anyway, but I might be wrong. who cares..)

    Fix - Details:
    ...so, in short: Try editing your "desktop.conf" file to match mine.
    Here is mine:
    ...
    user@MACHINE:~/.config/lxsession/Lubuntu$ cat ~/.config/lxsession/Lubuntu/desktop.conf
    [Session]
    windows_manager=openbox
    windows_manager/command=openbox
    windows_manager/session=Lubuntu
    windows_manager/extras=
    panel/command=lxpanel
    panel/session=Lubuntu
    screensaver/command=
    power_manager/command=auto
    file_manager/command=pcmanfm
    file_manager/session=Lubuntu
    file_manager/extras=
    desktop_manager/wallpaper=
    polkit/command=lxpolkit
    network_gui/command=nm-applet
    audio_manager/command=alsamixer
    quit_manager/command=lxsession-logout
    quit_manager/image=/usr/share/lubuntu/images/logout-banner.png
    quit_manager/layout=top
    workspace_manager/command=obconf
    launcher_manager/command=lxpanelctl
    launcher_manager/autostart=true
    terminal_manager/command=x-terminal-emulator
    screenshot_manager/command=scrot
    upgrade_manager/command=update-manager
    clipboard/command=lxclipboard
    composite_manager/command=
    composite_manager/autostart=
    disable_autostart=config-only
    upstart_user_session=false
    webbrowser/command=firefox
    webbrowser/desktop=
    xsettings_manager/command=build-in
    proxy_manager/command=build-in
    keyring/command=ssh-agent
    email/command=sylpheed
    pdf_reader/command=evince
    video_player/command=gnome-mplayer
    audio_player/command=audacious
    images_display/command=gpicview
    text_editor/command=leafpad
    archive/command=file-roller
    calculator/command=galculator
    spreadsheet/command=gnumeric
    bittorent/command=transmission-gtk
    document/command=abiword
    webcam/command=gucview
    burn/command=xfburn
    notes/command=xpad
    disk_utility/command=gnome-disks
    tasks/command=lxtask
    lock_manager/command=lxlock
    file_manager=Lubuntu

    [State]
    laptop_mode=no
    guess_default=true

    [Dbus]
    lxde=true
    gnome=false

    [Keymap]
    mode=system
    model=
    layout=
    variant=
    options=

    [XRandr]
    mode=
    command=

    [Security]
    keyring=no

    [a11y]
    activate=no
    type=

    [Updates]
    activate=true

    [Environment]
    type=lubuntu
    menu_prefix=lxde-

    [GTK]
    sNet/ThemeName=Lubuntu-default
    sNet/IconThemeName=lubuntu
    sGtk/FontName=Ubuntu 11
    iGtk/ToolbarStyle=3
    iGtk/ButtonImages=1
    iGtk/MenuImages=1
    iGtk/CursorThemeSize=18
    iXft/Antialias=1
    iXft/Hinting=1
    sXft/HintStyle=hintslight
    sXft/RGBA=rgb
    sGtk/CursorThemeName=DMZ-White
    sGtk/ColorScheme=
    iGtk/ToolbarIconSize=3
    iNet/EnableEventSounds=1
    iNet/EnableInputFeedbackSounds=1
    iGtk/ColorScheme=

    [Mouse]
    AccFactor=20
    AccThreshold=10
    LeftHanded=0

    [Keyboard]
    Delay=500
    Interval=30
    Beep=1
    user@MACHINE:~/.config/lxsession/Lubuntu$ uname -a
    Linux MACHINE 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
    ...
    Last edited by kondratievkirill; April 23rd, 2014 at 07:43 AM.

  7. #7
    Join Date
    Oct 2010
    Beans
    5

    Re: message:desktop manager is not active

    Thanks, that solved my problem.

    Also, for Lubuntu 14.04 the GUI option "Preferences > Default applications for LXSession" works. It's the item on top.

  8. #8
    Join Date
    Feb 2013
    Beans
    5

    Smile Reinstall pcmanfm

    I may not know what the core problem is, but I can tell how I overcame this problem.

    Originally I am in Lubuntu 14.04 LTS and I noticed that my wallpaper and desktop icons (symbolic links) were missing. I searched online and found the following small solution that worked for a while: from terminal enter:
    pcmanfm --desktop-pref

    I used this for a while but then after a routine update I reboot to encounter "Desktop Preferences not active" Dialog box.
    I run pcmanfm --desktop-pref in Terminal and get the following:
    ** (pcmanfm:2693): WARNING **: terminal lxsession-default-terminal isn't known, consider report it to LibFM developers
    ** (pcmanfm:2693): WARNING **: modules directory is not accessible

    I then reinstalled pcmanfm through synaptic, re-logged in and presto, everything back to normal.


    __________________________________________________ ____
    a@a-NC210-NC110:~$ uname -a
    Linux a-NC210-NC110 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:12 UTC 2014 i686 i686 i686 GNU/Linux
    Last edited by afc888ny; August 4th, 2014 at 12:50 AM.

  9. #9
    Join Date
    Apr 2011
    Location
    Classified
    Beans
    173
    Distro
    Lubuntu

    Re: message:desktop manager is not active

    I had this same problem. I just opened up "Default applications for LXSession", then went to the "Core Applications" tab, then clicked "Reload" next to Desktop Manager. Fixed it instantly.
    CPU: AMD FX 8120 8-Core Black Edition OC'd to 4.3GHz | Motherboard: Gigabyte GA-990FXA-UD3 | Graphics: Gigabyte Radeon HD 6850 WindForce | Memory: 16GB G.SKILL Ripjaw Series DDR3 1600 | Storage: 3TB total

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •