Results 1 to 5 of 5

Thread: Ubuntu Gnome Wi-Fi Hardware disabled

  1. #1
    Join Date
    Jan 2014
    Beans
    9

    Ubuntu Gnome Wi-Fi Hardware disabled

    I just bought a new laptop (Asus X551CA) and installed Ubuntu Gnome 13.10.
    There is a problem with my wifi. Wired connection works fine but for the Wi-Fi it's saying " Hardware disabled".
    I tried to go to the network settings and turning it on manualy but it just jumps back to off state imidiately.

    Oh and if someone knows how to get drivers for the touchpad I would also apreciate it .

    My network controller is qualcomm atheros ar9485

  2. #2
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,563
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Ubuntu Gnome Wi-Fi Hardware disabled

    Code:
    echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus.conf
    and rebooting should do the trick. Check the keys afterwards.

  3. #3
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    6,949
    Distro
    Ubuntu Development Release

    Re: Ubuntu Gnome Wi-Fi Hardware disabled

    It could be that the WiFi (wireless) card in the machine is turned off. I have heard that with some laptops it is possible to turn off wireless to save battery power by a keyboard key combination or that if wireless is turned off in Windows it will also be turned off in Ubuntu and Ubuntu cannot turn it on again.

    When you click the Network icon do you see a list of wireless access points in range? Is Networking and Wireless enabled? You may also need a driver for your wireless adapter. Run the command

    Code:
    rfkill list
    You should see this

    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    If you have even one "yes" then wireless will not work. When software is blocked it could indicate that we have not turned networking on or enabled wireless. It could also indicate that the wireless card needs a driver. When the hardware is blocked it will indicate that the wireless card is turned off, usually by a keyboard combination.

    To install a driver go to System Settings>Software and Updates>Additional Drivers tab and see if a driver for wireless is offered to you.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  4. #4
    Join Date
    Jan 2014
    Beans
    9

    Re: Ubuntu Gnome Wi-Fi Hardware disabled

    grahammechanical

    Code:
    echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus.conf

    and rebooting should do the trick. Check the keys afterwards.


    Thank you. This did it.
    I will report if I have any issues with it.

  5. #5
    Join Date
    Oct 2007
    Beans
    6

    Re: Ubuntu Gnome Wi-Fi Hardware disabled

    Yes, modprobe string is work.
    But found one more trick(bug) for simple users (X551 + Ubuntu 14.04 ).

    If you close/up laptop screen (sleep mode) - WiFi start to work
    Last edited by DJArty; April 19th, 2014 at 11:30 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •